Sound Blaster Audigy - The Definitive Music Creation Guide

SOUND BLASTER AUDIGY
 The definitive music creation guide

introduction

Just a few short years ago, music recording meant a serious investment in studio equipment, but today it’s perfectly possible to make "release quality" recordings on a home PC fitted with a suitable soundcard and running inexpensive music software. The Sound Blaster Audigy card is a state-of-the-art soundcard that give the user access to high-quality audio recording and synthesis and sample playback, and it comes bundled with a complete suite of professional-quality music software that turns a PC into a serious music studio. Musicians at all levels of experience can use the Sound Blaster Audigy system to record their own music, either from scratch, by remixing loops and samples or by combining both approaches. Furthermore, the system is fully expandable, so you can take your music-making skills as far as you want to. Add a MIDI keyboard and a microphone and you have a home studio with the potential to record a hit single.

Of course, to use such powerful equipment effectively and creatively requires guidance, and that’s the purpose of this book. It’s not a substitute for your software manuals but rather an overview of the process of using computers for MIDI sequencing, audio recording and audio editing, as well as for sound synthesis and effects processing. There’s a simple but essential introduction to MIDI and sequencing, a look at digital recording and a comprehensive computer-music glossary. Jargon is avoided wherever possible, with the emphasis being on simple, clear explanations.

In some respects, this book is designed to help you make sense of the various hardware and software manuals that you already have, but it doesn’t stop there. It also explains professional recording techniques and the art of mixing and takes you from initial musical idea to recording your own CD. It’s brimming over with professional recording secrets that you can try for yourself. With your computer and the Sound Blaster Audigy card, you have a wonderful opportunity to make great music and to have fun. Our aim is to help you do just that.

start using this guide

Created and produced by Sanctuary Publishing Ltd. 2001


chapter 1

introduction to
Sound Blaster Audigy

Recording studios were once built around hugely expensive, bulky equipment that required a lot of expertise to maintain and operate, but today release-quality recordings can be made at home using a desktop PC as the heart of the studio. All you need are the musical ideas and some rudimentary musical skills. Today’s computers need to be powerful to meet the needs of multimedia, and because they’re produced in huge numbers they’re much less costly than the traditional hardware studio alternative.

However, that’s not to say that anyone can buy a computer and just start making music. The computer needs to be fitted with a suitable soundcard, such as the Sound Blaster Audigy card, the focus of this book. As well as this, it also needs suitable music software. Sound Blaster Audigy users are fortunate here, as a complete suite of very serious music software comes bundled with the card when you buy either the Sound Blaster Audigy Platinum or Platinum eX package. The more basic Sound Blaster Audigy Player package comes without the Steinberg suite of music software and without the Audigy Drive expansion unit, so it’s assumed that you’ll be using either the Sound Blaster Audigy Platinum or Platinum eX package.

The aim of this introduction is to examine the role of computers in music making, and if this is an area that you haven’t explored before then you may be amazed at what you now have the potential to achieve. In fact, this may be a good place to introduce this book’s mission statement: to familiarise you with the equipment, concepts and procedures necessary to make music using computers.

computers and music

The right combination of computer, software and soundcard gives you the ability to record multiple tracks of audio, just as you would in a professional recording studio running a multitrack tape machine. This not only provides the opportunity to build up a musical composition layer by layer, but it also allows you to mix these layers or tracks in a creative way in order to produce a professional-sounding recording.

But there’s so much more to a computer music studio than simply emulating a multitrack tape recorder. In the early days of recording, everything comprised instruments and voices recorded using microphones, but today we have synthesisers, samplers and drum machines as well. Most musicians will be aware that computers can also be used as MIDI (Musical Instrument Digital Interface) sequencers, and since its introduction in the early ’80s MIDI has completely revolutionised the way in which we make records today.

MIDI

MIDI will be explained in detail later in the book, as a basic understanding of the subject is essential to getting the most out of your computer music system, but I feel that it’s appropriate to touch upon the concept briefly at this point. Using MIDI, musical performances (generally performed via a piano-style electronic keyboard) can be stored in the computer as relatively efficient note data (as opposed to audio data, which takes upwards of 5MB of memory per track per minute, depending on the audio data format). This MIDI data can then be replayed to recreate the original performance, which it does by actually "playing" an external hardware synthesiser, a so-called "native" software synthesiser running on your computer or the synthesiser section of your soundcard in real time (which is rather like a hardware synth on a chip). If this seems hard to grasp, think of MIDI as being the electronic equivalent of the written musical score — it’s simply a set of instructions to the player (in this case, the synthesiser) telling it what notes should be played and when. If you hold a musical score to your ear, you won’t hear any music; it only has meaning when interpreted by a performer. It’s the same with MIDI. MIDI can be recorded into a computer and played back later, but unless there’s a synth or soundcard there to interpret it, there won’t be any music.

Because MIDI files comprise fairly basic instructions, they are vastly smaller than audio files. Indeed, the data transfer rate of MIDI is such that even a modest computer can handle lots of separate MIDI parts without being overtaxed. Furthermore, because MIDI data is only a stream of instructions describing what notes to play and when to play them, you can use the same MIDI data to play back any synthesiser sound you have at your disposal. In traditional terms, this is rather like having a musical score that has been written for guitar but which you then decide to play on the piano. You can switch to any synthesiser sound at any time after recording, you can change the speed of the song without affecting its musical pitch and, as you’ll discover later, you can fix any mistakes that you made while recording.

adding audio

Audio recording on computers started on the more specialised Apple Macintosh platform and later spread to the Windows PC. Many software writers and soundcard manufacturers provide versions of their products for both Macs and PCs, but as PCs are more popular there tends to be more choice on that platform.

The first computer audio programs were aimed at recording and editing stereo audio files. Incoming audio was digitised — either via an external unit or a computer soundcard — and then recorded to a hard drive. In those early days, hard-drive sizes were measured in tens of megabytes rather than in gigabytes, so storage space was very limited and hugely expensive. Also, audio interfaces used to cost more than the computer to which they were connected.

Today, hard-drive space is a very inexpensive commodity, which makes it practical to use computers to record long audio sessions comprising anything from eight to 48 tracks, depending on the system. Also, the audio interface now comes as part of your soundcard, which costs only a small fraction of the price of your computer. Using Sound Blaster Audigy with the included Cubasis VST CE sequencing software, up to 24 audio channels can be recorded and played back.

MIDI/audio integration

The real revolution came about when MIDI sequencing and multitrack audio recording were integrated into the same piece of software and the desktop studio as we know it today was born. A modern sequencer can provide dozens of tracks of MIDI recording, plus all the audio tracks you need, with the actual number of audio tracks being limited mainly by the computing power available and the speed of the hard drive. A fast drive running with a SCSI interface can handle upwards of 32 simultaneous tracks of audio playback, whereas a modern EIDE internal drive (the type that comes with virtually all standard PCs) should be able to handle 16-24 audio tracks without difficulty.

the user interface

All modern music sequencers use a graphical interface so that you can record and edit your music intuitively rather than have to be a mathematical genius. In fact, MIDI information and sections of audio can be cut, copied, divided and moved around as easily as text in a word processor. Why would you want to move audio around? Well, imagine that you’ve written a song but you’ve only managed to sing the chorus well enough on one occasion. No problem. Just copy the good chorus vocal part to all of the other choruses and the job is done. The same applies when you want to edit down a rambling guitar solo or remove a link section that isn’t working out as well as you’d hoped.

Because both audio and MIDI recordings are visible within the same window, you can see exactly which parts are where, allowing you to restructure your song very easily. Figure 1.1 shows both audio and MIDI tracks placed on the main Arrange page of Cubasis VST CE, the sequencer software that comes with your Sound Blaster Audigy card.

Figure 1.1: Audio and MIDI tracks placed on the main Arrange page of a modern sequencer

To get MIDI into or out of a computer, you need to use something called a MIDI interface or one of the MIDI synthesisers that has a direct "to-host" computer connection, such as a serial or USB port. Again, the Creative Labs Sound Blaster Audigy card does its best to make life easy by providing an on-card MIDI interface that lets you connect your computer to your MIDI keyboard by using nothing more than a simple MIDI cable. Unlike the earlier Sound Blaster LIVE card, the joystick/MIDI port has now been replaced by the FireWire port and relocated to an additional daughtercard which connects to the Sound Blaster Audigy card (like with the APS), occupying a separate backplate slot. The eX version does not have this daughterboard, but instead provides the MIDI connector via the external cable, which connects to the external Audigy Drive. The Audigy Drive expansion unit that comes with the Platinum and Platinum eX versions of Sound Blaster Audigy provides an additional MIDI input and output that enables you to access up to 32 external MIDI parts, as well as take advantage of the on-board synthesis capabilities of the card.

Larger MIDI systems — ie those comprising additional hardware MIDI instruments — may require a multiport MIDI interface to overcome MIDI’s maximum channel capacity, whereby a maximum of 16 different musical parts can be transmitted over one MIDI port at one time. However, because Sound Blaster Audigy already provides two sets of MIDI ports, plus up to three "virtual" MIDI ports for accessing its onboard synthesis capabilities, you probably won’t need to think about a separate MIDI interface for a while yet.

Multiport MIDI interfaces are most often supplied as separate hardware boxes rather than included as part of a soundcard, and you can always add one later as your system and your needs evolve. Unlike some soundcards that have pretty rudimentary synth sections, Sound Blaster Audigy uses the latest E-mu synthesiser engine, developed by E-mu systems, one of the world’s foremost synthesiser-design companies and a subsidiary of Creative Labs. Two separate synthesisers are available on the Sound Blaster Audigy card, and the GM (General MIDI) soundset is based on the E-mu Systems’ General MIDI SoundFont bank, although additional banks of SoundFonts may be loaded in to provide limitless sound-generation capability. There’s also a software-based General-MIDI synthesiser that can be used at the same time as the two main synthesisers.

the audio interface

To get audio in or out of a computer requires an audio interface. This is because computers deal with digital information, while most audio equipment — such as microphones, amplifiers and loudspeakers — communicates via analogue signals. The audio interface or soundcard includes analogue-to-digital converters at the input and digital-to-analogue converters at the output in order to allow it to be connected directly to analogue equipment. Virtually all PC soundcards include stereo analogue audio ins and outs, although the sound quality varies considerably between budget models and those used for serious audio work. You’ll find that your Sound Blaster Audigy card is capable of extremely good audio quality — good enough, certainly, to make your own CD-quality recordings.

Although soundcards and audio interfaces for specialist applications are available with multiple inputs and outputs, most computer-based home-studio systems work perfectly well with a stereo input, because it’s unlikely that more than one (or two mono) sound sources will be recorded at once. Multiple inputs are only needed in situations where it’s required to record multiple performers at once to different tracks, for which an audio interface with multiple inputs will be needed.

audio mixing

Software sequencers can handle multiple tracks of audio, but they must also be able to handle the mixing of these tracks into a single stereo audio stream. Even in professional, high-cost studio systems, few soundcards or audio interfaces have as many physical audio outputs as the number of audio tracks that the system can record and play back. Used with Cubasis VST CE, the Sound Blaster Audigy card allows up to two channels of audio to be recorded at once, and the final mix can be fed the card’s six analogue outputs or to a combination of the analogue outputs and the stereo S/PDIF digital output. There are also four high-quality onboard effects included that are capable of producing reverb, chorus and numerous other special effects that can be used to process audio tracks.

Mixing is generally accomplished using the processing power of the host computer, although other solutions are available that use DSP (Digital Signal Processing) cards to do some of the work. (All of the software that comes with Sound Blaster Audigy uses the host computer’s native power or the Sound Blaster Audigy hardware itself, so there’s no need to buy any more hardware to make use of it.)

The mixing capability of a sequencer is limited by the available processing power of the computer, but virtually all current sequencing software provides the ability to mix tracks and to automate (record and play back) any changes in level that may be needed while mixing. A mixer that exists only in software — or some other software equivalent of a real studio device — is said to be virtual, and most virtual mixers include some of the functionality of their big studio counterparts, including the ability to apply equalisation (a fancy word for tone control!) and panning to individual audio tracks.

If you have external hardware synths, an external sound mixer will invariably be needed to combine your computer audio with the sounds from your MIDI synthesisers, but this need not be expensive or complicated. In any event, you can do a lot using the Sound Blaster Audigy card’s own MIDI and audio facilities before you even need to consider adding any external hardware other than a MIDI keyboard; Sound Blaster Audigy synth sounds (including SoundFont playback), native virtual synthesiser sounds and audio tracks can all be mixed so that they appear at the outputs of your soundcard as a finished stereo mix. Sound Blaster Audigy has six outputs to accommodate surround-sound applications, allowing you to produce your own 5.1 surround-sound mixes.

Indeed, you don’t need to send the final audio out of the computer at all. Although Steinberg WaveLab Lite (included in the package and not that unlike the full edition) has no CD-burning feature, by using Creative’s Playcenter 3 you can compile complete albums based on the songs that you’ve created in Cubasis VST CE and then, with the aid of a compatible CD writer, you can burn yourself a professional-quality audio CD.

With WaveLab Lite, you can tidy up the starts and ends of your mixes, adjust the relative levels between tracks, apply EQ where necessary and apply compression to even out excessive changes in level. The finished album can then be recorded onto a CD-R, a cassette, a DAT, a MiniDisc or any other audio format of your choice. You can also create MP3 files for distribution on the Internet by using Creative Playcenter 3.

effect plug-ins

In traditional studios, mixers tend to be used in conjunction with effects boxes such as delay, but modern computers are powerful enough to generate these effects in software. These effects often come as extra software modules known as plug-ins, and a modern computer will allow you to use a reasonable number of plug-in effects at the same time as playing back audio and MIDI. Plug-ins powered by the host computer rather than by an optional DSP card are said to be native. There are various native plug-in standards, depending on the sequencer software that you’re using, but the most popular is the VST system. (Sound Blaster Audigy also provides sophisticated onboard chip-based effect processing.) The included Cubasis VST CE software can also make use of Direct X plug-ins (PC only).

VST

The most common native plug-in format, VST (Virtual Studio Technology), was pioneered by Steinberg, the originators of Cubase and Cubasis, and the VST technology was then shared between various other companies to produce an industry standard. VST plug-ins are designed in both Mac and PC versions, and the format is supported by software manufacturers such as Steinberg, Emagic, TCWorks and others. There are VST plug-ins available that can handle all of the usual studio effects and processes, such as compression, limiting and gating, as well as reverb, echo, chorus and flanging. However, they can also go a lot further. There are also plug-ins for vocoding, pitch correction, creative distortion, spectral enhancement, noise removal, click suppression and other functions too numerous to list here. If some of these effects are unfamiliar, don’t worry — there’s a separate chapter that tells you all about effects and how to use them.

The VST standard has now evolved (it’s now VST II) so that plug-in settings can be controlled via MIDI information. In this way, effects can be automated under MIDI control so that they change as a song progresses. Again, don’t worry if this sounds quite advanced, because you don’t need to get involved with it until you feel ready, and the basics of plug-in automation will be explained later in the book.

All plug-ins take up some of your PC’s available power, so there will always be a limit to how many you can run at once. For this reason, it makes sense to buy the most powerful PC you can afford, if you have ambitious music-making ideas!

virtual instruments

First, the VST standard gave us computer-generated effects, but as computers became more powerful so it was extended to provide us with virtual instruments as well. VST synths, samplers and drum machines have the advantage of being readily compatible with any sequencer that supports the latest VST plug-ins, and they are easy to use because they provide a full screen to work with rather than some tiny LCD window. This means that you can have an onscreen control interface covered with virtual knobs, just like the real thing, and the automation capability of VST means that you can make adjustments to these controls in real time. These are then recorded as part of your song, just as with VST effects. As a rule, the more synth notes you play at once, the more computing power you require, which will eventually mean a compromise in the number of audio tracks and processing plug-ins you can use at the same time, which is another reason why you should buy a fast computer.

The sound from a VST instrument is fed via your soundcard, just like any other audio track, and it can be mixed in the same way. There are many virtual synthesisers and drum machines available in the VST format, and a number of these emulate classic instruments such as Moog synths, Hammond organs and Roland drum machines. Some are even created by enthusiasts and made available for free download from the Internet, although most of the better ones have to be bought. Others are available for download on the Steinberg website.

Creative Labs’ SoundFont system provides a way of playing back musical sounds based on waveforms recorded from real instruments, and the Sound Blaster Audigy card supports these directly. A description of SoundFonts and their place in the computer studio is included later in the book, but the key thing to remember is that sounds created from recordings of real sounds are called samples. The beauty of the SoundFont format is that, if you want new sounds, you don’t have to buy new instruments; instead, you simply load in more SoundFonts. There are some excellent commercial SoundFonts-library CD-ROMs available for far less than the cost of traditional sample-library CD-ROMs. If you’re feeling really creative, you can also record your own sounds and then turn them into SoundFonts by using the Vienna SoundFont Editor software that comes with your Sound Blaster Audigy card.

virtual samplers

A SoundFont is a type of audio sample, so you already have facilities for playing back high-quality samples using just your Sound Blaster Audigy card. However, other types of sampler are also available in software-only form, many of which will read commercial sample CD-ROM libraries. The Akai, E-mu and Roland formats are probably the most common hardware sampler formats. Also, software-only samplers are now available as VST instruments, and — like Sound Blaster Audigy’s SoundFont Playback system — they use the computer’s own RAM as sample memory, so fitting plenty of RAM is essential. A minimum of 256MB is recommended.

sample loops

Everyone knows that a lot of modern music relies on using rhythm loops that were created by somebody else, and many of these are actually taken from drum breaks on old records (ie breakbeats). Unfortunately, you’ll find that almost all drum loops are at the wrong tempo for the song you’re working on, which is where Steinberg’s excellent ReCycle Lite software comes to the rescue. ReCycle automatically deconstructs drum loops into their component beats and then presents them in a form which provides you with a high degree of control over their tempi. The special version of ReCycle Lite included in this package creates processed loops in the SoundFont II format, which means that you can replay them over Sound Blaster Audigy’s onboard synthesisers.

computers and composition

Computers can also help you compose music with inexpensive programs such as Band In A Box, which can create a complete MIDI arrangement based on your choice of chords and musical style. However, if you want something more avant garde, there are several so-called algorithmic processing tools available which generate new music based on mathematical principles. (KOAN Pro is a popular package for this purpose.) These programs are easy to install and, because most create standard MIDI data files, you can export the result into Cubasis VST CE and work on it further.

Most of the more serious MIDI sequencers — including Cubasis VST CE — will also allow you to produce a printed musical score from your own MIDI compositions. As long as you play along to the sequencer’s click track and tell the sequencer what key you’re playing in, whatever you play on the keyboard appears on the score. It’s that simple.

practicalities

Although a suitable computer fitted with a good soundcard and running suitable software can take the place of a conventional studio recorder, mixer, effects rack and synth bank, there are also other things that you’ll need to buy before you can use your system to the full. A monitoring system, comprising amp and speakers, is a must for any kind of music, and if you’re recording real voices and/or instruments you’ll also need a good microphone and mic pre-amp. (You can get surprisingly good results using Sound Blaster Audigy’s built-in mic pre-amp, but it would be unreasonable to expect it to do justice to a serious studio microphone.) Furthermore, you should really think about getting a CD burner for backing up your data and for making audio CDs. Monitoring arrangements and studio set-up considerations are discussed in more detail in the final chapter of this book, but at this point I’d like to say that most mutimedia-type speakers are insufficiently accurate for mixing music intended for CD release. Of course, they’ll do fine if you’re still learning or just want to have fun.

Finally, you’re going to need a MIDI keyboard to play all of those wonderful synth sounds and SoundFonts that the Sound Blaster Audigy card provides. The model you choose could have its own sounds built in (in which case you can control these from the Sound Blaster Audigy MIDI Out socket) or it could be a simple "dumb" controller keyboard, in which case all of your sounds will come from the computer. Keyboards vary a great deal in size and price, but I’d recommend that you get one with pitch-bend and modulation wheels so that you can put some expression into your playing. These two wheels will be distinctly visible to the left of the keyboard, if they’re fitted, although some companies (such as Roland) combine them into a single joystick-style lever.

the upgrade path

The world of computer music is anything but static, so it makes sense to buy the most powerful computer that you can afford and be prepared to upgrade it from time to time. One reason for the need to upgrade is that music software undergoes frequent revisions as more processor-hungry features are added, while another factor is the increasing number of optional plug-ins that add to the capability of your system. All of these demand a share of your processor’s available resources.

the rest of the studio

A recording studio is only as good as its weakest link, and with the computer’s ability to record CD-quality sound or better the weak link is usually the sound source. In the case of "real" recordings, this means the microphone and mic pre-amp, which is why recording with microphones is covered in a separate chapter, where you’ll learn why some microphones cost more than others and what a microphone pre-amp actually does. I’ll also provide some sure-fire ways of making professional recordings with microphones, even though you may only be working in your bedroom or garage.

your task…

This book is not designed to be a replacement for your computer, soundcard and software manuals. The manuals that come with the Sound Blaster Audigy package — combined with the available online support — should answer all of your technical queries, but where you may need help is in understanding the recording and mixing processes that are fundamental to making music, and this book addresses these areas in some depth but without using unnecessary jargon or complexity. It also aims to provide an overview of the software that comes with your Sound Blaster Audigy card, explaining what it can do for you and how it fits into the overall process of music-making.

Sound Blaster Audigy - The Definitive Music Creation Guide also addresses some of the practicalities of computer-music making, such as the layout of your "studio", the various system configurations you might consider using and some advice on the basics of acoustic treatment. Hopefully, after reading this book, instead of being overwhelmed by the amount of information that manuals can sometimes fling at you, you’ll know what you want to achieve and how to go about achieving it.

be prepared

Before you can make a start on making music, you need to be reasonably familiar with your computer. For instance, you need to know how to create, load and save files and so on. It’s also useful if you know how to diagnose common faults and recover from crashes, but having a friendly PC guru who can help out in emergencies is also very useful!

You’re much less likely to run into problems if you buy your PC system pre-configured and tested, but you should also be aware that playing games, loading programs from the cover disks that come free with some magazines or accessing the Internet can lead to problems with music software, not to mention making you vulnerable to picking up computer viruses. If you must use the same computer for both jobs, I’d recommend that you get your supplier to install a slot-in hard drive caddy and use a second hard drive with a separate operating system exclusively for music. In addition to the two swappable OS drives, I would also recommend a second, high-speed, permanent hard drive that you should use for audio recording only. You could also use software such as Power Quest Drive Image or Ghost to make a back-up of your OS drive, once you have it running smoothly, and burn this image to CD in order to recover from any disaster that may occur.

You may be able to get your computer supplier to make a CD-ROM back-up copy of the hard drive complete with the operating system and your music software immediately after installation and testing so that, in the event of a fatal crash, this can be copied back onto the hard drive. Doing this will get your system working again but won’t restore any changes you made since you took the computer home, and that includes retrieving any audio or MIDI data that you may have stored on the hard drive. For this reason, it’s imperative to make regular back-ups of important files. If you have to reformat the drive for any reason, you may also erase the invisible files that some companies use in conjunction with "key disk" copy protection, rendering the programs unusable in future. To prevent this from happening, always keep a note of all of the software you install so that you can uninstall any protected software before reformatting.

Finally, choose your computer wisely. If possible, buy your PC from a company specialising in computer music, because they’ll know of any hardware issues that might adversely affect the performance of your system. PCs are wonderful things, but there’s no such thing as a standard machine. There are several types of processor, motherboard, chip sets, graphics cards and so on, and inevitably some of these work better for music than others. If you buy the complete system from a music specialist with the Sound Blaster Audigy card and software fully installed, it may cost a little more than the bargain you spotted at the PC office superstore down the road, but at least the supplier is responsible if it doesn’t work properly.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

introduction to Audigy
computers and music
MIDI
adding audio
MIDI/audio integration
the user interface
the audio interface
audio mixing
effect plug-ins
VST
virtual instruments
virtual samplers
sample loops
computers and composition
practicalities
the upgrade path
the rest of the studio
your task…
be prepared


chapter 2

introducing MIDI

If you’ve used a MIDI sequencer before, you can probably skip this chapter, but if you haven’t then it will help to get you up to speed with the principles and terminology necessary to have a working understanding of the subject. I apologise in advance if this chapter seems a little more academic than the rest of the book, and I know that you really just want to get on and make music, but I’ve tried to make it as straightforward as possible. Those who think that the best way to learn is by experimentation have a valid point, but when it comes to MIDI a little advance knowledge goes a long way. If you already know a little or are feeling impatient, feel free to skip around the various sections within this chapter, but at least try to make it as far as "MIDI Controllers!" You can always refer back to something later on, if you need to, so you don’t have to read everything strictly in the order in which it appears here.

MIDI is the reason why synthesisers and other instruments from different manufacturers can work together in the same system. Before getting too deeply involved into the workings of MIDI, however, it’s first helpful to know what it offers the musician working with a computer studio. Firstly, I may have given the impression that MIDI is only relevant to keyboard players. Indeed, from a technological viewpoint, the keyboard is the simplest means of generating MIDI information, but there are practical alternatives based around percussion pads, MIDI guitars and even MIDI violins and wind instruments.

the virtual band

A MIDI sequencer package based around a PC enables you to record several different musical parts in isolation and then hear them playing together. You can choose any synth sound you have available to play any of the parts and you can change the sounds after you’ve finished recording, if you want to. It’s also easy to change the tempo of your finished recording so that, if you find something is hard to play, you can simply slow down the song, record that part and then speed it up again. You can also copy or move sections of your recordings — such as verses, choruses or solos — to new locations within the song. As touched upon in the introduction, MIDI isn’t a system for transmitting sound but rather a system for transmitting instructions to MIDI-compatible devices that produce sounds. Remember, MIDI is our electronic musical score and the performers are our synthesisers.

MIDI sequencing

One of the first applications of MIDI was to enable a keyboard player to play several electronic instruments from a single keyboard. This is useful but hardly revolutionary. However, the MIDI sequencer soon followed, and this did cause a revolution, because it allowed a solo musician to build up a composition in layers, exploiting synthesiser technology rather than conventional recording techniques. At the time, it was unthinkable that a computer could also provide multitrack audio recording, but recording multiple MIDI parts was relatively straightforward.

A basic MIDI system starts with a MIDI keyboard. Some of the simpler controller keyboards may only have a MIDI Out socket, while keyboard synths tend to have the full set of MIDI In, Out and Thru sockets on their back panels. If you choose a keyboard that has velocity sensitivity, this means that the harder you hit the keys, the louder the notes will be, just like on a piano. If you don’t have velocity sensitivity, all of the notes will play at the same level, like an organ. For a master keyboard, you can choose a "dumb" controller keyboard with no sounds of its own, or you may choose to use a conventional keyboard synthesiser with built-in sounds. Again, in either case, I’d recommend that you choose one with pitch-bend and vibrato wheels, as these allow you to add realism to certain instrument types.

MIDI wiring

All MIDI connections are made by using just one type of cable along which the MIDI data travels in one direction, and MIDI cables use five-pin DIN plugs, which are available from most music stores. The rules of MIDI connection are quite straightforward, and I’ll explain them shortly, but it’s also important to know what musically useful information can be passed from one MIDI instrument or device to another. Obviously, Note information is the most important, and that’s a logical place to start, but MIDI can do a lot more than send just notes.

the MIDI note

When you press a key on your MIDI keyboard, a MIDI Note On message is sent from the MIDI Out socket, along with a MIDI Note number identifying the key that was pressed. Then, when the key is released, a Note Off message is sent. In this way, the receiving MIDI instrument knows what note to play, when to play it and when to stop playing it. Each key on the keyboard has its own Note number, and up to 128 different notes can be handled by MIDI. The loudness of the note depends on how quickly you push down the key, and this is measured by circuitry within the keyboard that detects the key velocity. This Velocity information is sent along with the other Note data and is used to control how loudly each note is played back by the MIDI instrument receiving the MIDI data.

sending MIDI note data

A simple application of MIDI is to send Pitch, Note On, Note Off and Velocity messages along a MIDI cable to control a second MIDI instrument. The MIDI Out of the keyboard that is being played (called the master keyboard) is cabled to the MIDI In socket of the second MIDI instrument (called the slave), enabling it to play the notes as performed on the master keyboard. This simple MIDI connection is shown in Figure 2.1. If you try this before reading the rest of the chapter and it doesn’t appear to work, that’s because you also need to know about MIDI channels, a subject that will be introduced shortly.

Figure 2.1: MIDI master/slave set-up

MIDI sockets

• MIDI Out — sends information from a master MIDI device (keyboard, other MIDI instrument or computer interface) to slave MIDI devices. In a MIDI performance, master devices always send data while slave devices receive it.

• MIDI In — receives MIDI information which, as well as being read by the instrument, is also passed on to the MIDI Thru socket unchanged to allow for daisy-chain connecting.

• MIDI Thru — sends out a copy of the MIDI In signal.

the synthesiser module

Because several MIDI instruments can be played from a single keyboard, it’s quite possible to have extra synthesisers existing as compact hardware boxes, as chips on a soundcard or even as virtual software instruments being generated by a computer. A hardware MIDI module (a synth with no keyboard) is simply the sound-generating and MIDI-interfacing electronic part of a keyboard instrument packaged in a box. The problem now is how to connect multiple MIDI modules so that only the ones you want to play are triggered by the MIDI data rather than all of them playing all of the time. The solution is the use of MIDI channels, which are the means by which certain messages are "tagged" so that they are recognised by specific instruments and yet ignored by others.

MIDI channels

In a typical master/slave MIDI system where multiple MIDI modules are daisy-chained, all slaves receive the same MIDI information. Without channels, they’ll all play whenever you press a key on the master keyboard or send MIDI Note data from your sequencer. Fortunately, the MIDI-channel system tags MIDI Note messages with what is, in effect, an electronic postal address label so that the message is only read and acted upon by the intended recipient. MIDI devices set to receive on a different MIDI channel will ignore the message.

MIDI supports 16 separate channels, numbered 1-16, and any MIDI information sent on channel 1 will only be played by slave instruments set to receive on channel 1. Modules set to other channels still receive the information, but, as they can see that it’s not for them, they ignore it. By switching the MIDI channel at the master keyboard end, up to 16 different MIDI instruments set to 16 different channels can be addressed individually, which is an important element of MIDI sequencing.

a word about omni

MIDI instruments usually have an operational setting called Omni mode, although this is used little in practice. In normal usage, a MIDI instrument will be set to what we call Poly mode, so that it responds only to information on the appropriate channel, but in Omni mode it will respond to all incoming data, regardless of the channel on which it was sent. In Omni mode, everything that comes along the MIDI cable is played at once, and it usually sounds a complete mess! (There will be more about MIDI modes later, but I thought it helpful to mention Omni mode at this point, in case you’ve been experimenting and can’t figure out why everything is playing at once. If this happens to you, find the MIDI set-up option for the device and switch the MIDI mode to Poly.)

multitimbral modules

Early synth modules were simply MIDI instruments in boxes with no keyboards, but most modern modules and all serious soundcards actually contain several independent sound-generating sections, each of which can be addressed on a different MIDI channel. In other words, you have the equivalent of several synths sharing the same box. These sound-generating sections are often referred to as parts, and a 16-part multitimbral module would be able to play back up to 16 different musical parts at the same time, each set to a different sound. Each part responds to a different MIDI channel, which makes multitimbral devices like this very useful for sequencer work, not to mention economical.

Even though the parts respond separately and may be set to different sounds, the outputs from the various parts are usually mixed to stereo and emerge via a single stereo pair of sockets (although more expensive sound modules may have multiple outputs). Modules and soundcards also tend to include effects sections for things like reverb, chorus and delay, but — except for very expensive, specialised devices — these are shared between the various parts. They don’t get an effects section each! Even so, you will have independent control over the sound, level, pan position and amount of effect for each individual part.

Sound Blaster Audigy includes a pair of impressively specified multitimbral sound "engines", which will be examined in some detail later in the book, although, by using its MIDI interface(s), you can also control up to a further 32 external MIDI parts, if you have a suitable MIDI synthesiser or module. One special kind of MIDI module is the drum machine. Drum machines are similar to other types of synth, except of course they produce drum and percussion sounds rather than pitched instruments, and they often come with a type of built-in mini-sequencer that enables them to store and replay rhythm patterns and song arrangements based on permutations of those patterns. A regular synthesiser tends to interpret incoming MIDI Note data as different pitches of the same basic sound, whereas a drum machine produces a different drum, cymbal or percussion sound for each MIDI note. Almost all multitimbral synthesiser modules and computer soundcards tend to have one part dedicated to drum sounds (usually set to MIDI channel 10) so that you don’t have to buy a separate drum machine to create drum parts. Note, however, that you will have to create your own drum rhythms if you work this way, although commercial MIDI file disks of contemporary drum patterns are available, if you don’t want to make your own.

MIDI thru boxes

A more advanced sequencer set-up might comprise a PC-based sequencer plus half a dozen external sound modules. In theory, these can be connected in a simple MIDI chain, where the soundcard sends information from its MIDI Out socket to the MIDI In socket of the first slave. The MIDI Thru of the first slave connects to the MIDI In of the second slave and its Thru connects to the MIDI In of the next, and so it goes on. However, in practice, this type of daisy-chain connection introduces problems if the chain is more than two or three instruments long. Just like a Chinese whisper, the MIDI signal actually becomes slightly less intelligible as it passes through each instrument, and eventually the signal becomes too unreliable. When this happens, notes stay on for no reason or refuse to play at all. Fortunately, there’s a solution.

A MIDI thru box takes the MIDI Out from the master keyboard or sequencer and splits it into several Thru connections that can be used to feed the individual modules directly. Figure 2.2 shows a conventional MIDI daisy chain, while Figure 2.3 shows a MIDI thru box used to achieve the same end but with greater reliability. MIDI thru boxes may also be used to feed shorter daisy chains of MIDI equipment from each output. As long as these individual chains are no more than two or three devices long, everything should work reliably, but I’d advise against using passive thru boxes (ie those that require no power), as they can’t drive many MIDI devices.

Figure 2.2: MIDI daisy-chaining

Figure 2.3:MIDI thru box

MIDI programs

With all of this talk of channels and programs, it makes MIDI sound like TV, and in fact there are some useful analogies. Digital synthesisers are invariably programmable — they can "remember" a number of different sounds (either presets or those created by the user), where each is identified by its program number. MIDI can directly access up to 128 patches, sometimes numbered from 0 to 127 and sometimes from 1 to 128. The term patches came about because the original analogue synths used patchcords to connect their various modules, and as a rule the terms program and patch are interchangeable in this context. Program information can be sent via MIDI to MIDI slave devices, enabling the user to select sounds by remote control.

Instruments with space for more than 128 programs must separate these into two or more banks containing a maximum of 128 programs or patches in each bank. MIDI Bank Change messages are used to switch between banks, and again these can be transmitted via MIDI to remote instruments.

MIDI controllers

Earlier on, I stressed the importance of choosing a keyboard with pitch-bend and modulation wheels. A typical MIDI synthesiser or master keyboard has two (but sometimes three) wheels mounted to the left of the keyboard for controlling pitch bend and vibrato depth. These are operated with the left hand while a melody is being played with the right, and the MIDI information they generate is also sent over the MIDI link to any connected modules or soundcard synth sections. Further control may be provided by means of sustain foot switches or volume pedals (usually plugged into the master keyboard), and the data generated by these is also sent over MIDI to be used by remote slave instruments. Because pedals and wheels can be set to any position, rather than simply being on or off, they are known as continuous controllers, and it should come as no surprise to find out that they actually operate over 128 steps (a familiar number in MIDI-land). Other MIDI controllers are available for switches that are either on or off.

When using controllers, the data automatically goes to the same destination (MIDI channel) as the notes that are played on the keyboard. Note, however, that the amount of pitch bend you get when you use the pitch-bend wheel depends on how the receiving synth is set up. As a rule, pitch bend is scalable, so a full-scale movement of the pitch-bend wheel can cause a pitch shift of as much as a whole octave, although most people prefer to use a setting of two or three semitones for all of their instruments. Whatever setting you prefer, it’s less confusing if you use the same pitch-bend range for all of your instruments. Most pitch-bend wheels can move the sound both sharp and flat and are spring loaded so that they automatically return to their centre position when released. Interestingly, the pitch-bend wheel isn’t a part of the more general MIDI controllers group but instead has its own category.

other MIDI controllers

By now, you’re probably getting the idea that all kinds of control information can be sent via MIDI, as well as the more obvious musical data. A full listing of generic MIDI controller numbers and functions is included here for reference. Don’t feel that you have to learn them all or even use them all, but at least look through the list so that you’re aware of what is possible. (Note that not every MIDI devices supports all of the available MIDI controllers.) Sound Blaster Audigy’s MIDI controller list is shown later in the book.

controller listing

0 Bank select

1 Modulation wheel

2 Breath controller

3 Undefined

4 Foot controller

5 Portamento time

6 Data entry

7 Main volume

8 Balance

9 Undefined

10 Pan

11 Expression

12 Effect control 1

13 Effect control 2

14 Undefined

15 Undefined

16-19 General purpose 1-4

20-31 Undefined

32-63 LSB for control changes 0-31, where greater resolution is required

64 Damper/sustain pedal

65 Portamento

66 Sostenuto

67 Soft pedal

68 Legato footswitch

69 Hold 2

70 Sound variation/exciter

71 Harmonic content/compressor

72 Release time/distortion

73 Attack time/equaliser

74 Brightness/expander gate

75 Undefined/reverb

76 Undefined/delay

77 Undefined/pitch transpose

78 Undefined/flange-chorus

79 Undefined/special effect

80-83 General purpose 5-8

84 Portamento control

85-90 Undefined

91 Effects depth (effect 1)

92 Tremolo depth (effect 2)

93 Chorus depth (effect 3)

94 Celeste depth (effect 4)

95 Phaser depth (effect 5)

96 Data increment

97 Data decrement

98 Non-registered parameter number LSB

99 Non-registered parameter number MSB

100 Registered parameter number LSB

101 Registered parameter number MSB

102-119 Undefined

120 All sound off

121 Reset all controllers

122 Local control

123 All notes off

124 Omni mode off

125 Omni mode on

126 Mono mode on

127 Poly mode on

If you’ve scanned through the list, you’ve probably realised that not all MIDI controllers are used for performance control. For example, the last four controller numbers are used to change MIDI modes (Omni and Poly were mentioned earlier), but there are also Bank Change messages and an All Notes Off message to cut off any notes that may be left hanging on for any reason. (This can happen if a Note Off message gets lost or isn’t sent, for example.) Local On/Off is another non-performance controller, and this effectively separates the keyboard and sound-generating parts of a keyboard synth. (We’ll see why later.) There’s also a Reset All Controllers message, which returns all controllers to their default values.

Continuously variable controllers have values of between 0 and 127 (128 steps again!), while switched controllers are usually set at 0 for off and 127 for on. I must stress that you really don’t have to get involved in most of the details of MIDI — it just works! Move a MIDI controller on your master keyboard and the data gets sent. It’s that simple. However, when you come to edit MIDI sequence data, it’s useful to know what the more commonly used controllers do and what their numerical values mean. For example, you need to know that Pitch Bend information provides control in two directions, so its default position is 64, midway between the two extremes. Most other controllers have 0 as a minimum value and 127 as a maximum value.

The MIDI messages discussed so far are channel specific, inasmuch as they are only acted upon by the receiving device if they are on the same MIDI channel as the sending device. This type of message is called a MIDI channel message, and the repertoire of channel messages includes MIDI Note On and Note Off, Note Velocity, Pitch Bend, Controller Data, Program Change and Bank Change messages, etc. Later on, you’ll come across some useful MIDI data that isn’t channel specific.

MIDI modes

MIDI modes determine how an instrument responds to incoming MIDI data. In the context of sequencing, instruments are normally set to Poly mode, although some older instruments default to Omni mode when they are switched on, in which case you’ll need to manually select Poly mode each time you turn on your system.

The four main MIDI modes are as follows, although be aware that not all instruments offer the choice of all modes.

• Mode 1: Omni On/Poly. This is commonly referred to as Omni mode, which means that the instrument will play polyphonically but MIDI channel data is ignored — it will play everything you send to it! It’s useful for testing out a device in the shop, because you can guarantee that you’ll get a sound out of it, but it’s less useful in the studio.

• Mode 2: Omni On/Mono: The monophonic equivalent of mode one. This is a very obscure MIDI mode that is seldom supported or used, but it’s still in the spec. Monophonic means that only one note can be played at a time, while polyphonic means that several notes may be played at once to create chords or melodies with overlapping notes.

• Mode 3: Omni Off/Poly. The "normal" MIDI Poly mode. Use this mode when sequencing. In mode three, the instrument responds only to messages on its own MIDI channel and plays polyphonically.

• Mode 4: Omni Off/Mono. In this mode, the synth still reacts to MIDI data only on its channel, but it can play only one note at a time. Mode 4 is mainly for MIDI guitar players who need to have each string working on a separate MIDI channel in order to be able to bend individual notes or apply vibrato on independent strings. In Poly mode, vibrato and pitch bend are applied to all of the notes that are sounding.

non-registered parameters

Standard MIDI controllers are incredibly useful, but they can’t access everything that you might need to access simply because not all synthesisers work in the same way. Some parameters are the same for all instruments, and these are known as Registered Parameters (including Pitch-Bend Sensitivity, Fine Tuning, Coarse Tuning, Change Tuning Program and Change Tuning Bank); but, in order to allow manufacturers to provide access to parameters that only their instruments may have, the NRPN (Non-Registered Parameter Number) system was added to the MIDI specification. NRPNs are used mainly by software writers creating editor programs, so the average musician doesn’t need to know about them.

system-exclusive messages

System-exclusive (sysex for short) messages are another part of the MIDI system message system that allows manufacturers to access features and parameters that relate to only their own instruments. A sysex message contains an ID code unique to the type of instrument for which it is intended. Where two or more identical instruments are being used in the same system, it’s often possible to set them to different ID numbers in order to avoid confusion. Sysex IDs can be set between 1 and 16 and are only recognised by the instrument type for which they are designed, so you don’t need to worry about inadvertently sending the data to the wrong instrument. As with NRPNs, sysex messages provide hardware and software designers with access to all of the sound-generating parameters that might need controlling. However, whereas NRPNs access unique parameters by using MIDI controllers, sysex uses a specialised message structure which can be complex to understand and use.

aftertouch

Most of the serious controller keyboards include a controller known as aftertouch, which uses a pressure-sensitive strip under the keyboard to sense how hard you press down on the keys after the initial velocity has been read and converts this to MIDI data. Aftertouch sends out lots of MIDI data, so it’s best to switch it off if you don’t want to use it. If you do use it, however, it can be used to control various aspects of musical expression, such as brightness, loudness and vibrato depth.

Conventional aftertouch affects all of the notes that are playing at one time, not just the one you’re pressing down, although a few specialised instruments feature polyphonic aftertouch, where the data sent applies only to the note being pressed. Polyphonic aftertouch (sometimes referred to as key or channel aftertouch) can generate a huge amount of MIDI data, and so it must be used with care.

Another feature found only on specialist keyboards is release velocity. All velocity-sensitive instruments generate MIDI note velocity, depending on how quickly you push down the keys, but on an instrument with release velocity, additional information is generated depending on how quickly you release the keys. Very few keyboards offer this facility, however, and even fewer musicians know how to use it creatively!

sound banks

As explained earlier, only 128 separate MIDI patches or programs can be stored in the same sound bank, so to have more sounds you need more banks. In this case, a MIDI Bank Change message (a form of controller message involving controller numbers 0 and 32) is used to switch between the different banks. (The MIDI section at the back of your instrument manual will show you the exact form of Bank Change message that the instrument uses.)

assignable controls

Synthesisers are often designed by people who don’t know where to stop, and so, if they dream up a new feature, they tend to put it in! One thing that’s easy to do in software is to take the data from one controller and redirect it somewhere else — for example, the modulation wheel on your synth could be redirected to control something quite different, such as the amount of reverb or the brightness of the sound being played. Most of this type of controller assignment goes on inside the synthesiser program, so, if you’re using the factory preset sounds, you don’t need to worry about how it works. Nevertheless, if you’re the type of person who likes to create your own synth sounds, you’ll need to study your instrument manuals to find out what modulation options are possible.

MIDI and timing

MIDI data mainly concerns what note is played and when, but how does a computer know the right time to send out a MIDI note? The answer is that computer music exists on an invisible timing grid and, as the music plays, it steps through the grid a square at a time. MIDI messages dedicated to sequencer timing and control have no channel address, because they relate to the composition as a whole, not just to individual parts of it. For this reason, they are accepted by all MIDI instruments and devices that can make use of them. Perhaps the most important of all these messages is MIDI clock.

MIDI clock is a tempo-related timing code comprising 96 electronic "clocks" or ticks for each four-beat bar of music. You can’t hear these ticks, but they are recognised by any drum machine or sequencer set to External MIDI Sync mode. MIDI clock is one way of driving a sequencer or drum machine along the time axis of its invisible music grid, one tick at a time. (Note that MIDI clock is only of use to devices that need to know tempo information, such as drum machines, sequencers and synthesisers that have to play tempo-related loops and so on.)

A common use of MIDI clock is to sync up two MIDI devices where one is the timing master and the other the slave. The slave machine — for example, a drum machine — must be set to External MIDI Sync, which means that it will follow exactly the tempo generated by the master device (often a sequencer). If you do everything within your computer, you may never need to use MIDI clock or any other form of synchronisation, but if you want to run a drum machine alongside it then you’ll need to know how MIDI clock and other MIDI sync functions work.

start, stop and continue

In any system where one MIDI device is sync’d to another, the slave device needs some way of knowing when it’s supposed to start and stop. This is where MIDI comes to the rescue again! MIDI also includes Start, Stop and Continue messages, although, used in conjunction with MIDI clock, these only help if you start your master from the beginning of the song. It’s no good telling the slave to start if it doesn’t know whereabouts in the song it’s supposed to start from. Of course, MIDI has another solution, this time in the form of MIDI Song Position Pointers, and the really great thing about these is that they do all of the hard work for you without you having to think about them.

song position pointers

With MIDI Song Position Pointers, or SPPs, as soon as the master starts to play, a message is sent telling the slave device where it should start from. As a result, the slave device can lock up almost instantaneously, even if a song is started halfway through.

MIDI machine control

There is also a MIDI protocol for controlling compatible tape machines and hard-disk recorders, and this is known as MIDI Machine Control, or MMC. This allows remote access to the main transport controls and record-status buttons of a multitrack recorder, which can be useful if your multitrack recorder is on the opposite side of the room from your sequencer. Unless you have a pretty sophisticated studio, however, you probably won’t need to make use of this.

MIDI isn’t magic

By now I’ve built up MIDI to be something pretty spectacular, and, to be fair, so it is; but it’s based on quite old computer technology, dating from the early ’80s, and so it’s not that fast by today’s standards. Harder to believe is that MIDI is a serial system, which means that each chunk of MIDI data has to wait in line to be delivered. When you play a chord, all of the notes seem to sound at the same time, but in reality they switch on one after the other, in quick succession. Normally, the delays are too small to hear, but if you tried to play all of the notes on your keyboard at once there would be a small but significant delay between the first one sounding and the last.

The speed limitations of MIDI is seldom a problem, but if you’re trying to replay a multipart MIDI sequence that also contains lots of controller information (such as aftertouch) you can end up with a case of something like a "MIDI rush hour", where the timing starts to suffer. Most good sequencing software gives priority to MIDI note timing, but it’s still a good idea to switch off aftertouch and other controllers if you don’t need to use them.

MIDI song select

Because MIDI sequencers can hold more than one song in memory, MIDI also includes a Song Select message in the range of 0 to 127. This facility can be useful for calling up songs when using a sequencer in live performance, but it’s of limited use in the studio.

tune request

When a MIDI Tune Request message is sent, all of the MIDI instruments in the system that have a tuning routine will automatically retune to their own internal reference. This is most relevant to digitally controlled analogue synths, as the pitch of analogue oscillators can drift with time and temperature. Digital instruments — such as the ones on board the Sound Blaster Audigy card — are very stable and don’t require retuning.

sysex dumping

Only advanced MIDI users get intimately involved with MIDI sysex (system-exclusive) data, but it’s commonly used at a fairly low level to handle the transfer of MIDI-device program memories to and from a computer for backing up. Most modern MIDI instruments and signal processors have a sysex dump facility, and all you need to do is connect the MIDI Out of the instrument to your sequencer’s input, put the sequencer into Record and then initiate the dump procedure. The sysex data looks pretty meaningless if you examine it in the Event Editor, but it’s recorded in exactly the same way as other MIDI data. It usually takes several seconds to record all of the patches from a device in this way, but doing this provides insurance against your favourite sounds getting wiped and lost forever. The stored sysex data can be played back into the instrument at any time, restoring the patches you saved. Some instruments allow you to dump individual patches, banks or entire instruments using sysex, and a number of software-editing packages also send and receive data via sysex. Make sure that your sequencer is set up to accept system-exclusive data before recording a MIDI dump.

MIDI compatibility

MIDI was designed to allow instruments and devices from different manufacturers to communicate in a meaningful way, but sometimes the communication isn’t as complete as you’d like it to be. Any MIDI synth will send and receive MIDI Note data, and virtually all will accept MIDI Program Change and Velocity information, but over and above that the degree of compatibility depends on the manufacturer. If a MIDI message is received by an instrument incapable of responding to that message, the message is simply ignored. It’s a good idea to check the MIDI implementation chart in the back of the manual if you’re unsure about what MIDI features are supported by a particular piece of MIDI equipment. A 0 next to a parameter shows the facility is present, whereas an X shows that it is not supported.

more advanced sync options

Tape Sync

I’ve already introduced the idea of MIDI clock, but if you want to make a MIDI sequencer or drum machine follow an analogue tape recorder (yes, there are still a lot around!) then you’ll need a MIDI-to-tape sync box that can convert MIDI clock into a time code that can be recorded onto tape. The simplest such system is called FSK (Frequency Shift Keying), which uses a series of electronic pulses recorded onto a spare track of a multitrack tape recorder to provide a sync reference for the sequencer to follow, rather like the sprocket holes in cine film. The sync tones are derived from MIDI clock, which is itself related to the tempo of the song, so the faster the tempo, the more sync pulses there are per second. Most MIDI-to-tape sync boxes support SPPs (MIDI Song Position Pointers) so that the tape machine can be started anywhere in the song. Without this, you’ll always have to start from the beginning, which is very tedious. Most modern MIDI equipment can generate and read SPPs, and the whole process is quite transparent to the user. As tape recorders are increasingly being replaced by hard-disk recorders, this kind of facility is no longer as widely used as it once was.

SMPTE

SMPTE (pronounced "simptee") is normally used with video or to synchronise to other forms of professional system. It was originally designed to sync soundtracks to films, and it actually pre-dates MIDI by several decades, but it’s now supported by many MIDI interfaces, simply because it’s a universal system of synchronisation and many musicians need to correlate their work with images. SMPTE is based on real time, measured in hours, minutes and seconds, with further subdivisions for individual frames of TV and film material, and is available in a number of frame formats to accommodate TV (both 60Hz and 50Hz) and film, the most common of which are 24, 25 and 30 frames per second. Conversion from real-time SMPTE to tempo is carried out within the sequencer software, and most programs support SMPTE in a way that is very transparent to the user. All that the sequencer needs to know is the starting tempo, the start time of the song and the value and time location of any subsequent tempo changes. This data forms a tempo map and is stored as part of the sequencer song file.

SMPTE is most often used to synchronise MIDI equipment to video equipment for sound-to-picture work. If you don’t need to work to picture, MTC may be a more practical option.

MTC

MTC (MIDI Time Code) is a MIDI-specific variation on the traditional SMPTE protocol and offers the same choice of frame rates. Because MTC is a type of MIDI data, no SMPTE-to-MIDI conversion is needed, and so the hardware requirements can be simpler. Indeed, many digital-recording systems output MTC directly, which means that no external hardware is needed, other than a MIDI cable. MTC is probably the most commonly used method of synchronisation in the modern MIDI studio.

MIDI merge

There are occasions when it’s necessary to merge two MIDI data streams — for example, when feeding a sequencer from a master keyboard and a hardware-editing device at the same time. You might want to do this so that you can edit the sounds while playing them, in order to hear the changes being made. MIDI data is quite complicated, and so a special device is required called a MIDI merge box, which contains a small microprocessor. Figure 2.4 shows how a MIDI merge box might be used in the above example, enabling both to be fed into a sequencer at the same time. Most multiport MIDI interfaces include two or more mergeable inputs.

Figure 2.4: Basic MIDI merge

General MIDI

As a rule, different manufacturers want to build synthesisers that sound different, but there are occasions when you need to be able to access a standard set of sounds, such as when playing back MIDI song files created by somebody else. To accommodate this need, virtually all serious soundcards (including Sound Blaster Audigy) and many hardware synthesisers include a bank of what are known as GM (General MIDI) sounds. These GM sounds comprise one bank of 128 universally agreed-upon sounds stored in the same program locations on all machines. This universal GM sound set includes a number of standard pop and classical sounds, as well as synth sounds and sound effects, all of which are located at the same patch numbers so that, regardless of the manufacturer, the first patch in a GM synth will always be a piano, even if not all of the pianos sound exactly the same.

GM also includes drum sounds, on MIDI channel 10, and specifies to what keys the various drum sounds are mapped, so that a bass drum will always be a bass drum, even if it doesn’t sound exactly the same on every machine. In addition to making sure that the same sounds are stored in the same places, GM specifies the minimum multitimbrality and polyphony permitted to ensure that a MIDI sequence recorded using one GM module can be played back on any other GM module without the need to remap patches, move drum-note allocations or worry about running out of parts or polyphony.

polyphony and multitimbrality

To recap, polyphony relates to how many notes an instrument can play back at the same time while multitimbrality relates to the number of separate parts that can be addressed on separate MIDI channels. GM instruments provide the ability to play back 16 parts on 16 MIDI channels, providing a total polyphony of at least 24 notes.

basic GM definitions

• A GM instrument must support all 16 MIDI channels simultaneously in order to provide 16-part multitimbrality.

• Percussion parts must be on MIDI channel 10 with a minimum set of 47 standard sound types, including the most common drum and Latin percussion sounds. These must all be mapped in accordance with the GM standard.

• GM instruments must be capable of 24-note polyphony and notes must be allocated dynamically. The specification allows eight notes to be reserved for percussion, leaving 16 for the other instruments.

• All 128 preset sounds must be defined in accordance with their type and patch location. Although there is some variation in sound between one module and another, the contents of each patch location must be quite rigidly defined, right down to the dog barks, helicopters and gunshots in the special-effects section.

• All GM instruments must respond to the same set of MIDI controllers, and the default ranges set for these controller must be standardised. The MIDI-controller implementation must include the ability to change the master tuning and pitch-bend-wheel range via MIDI, a Reset All Controllers message (which resets all MIDI controllers to their default values) and an All Notes Off message (which silences any notes that are playing). All GM machines should also respond to Pitch Bend, Velocity and Aftertouch messages, although not all support aftertouch.

GM voice table

Program Instrument

Number

1 Acoustic grand piano

2 Bright acoustic piano

3 Electric grand piano

4 Honky-tonk piano

5 Electric piano 1

6 Electric piano 2

7 Harpsichord

8 Clavichord

9 Celesta

10 Glockenspiel

11 Music box

12 Vibraphone

13 Marimba

14 Xylophone

15 Tubular bells

16 Dulcimer

17 Drawbar organ

18 Percussive organ

19 Rock organ

20 Church organ

21 Reed organ

22 Accordion

23 Harmonica

24 Tango accordion

25 Acoustic guitar (nylon)

26 Acoustic guitar (steel)

27 Electric guitar (jazz)

28 Electric guitar (clean)

29 Electric guitar (muted)

30 Overdriven guitar

31 Distortion guitar

32 Guitar harmonics

33 Acoustic bass

34 Electric bass (finger)

35 Electric bass (pick)

36 Fretless bass

37 Slap bass 1

38 Slap bass 2

39 Synth bass 1

40 Synth bass 2

41 Violin

42 Viola

43 Cello

44 Contrabass

45 Tremolo strings

46 Pizzicato strings

47 Orchestral harp

48 Timpani

49 String ensemble 1

50 String ensemble 2

51 Synth strings 1

52 Synth strings 2

53 Choir aahs

54 Voice oohs

55 Synth voice

56 Orchestra hit

57 Trumpet

58 Trombone

59 Tuba

60 Muted trumpet

61 French horn

62 Brass section

63 Synth brass 1

64 Synth brass 2

65 Soprano sax

66 Alto sax

67 Tenor sax

68 Baritone sax

69 Oboe

70 English horn

71 Bassoon

72 Clarinet

73 Piccolo

74 Flute

75 Recorder

76 Pan flute

77 Blown bottle

78 Shakuhachi

79 Whistle

80 Ocarina

81 Lead 1 (square)

82 Lead 2 (sawtooth)

83 Lead 3 (calliope)

84 Lead 4 (chiff)

85 Lead 5 (charang)

86 Lead 6 (voice)

87 Lead 7 (fifths)

88 Lead 8 (bass and lead)

89 Pad 1 (new age)

90 Pad 2 (warm)

91 Pad 3 (polysynth)

92 Pad 4 (choir)

93 Pad 5 (bowed)

94 Pad 6 (metallic)

95 Pad 7 (halo)

96 Pad 8 (sweep)

97 FX 1 (rain)

98 FX 2 (soundtrack)

99 FX 3 (crystal)

100 FX 4 (atmosphere)

101 FX 5 (brightness)

102 FX 6 (goblins)

103 FX 7 (echoes)

104 FX 8 (sci-fi)

105 Sitar

106 Banjo

107 Shamisen

108 Koto

109 Kalimba

110 Bagpipe

111 Fiddle

112 Shanai

113 Tinkle bell

114 Agogo

115 Steel drums

116 Woodblock

117 Taiko drum

118 Melodic tom

119 Synth drum

120 Reverse cymbal

121 Guitar fret noise

122 Breath noise

123 Seashore

124 Bird tweet

125 Telephone ring

126 Helicopter

127 Applause

128 Gunshot

Note that some manufacturers number their patches from 0-127 rather than from 1-128.

GM drum map

Note Number Drum Sound

35 Acoustic bass drum

36 Bass drum 1

37 Side stick

38 Acoustic snare

39 Hand clap

40 Electric snare

41 Low floor tom

42 Closed hi-hat

43 High floor tom

44 Pedal hi-hat

45 Low tom

46 Open hi-hat

47 Low mid tom

48 High mid tom

49 Crash cymbal

50 High tom

51 Ride cymbal 1

52 Chinese cymbal

53 Ride bell

54 Tambourine

55 Splash cymbal

56 Cowbell

57 Crash cymbal 2

58 Vibraslap

59 Ride cymbal 2

60 High bongo

61 Low bongo

62 Mute hi conga

63 Open hi conga

64 Low conga

65 High timbale

66 Low timbale

67 High agogo

68 Low agogo

69 Cabasa

70 Maracas

71 Short whistle

72 Long whistle

73 Short guiro

74 Long guiro

75 Claves

76 High woodblock

77 Low woodblock

78 Mute cuica

79 Open cuica

80 Mute triangle

81 Open triangle

the GS format

The GM format is based on a system developed by synth manufacturer Roland, and they’ve now taken the idea a step further and come up with their GS format. GS is an enhancement to GM in that, instead of having just one bank of standard sounds, you can have several other banks offering variations on those sounds. The arrangement is that the standard GM sound set is in the first bank (bank 0), with up to seven further banks of variations. All of the variation tones of a piano will still sound like a piano, just as all of the variations of organs will sound like organs, but they will offer more variety.

Yamaha also introduced their own expanded General MIDI format, which they call XG. Like Roland’s GS mode, this provides several banks of alternative sounds, although most Yamaha XG instruments also support Roland’s GS format. GM and GS tend to be supported mainly by hardware synths rather than by soundcards, although Sound Blaster Audigy’s default SoundFonts support both GM and GS variations.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

introducing MIDI
the virtual band
MIDI sequencing
MIDI wiring
the MIDI note
sending MIDI note data
MIDI sockets
the synthesiser module
MIDI channels
a word about omni
multitimbral modules
MIDI thru boxes
MIDI programs
MIDI controllers
other MIDI controllers
controller listing
MIDI modes
non-registered parameters
system-exclusive messages
aftertouch
sound banks
assignable controls
MIDI and timing
start, stop and continue
song position pointers
MIDI machine control
MIDI isn’t magic
MIDI song select
tune request
sysex dumping
MIDI compatibility
more advanced sync options
MIDI merge
General MIDI
polyphony and multitimbrality
basic GM definitions
GM voice table
GM drum map
the GS format


chapter 3

MIDI sequencers

Originally, sequencers handled only MIDI data (audio came rather later), and in terms of familiarisation it’s most logical to examine their MIDI capabilities before looking at the way in which modern sequencers combine MIDI sequencing with multitrack audio recording. Included in the Sound Blaster Audigy bundle is a version of the excellent Cubasis VST CE sequencing software, which is an extremely sophisticated and capable program. To get up to speed with it quickly, it’s vital that you appreciate what a sequencer is designed to do and how its various elements work together. The following information applies to pretty much all MIDI sequencers, and so, if you decide to use something other than Cubasis VST CE, the information is still valid.

The MIDI aspect of a sequencer can be thought of as a multitrack MIDI recorder, where each "track" is used to record a separate layer of a composition, which may subsequently be edited, re-recorded or otherwise edited independently of any other tracks. In this respect, the multitrack aspect of a sequencer is a little like a multitrack studio tape recorder, except that the sequencer tracks record and play back MIDI data rather than sound. A typical MIDI sequencing system will provide at least 16 tracks and often many more.

By recording onto the sequencer tracks one at a time, numerous separate musical parts can be recorded, either by playing the parts from a MIDI keyboard or by typing the Note information directly into the computer, usually via some kind of graphical interface. Unless you’re a very good keyboard player, you’ll probably find that you use a mixture of both methods, playing the part in first and then fixing up any mistakes using the sequencer’s editing facilities.

Because the MIDI tracks of a sequencer play back MIDI data rather than sound, you’ll need a synthesiser, synthesiser module or soundcard to play back your compositions, and most serious PC soundcards — including your Sound Blaster Audigy model — are capable of playing back at least 16 different sounds at once, each controlled by a different MIDI channel. In fact, Sound Blaster Audigy can play back up to 48 MIDI parts and its MIDI interfaces can control up to 32 parts playing on external MIDI instruments. You don’t have to buy any extra hardware to get started, other than the MIDI keyboard itself, but Sound Blaster Audigy also gives you the opportunity to expand your system when you feel the need.

the strength of the sequencer

By using a MIDI sequencer, you can play all of the musical parts yourself. Effectively, you’re the composer, the computer is your musical score and conductor and the synthesiser is your band or orchestra. If you’re not happy with something you’ve done, you don’t have to start from scratch; you can just erase the unwanted notes and "write" in new ones. If you work anything like me, you’ll also use the sequencer as a musical notepad for saving musical ideas that can be revisited and expanded upon whenever you feel like it.

rechannelising

When I was first learning about sequencers, I thought I’d need to change the MIDI channel on which my master keyboard was transmitting every time I wanted to record a part on a new MIDI channel, but fortunately the clever design of modern sequencers — including Cubasis VST CE — makes this tedious task unnecessary. Instead, incoming MIDI data is automatically converted to the channel on which your track is set up to record. This process is known as rechannelising. As you skip between sequencer tracks, the incoming MIDI data is rechannelised automatically, so you can leave your master keyboard set to the same MIDI channel all the time.

MIDI sequencer set-up

At this stage, it’s useful to see what a basic MIDI sequencer set-up looks like. In fact, it’s not very different from the full MIDI-plus-audio set-up, which we’ll look at later in the book, but let’s take things one step at a time. In a typical set-up, the master MIDI controller is a keyboard, so for the sake of simplicity I’ll assume that everyone is going to use a keyboard, even though you could substitute this for a MIDI guitar or some other form of MIDI controller, if you preferred. The keyboard is connected to the MIDI In port of the sequencer via a MIDI cable so that, when the sequencer is set to record, any notes played on the keyboard are recorded as MIDI data onto the active sequencer track.

When you then play back the recording, the MIDI data is sent either to your external synth or to the sound chip on your soundcard, so that you can hear what you just played. The maximum number of musical parts or layers that you can use in your composition is effectively limited by how many synth parts you have available for playback. A GM-compatible soundcard will provide you with at least 16 separate parts, and if you have an external synthesiser, you can use this, too. Figure 3.1 shows a simple sequencing system based around a PC fitted with a Sound Blaster Audigy soundcard.

Figure 3.1: PC soundcard system

If your master keyboard is also a synth (ie it can generate its own sounds), you can use it as part of your sequencer set-up by setting it to a mode known as Local Off. (See your keyboard manual to find out how to do this.) This effectively breaks the link between the keyboard and the synth section so that the unit behaves as a separate master keyboard and synth module. This is important when working with a sequencer, as it simplifies the setting-up procedure and avoids a problem caused when the MIDI signal is connected in such a way that it has a path to recirculate continuously. This situation is known as a MIDI loop and can usually be recognised by erratic timing, stuck notes and other unusual MIDI problems.

Note that, when Local Off is selected, playing the keys won’t result in any sound from the synth section unless the instrument is connected to the sequencer and the synth’s internal sounds are being addressed by the currently active sequencer track. What actually happens in this case is that the keyboard sends the MIDI data to the sequencer and the sequencer sends a copy of this data to its MIDI Out port, which in turn drives the synth section of the keyboard. If your keyboard doesn’t have Local Off, you must disable MIDI Thru inside Cubasis VST CE.

MIDI isn’t audio

It’s vitally important to keep in mind that what is being recorded in the case of MIDI isn’t the sound itself but the electronic equivalent of a musical score. Just as a musical score is a series of instructions to the musicians, a MIDI sequence holds a series of instructions which tell your synths what to play and when to play it. According to the technical-support departments for the major synthesiser and music-software manufacturers, the confusion between MIDI and audio makes up a significant proportion of their calls, so I make no apology for labouring this point.

click track

At its simplest, you can use a sequencer as a multitrack recorder for MIDI information, where it always plays back exactly what you’ve recorded, faults and all, although the editing capabilities that you have at your disposal allow you to fix up things like wrong notes or timing problems. However, for this to work effectively, you need to record while playing along to a metronome click generated by the sequencer so that your idea of musical bars and the sequencer’s idea of musical bars agree.

If you don’t want to be forced to follow a click track, simply turn it off and use the sequencer as a recorder, but bear in mind that, when working in this way, you can’t use the internal beat and bar structure to plan your edits or to quantise the timing of your performance.

If your music needs to change tempo during the song, you can do this by entering new tempo values at whichever bar and beat positions you need them. (In the case of Cubasis, this is done in the Mastertrack, which is accessed by the means of the Master button in the transport window.) The click track will then change speed when a tempo change is encountered.

quantisation

Quantisation is a key feature of MIDI sequencing, and it’s probably the reason why much of today’s music sounds the way it does. When you quantise the MIDI data in a track, the timing of each note is changed so that every note falls on an exact subdivision of a bar. The size of the subdivision depends on the quantise value that is selected, but if you’re working in 4/4 time and you select eight as your quantise value then every note moves to the nearest point on an invisible grid, dividing the bar into eight equal intervals. This only works if you played along to the click track; if you didn’t, your bars and the sequencer bars won’t coincide. One thing to be aware of is that, if your musical timing is particularly inaccurate, you may find that quantising your performance makes things even worse, because the nearest quantise step may not be the one to which you intended the note to go. In most cases, you can remedy this by using one of the visual-editing windows of the sequencer to locate any rogue notes and then drag them back to the correct time positions.

More sophisticated sequencers offer a Percentage Quantise function that allows the notes you’ve played to be shifted towards the exact quantise division by a percentage. To take an example, if you set a 50% quantise value, the notes will move to positions that lie halfway between the nearest quantise division and the position at which the note was actually played, which is useful for tightening up a performance without making it sound too mechanical or rigid. Another quantise-related function usually called Swing adds a swing feel to the rhythm by alternately increasing and decreasing the time between successive beats.

tracks and MIDI channels

Newcomers to sequencing often get MIDI channels mixed up with sequencer tracks, but there is a big difference between the two. A sequencer track is something on which you record one of your musical layers, but the MIDI information on that track can be sent on any MIDI channel you like. What’s more, you might decide to have several different tracks all recording MIDI data on the same channel. If this seems like an odd thing to do, consider the situation where you’re recording a drum part from a keyboard. Few people are skilled to do this all in one go, so the most common approach is to use one track to record the hi-hats, another to record the kick drum, another to record the snare and so on. As I said, the drums in a GM set-up are always on MIDI channel 10, so all of these separate drum tracks would also need to be set to channel 10. After recording, you can either keep the drum layers separate to make them easier to edit or you can merge them into a single track to tidy up your screen and to make cut-and-paste editing easier. You could also set up two tracks to the same MIDI channel in order to record the left- and right-hand parts of a piano piece separately, if need be. Figure 3.2 shows the Arrange page of Cubasis VST CE with several tracks set to the same MIDI channel.

Figure 3.2: Arrange page showing tracks running drum parts on the same MIDI channel

cut-and-paste editing

Anyone who’s used a word processor will be familiar with cut, copy and paste actions, and a sequencer lets you edit music with the same degree of ease. You can move individual notes, groups of notes or whole sections of your song, and if you need two chorus sections you don’t have to play the whole section again; you can copy the first one. The copying of whole sections is done in the main Arrange window by dragging with the mouse, and long sections can be broken up into smaller sections using onscreen tools such as the scissors. Individual notes can be moved or copied in the Grid Edit (piano-roll) or Score (stave) pages by clicking and dragging with the mouse. Key commands are often used in conjunction with dragging to facilitate copying, and these tend to follow the same conventions as graphics programs.

Sequencers will record whatever MIDI data you send to them, apart from real-time messages such as MIDI clock. Normally, you’ll have the option of filtering out certain types of data, so if you don’t use aftertouch you can either switch it off at the keyboard end or filter it out at the sequencer end. Normally, you’ll want to record Note On/Off, Velocity, Pitch, Modulation and other controller information, such as Sustain. You may also want to record MIDI Program Changes and Bank Change messages, although it’s sometimes easier to insert these into the sequence data manually. If you find something strange happening, look in the Event Edit list and find out what’s stored there in addition to the Note data.

track information

A sequencer track needs to know certain information in order to be able to function in the way you want it to. For example, you must enter the synthesiser program and bank that you wish to control from that track and also what MIDI channel it is to be addressed on. Different sequencers handle this in slightly different ways, but in most cases there’s a set of parameter boxes associated with each track that tell you the patch, bank, MIDI channel, transpose value, loudness, pan position and quantise value, etc. (Cubase uses an Inspector window, plus several permanent parameter windows, for the entering of track information.)

destructive editing

In the better sequencers, many of the edits that you’ll make — such as quantising or transposing data — are real-time processes, so the original data isn’t changed at all. That means that you can change the settings later, if you want, or even switch off the quantising. Such processes are said to be non-destructive edits, because the original data isn’t altered.

Other editing functions are destructive in that, once your song is saved, the changes are permanent. For example, if you move a note to a new time or pitch, or if you erase or add a note, that’s a destructive edit. The same is true of cut/copy/paste editing in an arrangement, although you can always work on a copy of the original song if you think you may need to go back to the earlier version. Also, there’s the Undo facility, that blessing of the modern age. This at least lets you undo the last action you performed if it didn’t work out as planned.

sequencing a drum machine

You can make use of a drum machine just as you can any other MIDI sound module. If you want to create your own rhythms in the sequencer rather than rely on the patterns programmed into the drum machine, that’s fine. However, you must switch off the drum machine’s External MIDI Sync, or its internal patterns will start to play when the sequencer is started.

the MIDI interface

Your Sound Blaster Audigy card plus the Creative Audigy Drive has a pair of MIDI interfaces that allow your computer to communicate with other MIDI devices, but if your needs expand to the point at which you want to add further external MIDI devices then you may need to use a multiport MIDI interface instead. The MIDI interfaces for older Apple Macintosh machines would plug into the modem or printer serial ports, whereas these days the USB (Universal Serial Buss) interface is more commonly supported by both Macs and PCs. As a rule, if you choose a software sequencer manufactured by a company that also produces a MIDI interface, there’s less likelihood of encountering compatibility problems. It’s also a good idea to choose a multiport MIDI interface to allow for future expansion of your system.

multiport MIDI interfaces

A single MIDI interface can handle up to 16 MIDI channels, as dictated by the MIDI specification. (A Sound Blaster Audigy system has two sets of MIDI ports.) If you need to use two or more multitimbral synthesisers in order to create a composition with more than 16 parts, or if you have several multitimbral synthesiser modules and want to change from one to the other without having to reconnect MIDI leads, you’ll need a multiport MIDI interface. These feature multiple output ports, which are physically separate MIDI Outs that can each carry 16 MIDI channels of MIDI data. However, the sequencer has to be able to support multiport operation. Most of the major packages will do this, but some of the cut-down "lite" versions won’t. Fortunately, there’s usually an upgrade path from the lite version of a sequencer to the full version.

Inside the sequencer, the ports may be addressed by number or letter, so you have 16 channels on port A, another 16 on port B and so on. In this way, you can connect a 16-part multitimbral module to each MIDI Out port and never have to worry about repatching. Figure 3.3 shows how a multi-port system might be configured. In practice, most of these interfaces also have multiple MIDI inputs that merge together. This can be useful in systems that use MIDI patch-library software, as these require that the MIDI Outs of any attached hardware MIDI instruments are fed back to the computer’s MIDI In.

Figure 3.3: Multiport interface

the sequencer paradigm

You may be pleased to know that the Steinberg sequencing software included with your Sound Blaster Audigy card was designed by the company that set the pattern for the way in which most sequencing software looks and operates today. Cubase pioneered the visual multitrack tape analogy, whereby the sequencer tracks are shown as individual tracks one above the other, with musical bars running from left to right. When something is recorded into one of these tracks, a shaded block shows what portion of the track contains MIDI data. This block, or sequence, may then be moved or copied to a new position in the same track — or a completely different track — by clicking and dragging. If a sequence is moved to a different track, it will play back with the sound of the new track. Sequences can also be split into shorter sections or deleted as required.

This main page is used for recording and arranging, and further pages are available for editing, score writing, audio mixing and various other functions. Virtually all sequencers follow this general pattern, whereby the MIDI data can be viewed and edited, either as a list of MIDI events, graphically via a "piano-roll" grid display or by using a conventional musical stave. Figure 3.4 shows some of the edit pages from Cubasis VST CE.

Figure 3.4: Cubasis VST CE edit pages

Because sequencer screens can hold a lot of detail, and because it is sometimes useful to be able to view more than one window at a time, don’t consider using anything smaller than a 17-inch monitor. If you have a computer that can support multiple monitors, so much the better.

saving your songs

When you save a song that you’re working on, it’s stored as a file in a format that is specific to your sequencer software manufacturer, so you can’t usually take a floppy disk with your song on it and then expect to be able to load up the file in your friend’s music studio if he uses a different type of sequencing software. There are also issues in transferring PC files to Macs and vice versa, although, as most Macs have the ability to read PC disks and even format floppies for PCs, this need not be a problem. There are various reasons why song files can’t be transferred freely between different sequencer platforms, one of which is that the files contain information other than just the MIDI data. However, there is a universal format for saving MIDI data that can be transferred between sequencers, although you may lose some of your information — such as patch names, multiport interface assignments and so on — in the process.

This universal format is known as the Standard MIDI File, or SMF, and it can cope with a maximum of 16 tracks at a time. Most sequencers have a "Save As SMF" option. To open a song saved in SMF format in another sequencer, use the MIDI File Import option. Of course, if you’re using a computer with no floppy drive, you can send SMFs as email attachments or burn them to a CD-R. When you open the file, all of the MIDI data will be there, with any quantising made permanent.

help!

I’d like to finish this chapter with a list of problem-solving FAQs relating to MIDI and sequencing. Even the most experienced user has problems, sometimes, and often the cause is something very minor.

You’ve connected up your system and started the sequencer software but there’s no sound. Here’s what to check first.

• It seems obvious, but make sure that your computer, your keyboard and your amplifier system are all switched on!

• Make sure that the sequencer track parameters are addressing the correct sound source. Check your MME driver set-up menu. (The correct setting for use with Sound Blaster Audigy and Cubasis VST CE is shown in Figure 3.5.)

Figure 3.5: MME set-up

• If you’re using external synth modules, make sure they’re set to Multi or Sequencer mode and that they’re set to the same MIDI channels as those on which you’re sending data. Most synths have lights that flash to let you know if they’re receiving MIDI data. If they’re not flashing, check your MIDI cables. My cat regularly unplugs mine!

• If you’re working on a sequence that includes controller data, make sure that you didn’t turn down all of your modules using controller 7 (master volume), as they’ll all stay turned down until you send them new values to turn them up again. The best option here is to place controller 7 values in the count-in bar of the song to set all of the parts at the desired starting levels. In this way, you won’t get caught out.

If you do get sounds but they’re not what you were expecting, check the following.

• If two or more instruments play the same part, check that the modules aren’t all set to the same MIDI channel or switched to Omni mode.

• If your master keyboard plays its own sounds whenever you try to record a track using the sound from another module, you probably haven’t set it to Local Off mode.

• If you hear erratic bursts of sound, stuck notes or apparently limited polyphony, you’re probably experiencing a MIDI loop, in which MIDI data generated by the master keyboard is being passed through the sequencer and back to the input of the master keyboard. Again, see if you’ve forgotten to set Local Off on your master keyboard.

If you have no Local Off facility, disable the sequencer’s MIDI Thru function for the MIDI channel on which your master keyboard is sending.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

MIDI sequencers
the strength of the sequencer
rechannelising
MIDI sequencer set-up
MIDI isn’t audio
click track
quantisation
tracks and MIDI channels
cut-and-paste editing
track information
destructive editing
sequencing a drum machine
the MIDI interface
multiport MIDI interfaces
the sequencer paradigm
saving your songs
help!


chapter 4

audio and sequencing

Digital audio needn’t be complicated, but you need to know about things like sample rates and sync status if you don’t want to run into any difficulties, so please bear with me in the first half of this chapter.

All digital-audio equipment — including soundcards designed to accept analogue signals, such as the outputs from microphones — must convert the analogue input into a digital format before it can process it, and the analogue-to-digital converters used in this work using binary numbers to measure the instantaneous values of analogue audio signals. Strings of ones and zeros are used to represent analogue voltage levels, and as audio information is constantly changing so these measurements have to be taken very frequently in order to build up an accurate picture of the original sound. It therefore follows that a system for converting an analogue signal into digital information (ie an analogue-to-digital converter) must be able to measure analogue voltage at regular and precise intervals. If you have enough instantaneous measurements each second, the original sound can be accurately recreated up to the highest frequency limit of human hearing.

sampling theory

This process of digitising audio is known as sampling, whereby each individual measurement represents one sample, and it’s necessary to sample at a minimum of twice the frequency of the highest frequency that you’re likely to encounter if the output is to be reconstructed accurately. (Figure 4.1 shows what happens when a signal is sampled.) If the sampling frequency is less than twice the highest frequency, additional frequencies will be introduced, based on the sum and difference between the sampling frequency and the audio frequency. These frequencies were never present in the original signal and will sound musically unpleasant.

Figure 4.1: Audio sampling

The process of introducing unwanted frequency components by sampling at too low a rate is known as aliasing, and in order to prevent this it’s necessary to filter out any frequencies in the original signal that are above half of the sampling frequency. Because no filters are perfect, the sampling rate must be made a little higher than twice the maximum audio frequency, which is why, for an audio bandwidth of 20kHz, we have a minimum sampling frequency of 44.1kHz and not 40kHz.

A major factor affecting audio quality is the accuracy with which individual samples are measured, and the more digital bits are used to represent each sample, the more accurate the measurement. CDs and DAT tapes use 16-bit sampling, although many digital multitrack recorders, signal processors and soundcards also offer 24-bit conversion.

Digital numbers progress in whole steps — there are no half bits — and the number of steps depends on the resolution of the analogue-to-digital converter used. Eight bits means just 256 steps, which equates to rather poor sound quality and can lead to quantisation distortion. This actually sounds like noise, the main difference being that it disappears in the absence of a signal. Using more bits gives a vast improvement in resolution, and most digital processors these days use 16- or 24-bit resolution converters, where each bit in a linear sampling system equates to 6dB of dynamic range.

This means that, even if the design is perfect in all other respects, an eight-bit system can only provide a dynamic range of 48dB at best, while 16 bits gives a maximum dynamic range of 96dB and 24-bit systems in excess of 132dB. As you might imagine, nothing is perfect, and so the figures always fall a little way short of these ideal values, especially when it comes to 24-bit recording, where anything better than 120dB dynamic range is considered good.

sample rates

We’ve seen that audio signals can be represented by a series of binary numbers, but these numbers have to be read with exactly the same timing relationship as that at which they were recorded if the end result is to be accurate (ie undistorted). This is where sample rates fit in.

The sample rate is the number of times each second that an audio waveform is "measured" during the analogue-to-digital conversion process. This measuring is done at precise intervals, which are controlled by a very accurate crystal clock. Provided that the same sample rate is used for analogue-to-digital conversion and for digital-to-analogue conversion, the replayed audio will be of the same length and pitch as the original.

Although the minimum sample rate for serious audio work is 44.1kHz, less critical work is sometimes done at 32kHz (which reduces the audio bandwidth to under 15kHz), while broadcasters prefer to work with a sample rate of 48kHz. Typical soundcards support sample rates of both 44.1kHz and 48kHz, but it’s important that everything in your system that’s linked by means of a digital connection is be set to run at the same sample rate, or your final audio recording won’t play back at the same speed as that at which you recorded it. If the end result is going to be an audio CD, you should work at 44.1kHz, if possible. If you can’t work at 44.1kHz (for example, Sound Blaster Audigy’s ASIO driver will only operate at a sample rate of 48kHz), use a piece of software that can handle sample-rate conversion from 48kHz to 44.1kHz before attempting to burn an audio CD. This should be done using the included sample rate converter from EMU which was created specifically for this purpose. It can also be done in either WaveLab Lite or WaveStudio

high sample rates

Today we can add 88.2kHz and 96kHz to the list of standard sample rates, which in theory produce a slightly better sound quality than the 44.1kHz sampling rate used for current CD production. However, few people can actually hear a difference on typical programme material, and my own view is that sample rates above 96kHz only provide a sonic advantage if you’re using the most esoteric equipment to make acoustic-instrument recordings in a very sophisticated studio. In any event, there can only be an advantage in recording at 96kHz if the final result is also replayed at 96kHz rather than converted to 44.1kHz somewhere along the line to make it fit on a CD. To date, only speciality formats such as Sony’s SACD and DVD audio offer this option.

Ultimately, whether you use 24-bit/96kHz or 16-bit/44.1kHz sample rates is up to you, but keep in mind that the number of tracks you can run at any one time and the amount of processing that you can apply will be reduced as you work with more bits and/or higher sample rates. Sound Blaster Audigy’s converters can work at up to 24 bits, but final recordings are always made at a maximum sample rate of 16 bits/48kHz, although Sound Blaster Audigy can input and output sample rates of up to 96kHz in order to provide compatibility with other digital systems working at this rate. Note, however, that the card’s internal sample rate is 48kHz when 96kHz I/O (In/Out) is being used, so the sample rates of signals are converted on their way into and out of the card.

why more bits, anyway?

As current audio CDs use a 16-bit/44.1kHz format, you might reasonably ask why we ever need to record using more than 16 bits. Of course, there is a valid reason. Whenever you process a digital signal by changing its level or by adding EQ, it loses a little of its resolution. Furthermore, a 16-bit signal only has maximum resolution when recorded at its at maximum level. Quieter sounds are recorded using fewer than 16 bits, and the resolution is correspondingly lower. By recording and processing by using more bits that you need for the final delivery medium (ie CD), you can preserve the maximum resolution possible right through to the end of the project. If, on the other hand, you record everything at 16 bits, your final mix might only have a resolution equivalent to 13 or 14 bits by the time you’ve finished all of your processing. Being pragmatic, this is of little concern when dealing with pop music, which generally has a very limited dynamic range, but with discerning acoustic music, extremely quiet passages may end up being more noisy and more distorted than they need to be if recorded at 16-bit resolution.

dithering

A 24-bit master recording can be reduced to a rate of 16 bits using a process known as dithering, which preserves much more of the original dynamic range than simply truncating (discarding) the least significant eight bits (LSB — Least Significant Byte). Essentially, a tiny amount of pseudo-random noise is added to the signal to dither very low-level digital information, but in order to prevent this noise from compromising the apparent signal-to-noise ratio of the recording it can be mathematically designed so that it appears high in the audio spectrum (usually above 15kHz), where the human ear is least sensitive. This refinement is known as noise-shaped dithering, and it allows the music to remain audible and relatively undistorted as it fades down into the noise floor, just as it does with analogue tape. Without dithering, the signal would get progressively more distorted at lower levels before ceasing abruptly as the least significant byte turns off. Dithering should always be the last process that the signal undergoes before being burned to a CD (the final stage of mastering), if it is to be effective.

digital connections

Unlike analogue systems, where every signal needs to be sent down a separate cable, digital systems allow two or more signals to be sent along the same cable while remaining completely separate. How this apparent magic works is not important at this stage, but the words clocking and sync need to be explained.

Say you have a soundcard with a digital input and you want to transfer some music from a DAT (Digital Audio Tape) recorder or MiniDisc player into your computer in the digital domain. The first step is to connect the digital output from your player (probably via an S/PDIF phono connector) to the digital input of your soundcard. S/PDIF is a standard connection protocol developed by Sony and Philips (hence Sony/Philips Digital Interface) for consumer digital equipment, and on some equipment it may be provided as an optical port as an alternative to — or in addition to — the phono co-axial connector.

DAT and MiniDisc players incorporate their own highly accurate crystal clocks which control the rate at which the samples of data are played back in order to ensure that they are at the same rate as they were when they were originally recorded. For these little slices of data to get into a computer, the computer’s sampling clock has to be running at exactly the same rate as that of the player, but if the player and computer are allowed to run independently then their clocks will always run at slightly different speeds, even if they’re both set to the same frequency, resulting in clicks and crackles in the audio as the two clocks drift in and out of sync with each other.

clock sync

Fortunately, the digital data carried along an S/PDIF cable also carries the clock signal from the first machine, and this is used to synchronise the clock in the receiving device. However, the receiving device often has to be switched into Digital Sync mode for this to happen. (Figure 4.2 shows a digital tape machine feeding the input to a soundcard.) The rule is that the source device runs from its own clock (in Internal Sync mode) and the receiving device is set to Digital Sync. Multiple devices can be cascaded in this way, but stringing more than three digital devices in a chain may cause problems if the clock signal gets corrupted.

Figure 4.2: Digital sync (a DAT machine feeding a soundcard)

Note that more and more professional equipment is using the so-called AES/EBU digital interface, which can usually be identified by the use of XLR connectors rather than phono sockets. In any event, the sockets are normally marked clearly on the equipment rear panels. Both S/PDIF and AES/EBU carry a stereo signal plus a clock, but they operate at different voltage levels and so aren’t compatible, strictly speaking, even though you can sometimes get away with using an adaptor lead between the two. AES/EBU is balanced by using 100-ohm cable, has a nominal 5V level and will work with conventional mic cables over short distances, while S/PDIF is an unbalanced 75-ohm system operating at around 0.5V.

The main advantage of S/PDIF is that CD track IDs are carried as part of the data format, while with AES/EBU these are stripped out. On the other hand, AES/EBU ignores the SCMS (Serial Copycode Management System) copy-protection system used in some digital devices to prevent cloned tapes from being recopied in the digital domain.

Note also that the digital inputs present on the Sound Blaster Audigy system provide high-quality sample-rate conversion, which means that the card always runs in Internal Sync mode. Not only does this mean that the user doesn’t have to think about sync settings, but it also means that the two digital inputs can be used at the same time with signals that may not be running at the same sample rate.

word clock

More complex professional systems have a word clock facility, whereby the sample clock is fed via separate sockets rather than embedded in the digital audio signal. Word clock usually travels via unbalanced cable terminated in bayonet-fitting BNC connectors and, as with other digital interconnects, it will normally be clearly labelled on the rear panel of the equipment. As with any other digital clocking system, there can only be one master — all of the other devices act as slaves, locking to the master clock, which may come from a separate, high-accuracy clock generator with multiple outputs.

Be aware that many semi-pro pieces of studio equipment have rather poor master clocks that can introduce something called jitter (see below) into the rest of the system, resulting in a degradation of both audio quality and signal-to-noise ratio. While it’s true that digital audio data is simply a stream of numbers, these numbers must be the right values and delivered at exactly the right time if the original audio signal is to be adequately represented. The weakest link in the chain is probably the analogue-to-digital (A-to-D) converter, the job of which it is to sample the incoming audio signal and convert it into a stream of numbers. The part of the circuit that does the measuring is actually a very refined digital voltmeter, and if this doesn’t measure the signal accurately then the numbers will be wrong and the result will be distortion.

The measurements also have to be made at precisely regular intervals (ie the sample rate), although poor design, bad circuit-board layout, poor clock design and other factors can result in jitter. Jitter occurs when the sampling period varies slightly, rather than being constant, resulting in the audio waveform being sampled just before or just after the correct time, again resulting in the wrong value being stored. Jitter manifests itself as increased noise, reduced clarity and poor stereo imaging.

sample-rate conversion

In situations where you want to work at one sample rate but some or all of the source material is at another, sample-rate conversion will be necessary. This may be accomplished either by an external hardware box, which will take in a digital signal at one sample rate and output it at another in real time, or it can be done in the software domain. For example, material recorded onto DAT at 48kHz must be converted to 44.1kHz for CD mastering, or the audio will play at around 10% slower and pitched down accordingly. Sound Blaster Audigy automatically converts sample rates at the digital inputs to the internally set sample rate for processing, so no extra hardware is needed.

the sequencer revolution

First came MIDI, then came the ability to record audio onto a hard drive in real time. It didn’t take long before somebody figured out how to put them together to produce the most powerful musical compositional tool ever. The result was the MIDI-plus-audio sequencer, on which it’s possible to set up some of the sequencer’s tracks to record MIDI information and others to record regular audio, just like a tape recorder. Both MIDI and audio appear on the same screen, and many of the edit functions — such as cut, copy and paste — work the same on audio tracks as they do on MIDI tracks. This makes it very easy to work with songs that combine audio and MIDI, as everything can be managed from within the same environment, whereas previously it would have been necessary to sync up a MIDI sequencer to a hardware multitrack recorder. (The Arrange page of Cubasis VST CE is shown in Figure 4.3. Note the audio and MIDI tracks.)

Figure 4.3: Arrange page in Cubasis VST CE Arrange

Audio can be recorded into a computer-based sequencer via a soundcard or external audio interface, and Sound Blaster Audigy is capable of recording both regular analogue audio signals and digital signals from CD players, DAT machines, MiniDisc recorders and other digital-playback devices. Audio may also be imported directly from other hard drives or CD-ROMs containing audio data, and there’s a selection of software available that will allow you to import audio files directly from audio CDs, which can be handy if you want to use some of the excellent library sounds and drum loops that are available in audio-CD format. Just be sure to respect the copyright laws and not to use anyone else’s material without permission!

Before moving onto the features offered by modern MIDI-plus-audio sequencers, it’s a good idea to look at some of the basics of digital recording as it applies to computers.

audio and hard drives

When you record audio into a computer, it’s converted into binary data and stored on your hard drive, and the faster the drive’s sustained data-transfer rate, the more tracks of audio it can play back at one time. Modern internal hard drives tend to be EIDE (sometimes known as Ultra DMA) models, and, unless you’re working in a specialist area where you need a huge number of audio tracks, they work fine for between 16 and 24 tracks of simultaneous audio playback. Those needing more tracks should consider a fast SCSI drive and interface card or a FireWire drive. The Sound Blaster Audigy system includes an SB1394 port (IEEE1394 compliant aka FireWire) for the connection of external peripherals, including video cameras and hard drives.

If you plan to work with EIDE drives, you should ideally install a second hard drive purely for audio use so that you can defragment it without affecting your program files. Audio takes up a lot of space, so go for a 20GB drive or bigger. Defragmentation is necessary because constantly recording and erasing files results in your information being spread around the disk, and this means that the drive mechanism will take longer to find it. If your hard drive is badly fragmented, this will reduce the number of audio tracks that you can play back at one time, and in extreme circumstances you may hear glitches (breaks or clicks) in the audio playback. If you don’t want to install a second drive, at least consider creating a separate partition for your audio files using a program such as Partition Magic.

how many tracks?

Track counts are usually calculated at an audio sample rate of 44.1kHz or 48kHz and a bit depth of 16 bits. (44.1kHz/16-bit resolution is the same format as CD and MiniDisc.) If you need to work at higher bit resolutions and/or higher sample rates, the track count will fall proportionally. EIDE drives also require attention from your computer’s CPU, and so, if the CPU load is heavy, this might also reduce the number of tracks that you can play back. When you’re recording, your CPU and hard drive must have enough capacity to handle the new track(s) being recorded at the same time as playing back the tracks you’ve already recorded.

If your final product is going to be an audio CD, record either at 16 bit or 24 bit. (24 bit is good for acoustic music that has a wide dynamic range.) Even though the final CD will still only use 16 bits, you can use noise-shaped dithering to reduce your 24-bit mix to 16 bits while retaining most of the original dynamic range. With noise-shaped dithering, the dither noise is added at frequencies at which the human ear is least sensitive, usually between 15kHz and 20kHz. As a rule of thumb, if you’re working at 16-bit/48kHz resolution, you’ll need roughly 6MB of hard-drive space for each track/minute of audio you record.

random access

Unlike a tape machine, a computer doesn’t use up valuable recording space on a track during sections that you wish to leave silent. For example, you probably wouldn’t want to record anything onto a vocal track during an instrumental solo, but on a tape machine that unused section of vocal track would still be wasted space. With a computer, however, disk space is only used up when you make a recording. What’s more, if you decide to use a part of your recording more than once (as you might with a chorus or a section of backing vocal), this doesn’t take up any more disk space, either. This is because making a copy of a section of audio in the Arrange page of your sequencer actually uses the same section of audio twice, so it doesn’t have to be copied to the hard drive a second time. However, if you were to copy a section of audio and then perform some destructive editing on the original, that edit would affect that piece of audio in every instance that it was used.

the virtual mixer

Most MIDI/audio sequencers offer more tracks of recording than the hardware can provide physical outputs for. For instance, many basic soundcards have only stereo outputs, although the Sound Blaster Audigy has six analogue outputs and one digital (stereo) output, and all six analogue outs may be accessed directly by Cubasis VST CE. This means that you need some way of mixing or combining your audio tracks (and any MIDI sounds from the soundcard) inside the computer. This is why MIDI/audio sequencers include a virtual mixer section to combine the audio outputs from the different tracks and mix them down, usually to stereo. If the soundcard has multiple outputs, the mixer will include the means of routing audio tracks to the various outputs, where they may be used to feed an external mixer.

The most common mixer controls are level and pan for each audio track, and there may also be provision to add EQ (tone control). Most virtual mixers provide EQ, but in practice this is usually called up when needed rather than always being there whether needed or not (as is the case with a hardware analogue mixer). EQ uses up valuable processing resources, so it makes sense to call it up only when needed. If more sophisticated EQ is required on a particular track, it may be possible to use an EQ plug-in instead.

These days, it’s routine for some level of mix automation to be provided so that changes in level, pan position, EQ and even effects plug-ins can be recorded, just like any other MIDI data. When the song is played back, the fader changes happen in just the way you programmed them. If you need to make any alterations, these can be done at a track a time. This is known as dynamic automation.

The way in which mix automation works in practice is that the knobs or faders on your virtual mixer generate MIDI data when you move them, and when you’re recording automation moves (in Write mode) this automation data is stored by the sequencer, just like any other MIDI data. You can record automation moves for all of the tracks, some of the tracks or just a single track, and if you’re not happy then you can go back and refine what you’ve done. You can also work on just a few bars of music at a time, if you prefer. It’s also quite common to have a graphical display of the automation data, which will allow you to edit the mix automation using the mouse to move lines on a graph plotting level against time. Cubasis VST CE allows you to automate any mixer parameter, and the automation is very simple to use, with Read and Write mode buttons selecting whether automation data is being recorded or played back.

It’s also becoming increasingly commonplace for software manufacturers to build in facilities for surround-sound mixing. Although few home studios have adequate monitoring systems to mix surround material to a professional standard, it is possible to achieve extremely worthwhile results, and software packages that enable surround recordings to be burned onto CD-Rs in DTS format are starting to become available to home-studio users. DTS has the advantage that it can be recorded onto regular CD-Rs, rather than the more costly DVDs, and it can be played back on most DVD players. Sound Blaster Audigy’s surround features are designed for use with games, multimedia and music software. The outputs are individually adressable by the bundled version of Cubasis VST CE and other ASIO compatible software for creating surround-sound mixes.

VST plug-ins

The virtual mixers found in sequencers often support third-party plug-in effect, such as Steinberg’s VST standard, or they may come with built-in effects. A plug-in is a separate piece of software that works within a host program, such as a sequencer, to give it more features. In conventional studio terms, it’s like plugging in more effects boxes or signal processors.

The idea behind VST (Virtual Studio Technology) is to provide a standard format to allow third-party software writers to create interesting effects programs that can be plugged into VST-compatible sequencers and other audio software, regardless of manufacturer. These virtual processors can provide all of the studio effects that you’d expect to get from hardware boxes and a few more besides, but all of their power comes from the host computer, which means that you need a pretty powerful computer to get the best out of them.

Once a plug-in is installed, you can access it from a menu of effects inside the mixer section of the sequencer, and most plug-ins have realistic user interfaces that mimic the front panels of hardware devices. The controls may be adjusted via the computer mouse, and settings can be stored for later use. VST plug-ins may also be automated, which means that changes to their settings can be recorded into a sequence so that they play back dynamically.

In addition to effects, there are now VST instruments, which include software emulations of synthesisers, samplers, drum machines and so on. As with VST effects, VST instruments can take a lot of processing power, so a fast computer fitted with plenty of RAM is essential. Both VST effects and VST instruments will be discussed in more detail in the next chapter.

monitoring and latency

When you first make a recording, you’ll probably be singing or playing along to some MIDI parts that you’ve recorded previously. The process of listening to older tracks while you record new ones is known as monitoring. When you monitor what you’re recording (usually via headphones), you may notice a slight delay or echo which is known as latency, one of the less fortunate side-effects of computer-music systems. Fortunately, with a fast computer and appropriate software, the latency value should be too small to be of concern, although it can be a problem with some slower systems. Before exploring the various solutions, it will be helpful if I explain what latency is and what it’s caused by.

When audio is recorded into a computer, it first has to be converted from analogue to digital data, and this introduces a very small delay. After that, the way in which the audio data is processed and routed introduces a further delay, which may vary from just a few milliseconds (virtually undetectable) to a very obvious echo. Much depends on the speed of the computer, the amount of RAM buffering that’s needed to secure a reliable audio performance and how well written the audio software and its drivers are. This latency delay is compensated for on playback, but when you’re actually recording something this latency can affect your ability to sing or play in time, especially if it’s longer than 20ms or so.

Soundcards and interfaces that are fully compatible with the ASIO II driver standard (another Steinberg innovation) provide thru monitoring of the input by routing the audio being recorded directly to the audio out of the soundcard during recording or overdubbing. In other words, you hear the tracks that you’ve already recorded mixed in with the live sound of your vocal mic or instrument when you’re overdubbing. You can’t apply VST effects to the monitor signal, however, as the audio is no longer going via the processor, but you can add effects after you’ve made the recording if you want to. Sound Blaster Audigy automatically monitors the source signal during recording, so latency is never a serious issue when recording audio, even on slower computers. However, in order to play a VST instrument from a keyboard, the audio part of your system needs to have a very low latency value, or you’ll notice the lag between playing and hearing the sound. A long latency makes normal playing impossible, especially with sounds that have a fast attack, such as pianos. One (not entirely satisfactory) way around the problem is to record the part using a regular MIDI sound source — which has no appreciable latency — and then switch the track to the VST instrument after you’ve recorded it. Fortunately, the ASIO driver that comes with the Sound Blaster Audigy system is able to achieve very low latency figures, so virtual instruments respond quite quickly.

mixer layout

In a conventional studio, you have a mixer with separate faders controlling the levels of the individual tracks that you’ve recorded so that you can determine the relative levels of the different parts or layers of your composition. Being able to set up a good sound balance is one of the most important parts of a sound engineer’s job. Desktop computer systems allow you to mix in the same way as you would on a big studio console, the main difference being that virtual mixers have onscreen faders that you move with a mouse rather than physical faders. Rotary controls — such as those that govern pan, effects send or EQ — can usually be adjusted by clicking on them with the mouse and then either moving the mouse left/right, up/down or around in circles — it all depends on which method the software designer prefers. A separate virtual mixer channel is used for each sequencer audio track, and the final mix is routed to the soundcard outputs. If you prefer to mix with real faders, there are a number of MIDI controllers on the market that are essentially boxes of faders that generate MIDI control information. Figure 4.4 shows the Mixer section of Cubasis VST CE.

Figure 4.4: Mixer page in Cubasis

waveform editing

Computers allow you to do things that would never have been possible with a tape recorder, but if you want to go one step deeper than basic copy-and-paste editing you can view sections of audio as waveforms and perform various operations on those waveforms. The most basic (but also one of the most useful) features is the ability to select and silence sections of audio, and because you can "see" the audio onscreen while listening to it you can see exactly where to make your cut.

Other common edit-page functions include the ability to change gain, to reverse whole sections of audio (ie to create a backwards-tape sound) and to create fade-ins and fade-outs. Cubasis allows you to "nominate" a separate waveform-editing program that will open whenever you double-click on a piece of recorded audio. Steinberg’s WaveLab Lite is a good choice, although Creative WaveStudio — included in this package — has some useful editing features, as well as a de-noising feature. Figure 4.5 shows a waveform in WaveLab.

Figure 4.5: Waveform Edit page in WaveLab

time and pitch manipulation

Facilities vary from one software package to another, but pitch change and time stretch are supported by most sequencers, either as built-in functions or as optional plug-in effects. These features are invaluable for processing audio sample loops (as is the included ReCycle software) so that they fit alongside other audio elements, and they may operate either in real time or offline. Offline processes are destructive, but because they don’t have to hurry they can often do a better job than real-time processes. They also don’t use up any computing power during playback because, once the process is complete, they create a new audio file with the changes made permanent.

audio in arrangements

Most musicians spend the bulk of their time using the Arrange window of their sequencers, as it’s here that recording is initiated and the most common copy and paste edits for both audio and MIDI data are handled. Starting and stopping is actioned from a tape-recorder-like transport section, and audio tracks normally have to be set to Record Ready mode before anything can be recorded onto them.

When you drag an audio or MIDI part to a new location in the Arrange window, it will often snap to the nearest beat rather than just land where you put it, so it’s important to familiarise yourself with the key commands that allow you to drag MIDI and audio sections around in such a way that they snap to finer increments (such as the selected quantise value) and the ones that allow them to be moved completely freely. Also, make sure that, when you delete a piece of audio from the arrange window, you won’t delete the audio file itself but will simply remove it from the current song. If you need it later, you can re-import it back into the song, but if you don’t need it, you can erase it permanently to recover the disk space that it used.

Unless you’re very careful, you can end up with a hard drive full of audio files with cryptic filenames. Study your sequencer’s manual and see what’s the best way of bringing some order to this potential chaos. One way is to make sure that the audio files have names that relate to the song of which they’re a part. Also, try to erase unwanted takes as soon as you’re sure that you won’t need them again, as they just add to the confusion.

audio and clocks

As explained earlier in the chapter, when audio is recorded onto a computer via a soundcard, the audio data is "clocked" by a crystal clock (on the soundcard) that determines the sample rate of the recording. When recording from an external digital source, the clock in the source machine must be the master and the sequencer must be set to External Clock mode for the duration of the recording (unless the input includes sample-rate conversion, as in the case of Sound Blaster Audigy). Because the external clock may not run at exactly the same speed as the clocks on your soundcards, the playback speed may change slightly when you switch back to internal clock, but in practice crystal clocks are very accurate, so the timing discrepancies should be insignificant, unless the audio segment is very long.

However, the same is not true if you use MIDI time code or MIDI clock to synchronise the sequencer to a less than perfectly stable outside source, such as a tape recorder (using a suitable MIDI-to-tape sync device). In this instance, the audio will play back at a fixed rate governed by the soundcard clock, but the MIDI playback may vary slightly as the tape speed fluctuates, giving rise to audible timing errors. The most common way around this problem is to chop the audio tracks into shorter sections. Each section will always start at the correct time, because it’s triggered from the MIDI timing engine, and the shorter the section, the less chance it has to drift out of time before the next section starts, so the effect won’t be cumulative.

audio loops

The audio loop is the cornerstone of dance music, but, because most loops are rhythmic, precise timing is very important. Again, using separate audio loops one or two bars long will provide tighter timing than using very long tracks, and if you need to use drum loops at a different tempo then Steinberg’s ReCycle software offers a very powerful set of tools that will enable you to achieve this without experiencing the audible side-effects of pitch shifting. ReCycle enables the tempo of a rhythmic loop to be changed by in excess of +/-10% without unacceptable side-effects and without changing its pitch. The available pitch range is often much greater than this before the sound quality is adversely affected.

recording levels

With any digital recording system, it’s best to optimise the level of your input signal at source, because soundcards don’t usually have an analogue gain control between the input and the analogue-to-digital converter. Many systems provide digital gain controls after conversion, but if your input is at too low a level then some resolution (sound quality) is lost before the signal gets to the gain control. Sound Blaster Audigy has both mic and line inputs, but if you’re really serious about recording and want to use a studio quality microphone then it would be worth investing in a hardware box called a recording channel. These vary in price and facilities provided, but most include a mic and line pre-amp (with switchable phantom power for capacitor microphones), followed by a compressor (to keep the levels even) and possibly an equaliser. The user would normally feed this into one of the line inputs of the Sound Blaster Audigy card and adjust the recording level on the recording channel itself while watching the software record-level meters on screen.

Try to keep your peak levels just a few decibels below the level at which clipping occurs in order to achieve the lowest level of distortion and the best signal-to-noise ratio. Unlike tape systems, digital systems have no safety margin above 0dB, so if you go into the red you’ll probably hear distortion. Regardless of whether you have 16- or 24-bit recording capability, the ultimate quality of your recording will be defined at source, and in most cases the dynamic range of a 16-bit system will exceed the dynamic range of the analogue signal being recorded.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

audio and sequencing
sampling theory
sample rates
high sample rates
why more bits, anyway?
dithering
digital connections
clock sync
word clock
sample-rate conversion
the sequencer revolution
audio and hard drives
how many tracks?
random access
the virtual mixer
VST plug-ins
monitoring and latency
mixer layout
waveform editing
time and pitch manipulation
audio in arrangements
audio and clocks
audio loops
recording levels


chapter 5

audio mixers

Mixers, whether hardware or virtual, are a vital part of any audio system. In a traditional studio, the mixing console is the central control panel for the studio. Not only does it allow you to change the level and EQ of individual signals but it also provides a means of routing signals to and from a multitrack recorder or to external effects and processors. Large studio consoles can be intimidating at first sight, but when you break them down into logical sections you’ll find that they are really pretty straightforward, and most of those intimidating controls are there because the same functions are repeated many times for different audio channels.

In the software studio, the mixer exists entirely inside your computer, but you may be surprised to learn that it offers pretty much all of the facilities that you’d find on a big studio console — including mix automation — and often some features you wouldn’t find on a hardware mixer. It really helps if you understand the basics of mixing before you begin to use your virtual studio, and the simplest way of doing this is to look at a how a simple hardware mixer does its job. Cubasis VST CE places a very powerful music studio at your fingertips, and just as the traditional engineer has to find his way around the hardware in the studio, so you need to familiarise yourself with your software.

the building blocks

All mixers, whether real or virtual, comprise several identical "building blocks" known as channels, and these channels are fed from individual audio tracks. The main purpose of a channel is to allow the level of the signal being fed into it to be changed, to enable the signal to be EQ’d and to provide routing. Routing includes the ability to send the signal to what is known as a mix buss, which is a kind of electronic highway, where the outputs from two or more channels are added together to form a single, composite signal. Mixers also enable you to route signals via effects and processors.

mic and line levels

Internally, analogue mixers are designed to work within a particular range of signal levels, usually up to 10V or so, whereas digital mixers have their maximum ranges determined by their internal digital headroom. There are two types of mixer inputs, those optimised for either microphone-level or line-level signals, and in the case of the soundcard studio you’ll find that your soundcard also has separate mic and line inputs.

Line-level signals are generated by effects units, tape machines, CD players, MiniDisc players and many electronic instruments, but the signal produced by a microphone is very small in comparison. The microphone pre-amp’s job is to bring the mic level up to line level.

Note, however, that, in order to use a professional microphone that requires 48V phantom power, you’ll need a separate mic pre-amplifier with integral phantom power connected to the line input of your soundcard. This is because the capacitor microphones used for professional voice and instrument recording require power to operate, and phantom power is simply a standard method of sending 48V along the mic cable from the mixing console or mic pre-amp. Dynamic microphones — such as those you might use for live performance — don’t need phantom power, but they still need a pre-amplifier to bring their outputs up to a useful level.

Phantom powering can only be connected to balanced microphones, although it won’t do any harm when connected to balanced dynamic microphones that don’t need it. However, it should never be connected to unbalanced microphones. As a rule, if the mic body is fitted with a three-pin XLR socket, it is balanced. (You can find out more about microphones in the chapter on "Recording With Microphones".) Soundcards are invariably designed without 48V phantom power, although some provide a low voltage supply for powering consumer electret microphones.

channel gain

Because microphones don’t all produce the same level of output, and because their output levels depend on the closeness and loudness of the sound being recorded, separate microphone amplifiers are invariably equipped with a gain control that determines the amount of amplification that is applied to the signal. Line-level signals don’t need to pass through the microphone amplifier, which is why both mixers and soundcards have separate mic and line inputs. The line input on a typical mixer will also be fitted with a gain control, although on a soundcard it’s more likely that you’ll have to adjust the source level on the device that’s connected to the input. On Sound Blaster Audigy, this is the mic/line input on the Audigy Drive. (Note that the microphone/line input on the Audigy Drive unit has a gain-control knob, while that on the Sound Blaster Audigy card itself doesn’t.)

You can change the level of the signal once it is in the mixer, but for the best audio quality you should arrange for the source level to be as high as possible without the peaks being clipped. Onscreen meters in the audio software that you’re using will help you to set the optimum level, while on a hardware mixer physical meters would be used.

mixer channels

Figure 5.1 shows a simplified schematic of a four-channel mono mixer with simple bass and treble equalisation. Separate mic and line gain controls are shown to aid clarity, but remember that a soundcard input probably has no physical controls, so it would be up to you to adjust the level at source.

Figure 5.1: Simplified four-channel mono mixer

After the input-gain stage comes the equalisation section, which can be as simple as the bass/treble (also known as hi/lo) arrangement shown here, or it can be a complex, multiband affair, as is more common in serious semi-pro and professional mixers. It’s generally possible to bypass EQ, and if you need something more powerful there are plug-ins to cater for the most sophisticated type of equalisation. (All VST plug-ins have a Bypass button, where applicable.) Cubasis has a two-band parametric EQ on each channel, and this is flexible enough to handle most tasks without needing an additional EQ plug-in.

Finally, the signal level is controlled by a knob or fader before it passes to the mix buss, usually via an On or Mute switch. Note that all of the input channels are identical, and a larger mixer would simply have more input channels.

After this, the combined signal on the mix buss passes through further amplification stages that are controlled by a master level fader, which sets the output level of the mixer.

stereo mixers

A stereo mixer is only slightly more complicated than a mono mixer, as can be seen from Figure 5.2. Here the input channels have an extra control for panning the signal between the mixer’s left and right outputs. When the pan control is turned completely anticlockwise, the channel signal is routed exclusively to the left mix buss, while turning the control clockwise routes the signal to the right buss. Leaving the pan control in the centre routes equal amounts of signal to the left and right busses, making the resulting sound appear to originate from midway between the speakers in a stereo speaker system. The left and right mix busses are usually referred to as a single stereo mix buss.

Figure 5.2: Stereo mixer with output meters

In a stereo mixer, there are two master faders, one for the left output and one for the right, although some mixers use a single stereo control. Figure 5.2 also shows a stereo-level meter, which allows the user to monitor the output level of the mixer, and in the virtual mixer this meter will invariably be in the form of a bar graph. A stereo mixer of this type is usually described in the form "something into two" — for example, a twelve into two (12:2) mixer has twelve input channels and two outputs (left and right).

auxiliaries

So far, I’ve explained the EQ controls, the pan control and the level fader, but in recording it’s also necessary to do things like add effects or send a mix to the performer’s headphones, and there has to be some way of providing a different balance on the cue output than that on the main stereo mix outputs. For example, singers usually need to hear more of the vocals than of the instrumental backing. It’s possible to set up a monitor cue mix in a virtual mixer, as long as your soundcard has at least one more output in addition to the main stereo outputs.

pre-fade send

Both effects and cue monitoring (sometimes called foldback) can be handled using the auxiliary controls on a mixer, as shown in Figure 5.3. Here you can see two new controls, aux 1 and aux 2, where "aux" is short for auxiliary. Aux 1 is simply another level control which feeds a mono mix buss running across the mixer to the aux 1 master level control and then to the aux 1 output. The signal feeding the aux 1 control is taken before the channel fader and so is known as a pre-fade send. The implication of this is that the signal level at aux 1 doesn’t change if the channel fader is moved, making the pre-fade aux send level completely independent of the channel faders, which is necessary when setting up a cue mix for the musician or when the singer performs an overdub.

Figure 5.3: Aux controls

The overall aux 1 mix — which comprises a mix of the aux 1 feeds from all of the mixer channels — is adjusted via the aux 1 master-level control, and the aux 1 output would normally feed a headphone amplifier. By adjusting the various pre-fade sends, an engineer can set up a monitor mix with which the performer feels comfortable. In the soundcard studio, the aux 1 signal would be routed to a spare soundcard output, which would in turn feed a headphone amplifier. However, in systems where there is no provision to connect a headphone amplifier, it’s usually possible for the performer to perform overdubs while listening to the main mix.

post-fade send

The second aux control, aux 2, takes its feed from after the channel fader (post-fader), so its level is affected by changes in the position of the channel fader. This is exactly what’s needed if aux 2 is being used to feed an external effect, such as reverb, because, when the channel signal level is turned up or down using the fader, the amount of added effect has to change by the same amount.

By using different settings of the aux 2 control on each channel, it’s possible to send different amounts of each channel’s signal to the same effects unit, the output of which is added back into the main stereo mix. When using this arrangement, different amounts of the same effect — such as reverb or echo — can be added to different sounds in a mix. In the software mixer, the VST effects rack takes the place of external effects units, but it’s still fed from channel aux sends in the usual way, so it’s very much like using a "real" mixer. Effects unit used in conjunction with a channel aux send should be set so that they produce only the effected sound and none of the original, unusually by setting the effects mix control to 100%. The channel aux sends then determine the amount of effected sound added to the original, "dry" sound passing through the channel. By having multiple post-fade sends, multiple effects units or effects plug-ins can be connected, and all of these can be applied independently to the different channels.

The diagram in Figure 5.3 also shows how an external effects unit is connected to a hardware mixer, which is broadly similar to the way in which Cubasis handles virtual effects. All of the controls shown in the figures are arranged in a logical order in order to illustrate the signal flowing through the channel, although mixers typically tend to have their pan and aux controls located above the channel fader for convenience.

insert points

Another way to connect an effects unit or signal processor to a mixer is via an insert point. All serious stand-alone mixers and all VST-compatible virtual mixers have insert points on their main channels and also on their master stereo outputs. An insert point is just a socket (real or virtual) that allows the signal path through a normal channel or stereo master to be interrupted and re-routed through an external device. Once a plug-in has been called up, all of the signal flows via the plug-in rather than directly through the channel. Cubasis allows one insert effect per channel, while the full version of Cubase offers up to eight inserts per channel, allowing effects or processors to be connected in a chain.

Figure 5.4 shows the location of the channel insert points in a typical VST-compatible mixer, and the routing for effects sends as they apply to the Cubasis mixer is also shown. The pan controls have been omitted to make the diagram easier to read.

Figure 5.4: Channel insert points

multitrack mixers

Studio consoles are designed to allow whole bands to record at once, which involves a lot of complex signal routing. In the virtual studio, however, it’s more usual for musicians to add one or two parts at a time in order to build up a composition in layers, and so the recording side of the virtual mixer tends to be fairly simple. Most of the time, all you’ll need to do is switch a track to Record and then set the level of the signal to be recorded at its source. You can also set the level of the signal that you hear in the mix by using the channel fader so that you can establish a comfortable working level. While in many VST-compatible programs it’s possible to add virtual effects as you record, it’s generally safer to leave effects to the mixing stage so that you can hear all of the recorded tracks in context.

tracks or channels?

The terminology associated with mixers can be a little confusing, and a common mistake that even experienced users make is to refer to a mixer as having so many "tracks". In fact, mixers don’t have tracks; they have channels (inputs), and groups (outputs). It’s recorders that have the tracks, and these tracks are generally fed to mixer input channels. Of course, it’s perfectly possible to feed track 1 to mixer channel 1, track 2 to mixer channel 2, etc, and so avoid confusion.

groups

Up until now, we’ve talked about mixers with simple stereo outputs, but when you’re working with a lot of audio tracks it’s sometimes useful to be able to route selected groups of channels through an intermediate type of mixer channel that allows you to control the level of the entire group (usually in stereo) via a single fader. Hardware mixers have a fixed number of groups, and the signals are routed to them via switches, but in the virtual mixer it’s normal to be able to add more groups as required.

Any of the input channels may be routed to any of the groups, and if two or more channels are routed to the same output then they are automatically mixed together. As before, the channel faders set the relative levels of the various elements in the mix, but now the group fader controls the overall level of the group. The outputs from any of the groups you’ve set up are routed back into the stereo mix, and if you set up your groups carefully, this simplifies the act of mixing considerably. For example, you may have a recording of 20 or more audio tracks, many of which can be grouped so that, for example, you only have to adjust a drum/bass group, a backing-vocal group, a keyboard group, a lead-vocal track and a guitar track. Without grouping, you’d need to mix using all 20 faders, but in this example you need use only five. Simplifying a mix in this way — by separating sounds into logical groups — is called subgrouping.

Figure 5.5 shows a group-routing arrangement as it applies to both hardware and software mixers. Hardware mixers handle group routing by using switches alongside the channel faders, whereas virtual mixers are more likely to use a drop-down menu system, offering you a choice of possible destinations for each mixer channel.

Figure 5.5: Grouping

The Cubasis mixer doesn’t have grouping facilities, although it does have two additional stereo busses, to which channels may be routed, as shown in Figure 5.6. This may in turn feed alternate outputs on the soundcard, making for greater flexibility when an external mixer is also being used. Of course, if you want to experiment with grouping, you’ll need to upgrade to the full version of Cubase VST.

Figure 5.6: Cubasis buss routing

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

audio mixers
the building blocks
mic and line levels
channel gain
mixer channels
stereo mixers
auxiliaries
pre-fade send
post-fade send
insert points
multitrack mixers
tracks or channels?
groups


chapter 6

effects and processors

Adding effects and processors to the audio you’ve already recorded really opens up the creative possibilities of computer music — you can make tonal changes to vocal and instrument parts, control peaks in the signal level using a compressor or add echo and reverb to make any sound more interesting. Note, however, that VST effects can only be applied to audio tracks; you can’t use them on MIDI tracks controlling external hardware or soundcard sound generators.

Before you start loading in those plug-ins, it helps to know a few basic facts, the most important one being the difference between an effect and a processor. This difference is very important to understand, because effects and processors are generally connected and used in different ways.

There are devices that treat the whole signal and devices that add a proportion of treated signal to the unprocessed signal in order to create their effects. The term "processor" is commonly used to describe devices that treat the whole signal and "effect" is used where a mix of processed and unprocessed sound is involved. Examples of processors include gates, expanders, compressors, limiters, equalisers, enhancers and distortion devices, all of which are characterised by having no mix control (with the exception of some enhancers, where the mix control determines the depth of the effect). Examples of effects include reverberators, digital delay lines, chorus units, flangers, ADT units and pitch shifters. (If some of these seem unfamiliar, don’t worry as all the common effects and their applications are described in this chapter.)

All effects have a mix control, which enables the user to blend the processed and unprocessed sound together. Most effects rely on some kind of time delay, even if it’s a very short one, as is the case for chorus and flanging.

There are two main ways in which an effect can be used: via an insert point or in an effects send/return loop, fed from an aux send. This is true whether you’re working in a traditional hardware studio or inside a modern MIDI/audio sequencer. When the effect is used in the send/return loop, the same effects can be "shared" between a number of different mixer channels, where the balance of unprocessed sound to effect is set by the controls on the mixer rather than on the effect plug-in itself. For example, it’s possible to set up a reverb plug-in and then add a lot to the main vocal, a little to the guitar and even less to the drums.

If the same effect is used via a mixer insert point, on the other hand, it can be used to process only one track (or a group/master, if the software provides inserts at these points, too), in which case the plug-in’s own mix control is used.

In contrast, a processor is normally only ever used via an insert point. Any attempt to use it via an effects send loop is likely to yield unpredictable and undesirable results. At best, the resultant process will be weakened by the addition of the untreated portion of the signal, and at worst phase differences within the circuitry may completely change the tonality of the signal.

using virtual effects and processors

VST plug-ins must be placed in the folder called "VSTplugins" before you can use them. Several different VST-compatible programs can share the same VST folder on the same machine, although you may need to guide the program to the folder. Cubasis VST CE creates its own "VSTplugins" folder when installed, and as the sequencer is arguably the most important piece of software you’ll have to work with I’ll be using Cubasis as an example to illustrate this chapter. However, don’t neglect the possibilities that arise from being able to use VST plug-ins in other music software. For example, you may decide to upgrade Cubasis VST CE to Cubase VST, which will give you slightly more flexibility in the way in which VST plug-ins can be used, including the ability to create submixes that can be processed using insert effects or processors.

types of plug-ins

Pretty much any hardware effect or processor can be recreated in software form, and there are numerous emulations of specific analogue signal processors already available as plug-ins. Indeed, there are many digital processes that can be handled more effectively by software, because of the improved display facilities accorded by many programs. For example, EQ plug-ins can display frequency curves and reverb plug-ins can depict various parameters graphically, rather than numerically.

In addition to the more obvious processes, it’s also possible to buy plug-ins that perform de-noising, de-clicking and other sophisticated tasks, and these are much less expensive than their hardware counterparts. Also available are physical-modelling guitar-amp simulators, tape echo unit emulators, vocoders and even plug-ins that deliberately add noise and crackle in order to simulate vinyl recordings.

Each channel on a VST-compatible virtual mixer has one or more insert points into which an effect or processor can be placed. Here, when more than one plug-ins are loaded at the same time, the signal flows through the topmost plug-in first. The plug-ins are chosen from a menu that lists all of the virtual effects/processors that are available. Placing an effect/processor in a channel insert point means that everything fed through that channel passes through the active effect.

If the same effect is needed elsewhere, you can open another copy of the same plug-in and place it in the insert point of a different channel. However, it’s important to understand that, even though you may be using the same plug-in, if you use it in two different places it will take twice the processing power. This drain on computing power is the only serious limitation. Once a VST plug-in or similar virtual effect has been installed, you can use it in as many insert points as you like, with different settings for each usage.

Because it’s so important, I’ll stress again that, for effects used in insert points, the effect level is set using the mix control on the plug-in’s own control panel, not by any of the mixer controls.

A more efficient method of deploying effects (but not processors) is to use the aux effect send/return loop, which works in much the same way as its counterpart on a hardware mixing console. While you can use either effects or processors in insert points, effects sends are only suitable for use with delay-based effects, such as reverb, delay, pitch shifting and chorus/flanging. They should not be used with processes such as EQ, compression or gating, as explained earlier. In most cases, the effect sends would be used to add a different amounts of the same effects — such as reverb or echo — to the various tracks in a mix.

Figure 6.1: VST plug-in being used as an insert effect in Cubasis VST CE

Figure 6.2: VST plug-in being used in an effect/send loop via the Cubasis effects rack

In Cubasis VST CE, the effect sends (fed from the two channel aux send controls) feed a virtual effects rack, which can contain up to two plug-ins, each fed from the corresponding aux send control on the mixer channel. The output from the effects rack is routed into the stereo mix and the individual aux send controls on each channel set the effects level for that channel. Note that, when you’re using effect sends, the mix control on the plug-in should be set to maximum, so that it produces all effect and no "dry" signal. This enables the channel aux controls to regulate the overall amount of effect added to each channel. A two-band parametric equaliser is included in each Cubasis VST CE audio mixer channel and does not rely on a plug-in for its operation.

what are effects for?

Having touched on the way in which effect and processor plug-ins are handled in Cubasis VST CE, it’s useful to know a little about what the various plug-ins do and how they can be applied in an artistically useful manner.

The best time to add most effects is when you start to mix your tracks, because if you treat something on its own you run the risk of your results sounding quite different when the other tracks are playing back. However, guitar effects such as overdrive or chorus tend to be added during recording, as they can affect the way in which the guitarist plays. Even so, it helps to record without reverb and to add it later, as the reverb decay will help disguise any edits you may need to make. It also means that you save a track because, while stereo reverb can be added to a mono track on playback, recording stereo reverb at source requires a stereo pair of tracks.

Without doubt, the most important effect of all is reverberation. Synthesised instruments without built-in effects or recordings of voices and instruments made in a typical home studio tend to sound small and lifeless because they don’t have the added reverberation that would be present in a real-life performance venue or concert hall. In the studio, synthesised electronic reverberation is used to put back this missing ambience.

reverberation

Reverberation occurs naturally when sound is reflected and re-reflected from walls and other obstacles within a large room, and an electronic reverb unit mimics this effects by generating thousands of randomly spaced echoes. By adjusting the parameters, you can create the impression of a real room or hall, as well as some less natural-sounding spaces. Our unconscious uses reverb to determine such details as direction, type of acoustic environment and distance, so it’s important to know the aspects of reverb that are responsible for these different auditory clues.

Reverb comprises a series of closely spaced echoes following the original sound. After the initial sound, there’s a short pause as the sound travels to the nearest surfaces (wall, floors and ceilings) before it bounces back to the listener. Some of these reflections encounter other surfaces and are re-reflected, and in practice the complexity of the reflections builds up rapidly so that the individual echoes cease to be audible. Because natural materials absorb a proportion of the sound (as does air), the loudness of the reflections dies away. In most rooms, high frequencies are absorbed more than low frequencies, and so, as the reverb decays, it also begins to sound duller.

The time that it takes for the reverb to die away completely (although, in practice, a 60dB reduction is used) is known as the decay time, and this tends to be between one and three seconds for most musical applications. In addition to emulating various types of room — usually based around rooms, halls and chambers — plate settings are also popular, as they imitate the mechanical reverb plates that were used in pop music until around the end of the 1970s.

In a real room, both ears hear slightly different versions of the reflected sound, and it’s this difference that creates the impression of stereo width. Digital reverb units can process a mono input to produce two different sets of synthetic reflections in order to produce a stereo effect. Figure 6.3 shows the pattern of decaying reflections created by a typical digital reverberation unit.

Figure 6.3: Reverberation decay pattern

The main reverb parameters available for user control include type of room, pre-delay time, overall decay time and high-frequency damping. Pre-delay determines the time between the original sound and the first reverb reflection, and provides a simple way of creating an illusion of room size. (Longer pre-delays can sometimes sound effective when treating vocals.) The overall reverb decay time (ie how long the reverb takes to die away) affects how we perceive the environment, with longer reverb times suggesting large, reflective spaces, while short decay times may be used to simulate smaller rooms or heavily damped spaces. Lastly, high-frequency damping allows the high-frequency decay time to be made shorter than the overall decay time. The greater the HF damping, the more the reverb sounds like a room with soft furnishings or carpets.

Reverb tends to be used on more than one track in a mix, so it’s usual to feed it from an aux send (in send-/return-loop mode) rather than to put it in an insert point. For example, you might be able to use the same reverb setting on both drums and vocals, but you may want to use more on the vocals than on the drums. The reverb plug-in’s mix control should be set to effect only, so that the channel aux controls can be used to adjust the amount of reverb that is added to each channel.

Effects such as reverb may also be connected via insert points, although, as I pointed out earlier, this limits their use to that one channel only, and because good reverbs demand a lot of processing power, this is an extravagant way of working. When used via an insert point, the effect/dry balance of the reverb must be set on the effect unit or plug-in itself.

delay

Delay, as the name suggests, is means of delaying an audio signal so as to produce one or more distinct echoes of the original sound. By feeding some of the delayed sound back to the input, the echoes continue to recirculate and decay, creating multiple echoes. The higher the level of the feedback, the longer it takes for the echoes to decay. The main parameters are delay time and feedback, although some plug-ins also provide tonal control over the delayed sound. Delays require much less CPU power than reverb, so you can afford to be slightly more generous with them.

multi-tapped delay

A multi-tapped delay program generates multiple echoes at different delay times but is otherwise similar to the single delay. On some models, it may also be possible to pan the individual delays from left to right in the stereo field and create some interesting spatial effects, and you may be able to set individual delay times for each of the multiple delays. Some of the more sophisticated plug-ins also allow distortion and pitch modulation to be added to the delayed sound, thus emulating the tape-style echo boxes that were popular in the 1960s and 1970s, when they were often used on lead guitars and vocals.

A popular technique with both single and multi-tapped delay is setting the echo delay time(s) so that the repeats are in time with the tempo of the song. Of course, shorter delays can also be used to create a doubling or double-tracking effect.

modulation effects

Many standard studio effects are variations on digital delay, where the delay time is modulated via a low-frequency oscillator (LFO) to produce chorus, flanging, phasing and vibrato effects. By modulation, I mean that the delay time is changed under the control of a low-frequency oscillator, just as though someone were rhythmically turning the delay-time knob up and down. This also introduces a rhythmic variation in pitch. Phasing and vibrato use such short delay times that no delay is perceptible, while chorus and ADT (Automatic Double Tracking) use a slightly longer delay time to produce a doubling or thickening effect.

chorus and ADT

Chorus uses a delay of up to 70ms or so to create a slight doubling effect. The delay time is then modulated to produce a slight wavering in pitch. An equal mix of delayed and unprocessed sound is used to produce an ensemble effect, which is rather like two instruments playing the same part. The depth of the chorus is controlled by the level of the LFO (the control is usually called "depth"), and, as a rule, the faster the modulation, the less depth is needed. Chorus is often used on string sounds, synthesiser pads, electric guitars and fretless bass guitars.

ADT is similar to chorus, but it uses a delay time in excess of 70ms to create a more pronounced doubling effect and it has a shallower depth of modulation. ADT is often used on vocals to make it sound as if the same singer has performed a part twice. This effect was made popular by John Lennon.

flanging

Flanging uses shorter delay times (in the range of 2-20ms) coupled with the addition of modulation and feedback to create a familiar, psychedelic whooshing effect, which was first achieved in the ’60s by running two tape machines together. With flanging, the higher the feedback setting, the stronger the effect, and, as with chorus, increased speed should be used with reduced depth. Both chorus and flanging sound best in stereo, as they create a strong impression of movement. Because flanging is such a dramatic effect, it’s best used sparingly, although it can sound good on instruments, vocals or even entire mixes.

phasing

Phasing users shorter delay times than flanging and little or no feedback to produce a moving comb filter, which sounds not unlike mild flanging. Because the effect is more subtle than flanging, it can be used more extensively, and is often employed on synth pads and rhythm-guitar parts.

vibrato

Vibrato is a modulation of pitch similar to that produced manually by a guitar or violin player, and is created by using only the delayed sound and none of the original. The delay is kept very short, so as not to affect the timing of the performance, and the modulation depth determines the depth of the vibrato. In the case of a plug-in, the main adjustable parameters are likely to be rate and depth.

pitch shifting

Pitch shifters change the pitch of an original signal either upwards or downwards and usually have a range of at least one octave in either direction. The process of shifting involves breaking the sound into very short segments and sampling them in turn. Each sample is then either looped or truncated, depending on whether the pitch is being moved up or down, and digital algorithms are used to splice the segments back together, so as to avoid glitching. Basic pitch shifters tend to impart a strange modulation to the sound, due to the looping and splicing processes, but at smaller pitch shifts, where the intent is just to detune or double the sound, these side-effects are negligible.

Larger shifts can be used to create octaves or parallel harmonies, and there are intelligent pitch shifters available that can create musically correct, real-time harmonies to vocal or guitar parts. As a rule, the better-quality pitch shifters require a significant amount of CPU power.

Many of the better plug-ins also include formant correction, which makes it possible to change the pitch without making the voice sound either speeded up (ie the "Mickey Mouse" effect) or slowed down. Conversely, they can create the speeded-up or slowed-down effect without actually changing the speed. Recent developments in this area allow singers to change their voice in order to sound more like other artists, or even for males to sing vocal parts in a way that makes them sound like females.

processors

Devices categorised as processors rather than effects include exciters, equalisers, compressors, limiters, gates, expanders, autopanners and pitch correctors (although you can also do creative things by putting a pitch corrector in an effects send/return loop). All of these devices change either the level or the tonal quality of the signal passing through them, and you wouldn’t normally add a dry signal to the output of one of these units. Because aux sends are used to add the output from an effect to the dry signal, it isn’t normal to connect a processor via an aux send.

compressors/limiters

A compressor is a type of processor that is used to "level out" excessive peaks in a performances by automatically changing the gain of the signal path in response to the level of the signal. Just as a studio engineer might pull down a fader if the level gets too high, so a compressor will turn down the level if it exceeds a threshold set by the user. Signals falling below the threshold level thus remain unchanged, while the degree of gain reduction applied to high-level sounds is set by the compression ratio control, as shown in the graph in Figure 6.4. Compression is used in situations where a recorded sound fluctuates too much in level, and it’s almost always necessary to compress lead vocals. Instruments such as bass guitar and drums can also sound tighter and more powerful when compressed. With a very high ratio setting, a compressor’s maximum output is effectively prevented from going beyond the threshold. Used in this way, the compressor is said to be functioning as a limiter.

Figure 6.4: Compressor ratio graph

As a rule, high compression ratios are used in conjunction with high threshold settings so that only the signal peaks are affected. Lower ratios may be used with lower threshold settings to provide gain-levelling over a greater dynamic range.

If your compressor has an attack control, this will govern how quickly the gain reduction is applied once a signal has exceeded the threshold. The release control sets the time for the gain to return to normal once the input has dropped back below the threshold. Some compressors have auto-attack and -release settings, and these respond to the dynamic character of the input signal, which is very useful in the case of signals that are constantly changing in character or for processing complete mixes.

If you use a stereo compressor, the software will always be designed so that both channels are compressed by the same amount, thus maintaining an accurate stereo image.

The maximum gain of a compressor occurs when the input signal is below the threshold, which can sometimes lead to background noise being audible during quiet passages or pauses. To combat this problem, a gate plug-in inserted before the compressor will mute the channel during pauses in the recorded material.

Some compressors have what is known as a soft-knee characteristic, whereby the amount of gain reduction increases progressively as the signal level approaches the threshold. This is in contrast to the conventional hard-knee compressor, where no gain reduction occurs until the signal reaches the threshold. Soft-knee compressors are less obtrusive in operation than hard-knee types, and so may be preferred on those occasions when "invisible" gain control is needed.

gates

Compressors control the levels of signals that exceed a threshold, while gates control the levels of signals that fall below a threshold. During pauses, when any background noise is most likely to be audible, the gate closes and effectively mutes the sound. To achieve this, the gate threshold level must be set just above the background noise. Note that gates only remove noise when there is a pause in the wanted signal — they can’t help with noise that’s audible over the top of the programme material.

In addition to muting electronic noise such as hiss or hum, gates are also used to mute the spill from other instruments or to exclude low-level environmental noise. They are also used to mute the hum from electric-guitar pick-ups when the guitarist isn’t actually playing. Vocals may also be gated to hide any sounds of rustling clothing, breathing or headphone spill. Figure 6.5 shows how a gate reacts when the signal falls below the threshold level.

Figure 6.5: Operation of a gate

You may also come across something called an expander, which is similar to a gate, except that, when the signal falls below the threshold, the gain is reduced according to a ratio, rather like a compressor but in reverse. In practice, an expander works like a gate but is less abrupt when the signal level crosses the threshold.

de-essers

De-essers are designed to reduce the effect of sibilance in vocal sounds. At its simplest, a de-esser may be a special compressor designed to respond only to frequencies in the 4-8kHz range, where sibilant "T" and "S" sounds cause problems. A limitation involved with this simplistic approach is that, when a sibilant sound occurs, the gain of the whole audio signal is reduced momentarily, and unless the process is applied very subtly this can result in a lisping sound.

A better approach is to use a design based on a split-band compressor, so that frequencies up to 3kHz or 4kHz are unprocessed and gain reduction is applied only to frequencies above that. The side-effects produced by this method are far more benign. However, it’s still possible to design an even better de-esser which affects only the frequencies in the range containing sibilant sounds, with the frequencies below and above this range left unaffected.

equalisers

Equalisers are essentially tone controls, and most virtual mixers have EQ built in or available as plug-ins. Equalisers appear in a number of different forms. Parametric equalisers allow the user to control the frequency at which the equaliser works, the width of the frequency spectrum affected and the amount of cut or boost applied at that frequency. They are the most versatile type of equaliser but also the most time consuming to set up properly. Use a parametric when addressing specific problems, such as resonances at particular frequencies that need to be brought down in level. Cubasis has two bands of parametric EQ available within each mixer channel.

A simpler alternative is the shelving equaliser, which is often configured to work like the treble and bass controls on a consumer music system. All equalisers can cut as well as boost, so the low control is able to reduce the amount of bass that you hear as well as increase it. Use shelving EQ for general tonal shaping, such as brightening a sound or adding more bass. High and low equalisers can be found combined in a single plug-in or they may come as separate plug-ins.

Graphic equalisers use a row of faders to cut or boost narrow sections of the frequency spectrum, and the more faders there are, the finer the degree of control, as each controls a narrow part of the audio spectrum. Graphic equalisers get their name because the position of the faders provides a visual picture of the changes made to the frequency response of the input. Although easy to use, graphic equalisers can be a little limiting, as the faders may not control the exact frequency band that you wish to adjust.

A more sophisticated version of the graphic is the paragraphic equaliser, on which each slider also has an associated frequency and bandwidth control to turn it into a fully parametric equaliser. These are very costly to build in hardware form, but they are relatively common as software plug-ins. Many plug-in equalisers generate a visual frequency-response curve as the faders and controls are adjusted, which makes them easier to set up.

exciters

Also known as enhancers, exciters are devices that add synthesised high-frequency harmonics to a signal to make it sound brighter and more exciting. Exciters are used to push sounds to the front of a mix and to create clarity and space in crowded mixes, and they can be used on whole mixes or just on individual tracks. Enhancers working on slightly different principles are available from different manufacturers, and some also include facilities that allow you to adjust the bass end of the spectrum. Exciters can be very useful devices, but you have to careful not to over-use them.

autopanners

An autopanner is simply a device that automatically pans a mono signal from left to right in a mix, usually under the control of an LFO. Extreme autopanning can be dizzying to listen to, but it’s effective when used occasionally or if set to run at the same tempo as the song. You might also consider autopanning the output of an effect plug-in connected to the send/return loop, rather than processing the original sound. Obviously, the output of a panner must be in stereo for it to have any effect.

pitch correction

Pitch correction is possible only for monophonic sounds, with lead vocals being the most obvious example. Plug-ins such as AnTares’ AutoTune allow the user to set up a scale comprising all of the valid notes used in a song, after which the software shifts any notes that are off pitch to the nearest note in the scale. However, if the process is set to work too quickly, you may end up with robot-like vocoder sound, but with a little careful adjustment the result can be very natural. These plug-ins won’t turn a dreadful singer into a good one, but they will turn a reasonable performance into one that’s perfectly in tune.

summary

Effects are essential to modern recording, with reverberation being the most important effect of all, and now that plug-in effects are available, as well as conventional studio hardware, anyone with a sequencer can experiment with audio effects without having to buy racks of expensive gear. The overviews in this chapter should give you some idea of what these effects do, but deciding when to use them comes under the auspices of "art", which is my way of saying that, ultimately, you’re the one who decides what works and what doesn’t. The secret is to experiment. The great thing about software is that you can try anything you like without the risk of damaging anything! If you feel that you need more guidance, refer back to the chapter on "Audio Mixers".

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

effects and processors
using virtual effects and processors
types of plug-ins
what are effects for?
reverberation
delay
multi-tapped delay
modulation effects
chorus and ADT
flanging
phasing
vibrato
pitch shifting
processors
compressors/limiters
gates
de-essers
equalisers
exciters
autopanners
pitch correction
summary


chapter 7

synthesis methods

Synthesisers are fascinating instruments, able to produce a wide range of both imitative and abstract sounds, and although there are various technologies used for synthesis, a number of factors are true regardless of the synthesis method employed.

The character or timbre of a sound is determined by two key factors: the harmonics (and non-harmonic overtones) that make up that sound and the way in which these components change in both level and pitch as the sound evolves. For example, a percussive sound starts very suddenly and then dies away, because no new energy is applied to sustain the sound. A bowed sound, on the other hand, may build up relatively slowly and be sustained until the bowing action ceases. Often, the way in which a sound builds up and dies away has more effect on how the sound is perceived than the nature of the sound itself. All synthesisers have the capacity to produce sounds with varying harmonic structures and to shape the loudness envelopes of those sounds, but there are also other building blocks such as filters, modulation oscillators and so on that can be used. This chapter explores the basics of the main methods of synthesis.

additive synthesis

To accurately synthesise a "real" sound, it would be necessary to recreate all of the harmonics and overtones of the sound in question, set their relative levels, apply a separate envelope to each harmonic and then change the frequency of each sound to emulate the way in which it behaved in real life. What’s more, there would need to be some way of controlling the sound so that it changed in response to playing technique, just as a "real" instrument does.

Building a sound from scratch in this way is known as additive synthesis, and although technically possible, in practice it’s extremely difficult and processor intensive. For this reason, it’s not often seen in commercial products, other than in a simplified form.

analogue synthesis

Commercial sound synthesis originally began with the analogue synthesiser, so called because it relied entirely on analogue oscillators, filters and envelope shapers, which were controlled by electrical waveforms and voltages. Analogue circuitry is expensive to build and tends to have stability problems related to temperature, but the subtle detuning effects that this causes are thought by some to contribute to the warm, "organic" sound of analogue synths. Some modern instruments are still based on true analogue circuitry, often incorporating digital control systems, but most attempt to emulate it by entirely digital means.

The original analogue synths were monophonic (ie you could only ever play one note at a time) and always played at the same level, no matter how hard the key was struck. Limited polyphony followed, but it’s only in the digital emulations of these devices that generous polyphony is possible at a realistic price. If a synthesiser is said to be "16-note polyphonic", it simply means that up to 16 different notes can sound at the same time. If any more are played, the earlier notes are cut off, so the number of notes sounding never exceeds 16.

subtractive synthesis

Analogue synthesis is a form of subtractive synthesis. This process starts out with a harmonically rich oscillator sound, such as a square wave or sawtooth wave, after which filters are used to reduce the level of unwanted harmonics. Although the accuracy with which "real" instruments can be emulated is limited, subtractive synths have an attractive musical quality and are useful for creating more abstract musical sounds. Analogue synthesisers and their modern digital emulations are very popular in dance-music production.

sample-based synthesis

Many modern instruments also work on the subtractive principle, but, instead of starting out with only simple electronically generated waveforms, they use electronic samples (short recordings of sounds of real instruments). These are then further modified by traditional subtractive means, such as the use of filters and envelope shapers. The starting point for a modern sample-and-synthesis patch may be a sampled violin note, a flute, a piano or even a human voice, and some of these may be supplied in a way which allows them to sustain indefinitely. Looped samples may be thought of as being equivalent to oscillators, because a steady sound continues to be generated for as long as the key is held, while string pads and choirs are generally looped. Basic analogue-style waveforms may also be included, enabling these instruments to emulate traditional analogue synthesisers.

Short percussive sounds are not usually looped, as they are short enough not to require much sample memory. As with analogue synths, the waveforms may be pitch modulated (using LFOs), transposed and so on. The E-mu chip on the Sound Blaster Audigy card relies on subtractive synthesis, where the waveforms are provided by SoundFonts (ie sets of instrument and waveform samples that are stored in the computer’s RAM memory). The advantage of this system is that new sounds can be added simply by loading new SoundFonts.

more about Sound Blaster Audigy

Sound Blaster Audigy’s onboard synthesiser chip is closely related to the legendary E-mu Proteus range of sample-playback modules, and it also contains elements of E-mu’s Emulator sampler technology. The chip supports 32 individual digital tone oscillators, running at a sample-clock rate of 44.1kHz. The addition of sophisticated sample-interpolation algorithms and digital filtering makes the Sound Blaster Audigy chip capable of very high-quality sample playback that can be further enhanced and modified using filters, envelopes and modulation, just as in a serious hardware synthesiser. Each Sound Blaster Audigy synth provides extensive modulation capability via two sine-wave LFOs and two multistage envelope generators.

For more information about how synthesisers work, read the rest of this chapter, but effectively modulation simply means the dynamic alteration of an audio parameter such as volume (producing amplitude modulation, or tremolo), pitch (producing frequency modulation, or vibrato) or filter cut-off frequency (producing filter modulation, or a "wah-wah" type of effect). These effects require a modulation source and a modulation destination, and so, in order to modulate a filter to produce a wah-wah effect, the source might be an LFO, while the destination would be the filter cut-off frequency.

In the Sound Blaster Audigy synth, the modulation sources are the LFOs and envelope generators, while the modulation destinations can be the oscillator pitch, the output volume or the filter cut-off frequency. In addition to the oscillator or sound source, each sound-producing element of the Sound Blaster Audigy chip consists of a resonant low-pass filter and two LFOs, where one (LFO2) modulates pitch and the other (LFO1) modulates pitch, filter cut-off frequency and volume simultaneously. There are also two envelope generators, where envelope 1 affects both pitch and filter cut-off frequency simultaneously while envelope 2 controls the volume of the output. The output stage includes an effect/processor section that mixes the dry (untreated) synth sound with reverb and chorus. The user can decide how much of these effects to add.

FM synthesis

Originally popularised by Yamaha, FM synthesis relies on combining frequency-modulating oscillators with other kinds of oscillator to produce harmonically rich waveforms. This is all accomplished in the digital domain, and the ways in which the oscillators interact are based on algorithms. Certain algorithms are best suited to producing specific types of sounds, such as bells, pianos and plucked strings. Although not as intuitive as subtractive synthesis, FM synthesis is good for producing complex metallic overtones, making it particularly effective at producing electronic-piano-style sounds. The Sound Blaster Audigy package includes a software-based synth capable of producing GM-type sounds, and this may be used at the same time as the two hardware synthesisers. Note that the Sound Blaster Audigy card no longer provides the OPL emulation previously provided by the AWE range. The software wavetable synth is based on Ensoniq’s ECW waveset files.

physical modelling

Physical-modelling instruments use mathematical models to emulate the way in which real acoustic instruments produce sound, and a different model is needed for each family of instruments. For example, a clarinet simulation would involve simulating the vibration of the reed, the resonance of the instrument body, the positions of the valves and so on. This is complicated, but the advantage is that the modelled instrument responds to playing techniques more like the real thing. For example, a physical model of a flute might change its harmonic structure when overblown, or a plucked string might start slightly sharp when played harder.

It’s possible to physically model many acoustic instruments, and various aspects of different instruments may be combined to produce hybrid instrument sounds that don’t actually exist. Because of the complexity of physical modelling, the number of user parameters is usually limited, and additional MIDI controllers — such as breath controllers or pedals — are often needed to articulate the sound in a convincing way.

wavetable synthesis

Wavetable synthesis is slightly different to other methods because, instead of using one oscillator or sample as the sound source, a table of different oscillator waveforms is used, and these can change from one to the next as the sound evolves. Sometimes these wavetables are designed to produce a naturally evolving sound, while at others they can be abstract or rhythmic. Commercial wavetable synthesis started with the PPG and then the Korg Wavestation, while most of today’s wavetable instruments come from German manufacturer Waldorf. The processing of the wavetable sound is generally carried out by conventional filters and envelope shapers.

soundcards

Most soundcards included a synthesis section, often based on the General MIDI soundset, but until very recently soundcards had a reputation for producing second-class sound quality. However, Sound Blaster Audigy’s E-mu chip offers sound quality that compares very favourably with stand-alone synths, and because the basic sounds are loaded as SoundFonts there’s no limitation to the kinds of sounds that can be loaded and played. There are two identical synths on the Sound Blaster Audigy chip, providing two 16-part multitimbral synthesisers that can be used at the same time to provide up to 32 separate musical parts.

Some soundcards have onboard RAM sockets so that the sample RAM can be increased, if desired, which enables longer samples (or more samples at once) to be used. Sound Blaster Audigy uses the RAM of the host computer to store its SoundFonts, which means that there’s no limitation to the amount of RAM that can be installed, other than what the computer can take. Also, standard computer RAM may be cheaper than the specialist RAM needed for soundcards.

software synthesis

Software instruments are available either in the form of stand-alone programs or as plug-ins, and Sound Blaster Audigy also includes a basic software synth that is capable of producing General MIDI sounds and that can be used in addition to the two chip-based synthesisers.

VST instrument plug-ins offer a wide choice of instrument types and styles and are relatively easy to install and use, so I’d recommend that, after trying the included soft synth sounds, you listen to some of the VST instruments that are currently available. You can pick up VST plug-ins that work by all of the synthesis methods mentioned above and that provide surprisingly accurate emulations of the MiniMoog, the PPG Wave, the Hammond B4 organ, the Rhodes Suitcase electric piano, the Sequential Prophet 5 polysynth and many other classic instruments. (Note, however, that not all of these are endorsed by the original hardware manufacturers and that these trademarks are still the property of their registered owners.)

All software-based synthesis uses either the computer’s own processing power or additional DSP cards or hardware, but VST instruments are always powered by the host computer. The Sound Blaster Audigy package includes Cubasis VST Creative Edition which can use VST instruments. Several companies offer time-limited downloads of demos of their VST instruments from their websites. VST instruments are produced by a number of companies, including Steinberg, Native Instruments, Waldorf, Emagic and TCWorks, so it’s worth checking out the websites of these companies for demo versions.

samplers

A sampler is essentially a polyphonic synthesiser in which the oscillator sound can be any sound that you choose to load into it. Once a sound has been recorded or sampled (into RAM), it can be played back at different pitches via MIDI, just like any other synthesiser sound. To play a sample back at a higher pitch than that at which it was first recorded, the sampler has to speed up the sound, which means that the sample also plays back faster. Conversely, if you drop the pitch by slowing down the sample, the sound will go on for longer. Sustained sounds (as opposed to percussive sounds) can be looped to make them play for as long as required, and in most instances conventional envelope shapers and filters are used to shape the sound.

Because samples are held in RAM, they are lost when the system is powered down, and so must be reloaded before use, either from the system’s hard Sound Blaster Audigy or CD-ROM. Older samplers use floppy disks, while some modern hardware models offer "Flash" memory, which enables frequently used samples to be stored when the instrument is switched off.

A huge range of expertly recorded library samples are available on CD-ROM in the popular Akai, E-mu and Roland formats and in the Creative SoundFont II format, although it’s always possible to record and edit your own samples. Sound Blaster Audigy’s synthesisers are very high-quality sample players that support the Creative Labs SoundFont II format, and more advanced users can utilise the included Vienna SoundFont editing software to create their own SoundFont samples. There are also many third-party SoundFont CD-ROMs available that are equal in quality to those provided for hardware samplers but generally at a much lower cost.

how samplers are used

It’s helpful, at this point, to look at the two main ways in which people use samplers. Clearly, the ability to sample long sections of sound from real instruments makes it possible to produce more accurate "real" instrument sounds than those produced by synthesisers with limited waveform memory. Greater accuracy is produced by using sets of samples where each sample covers just a few notes of the original instrument, thus avoiding the unnatural artefacts that occur when a sound is transposed too far from its original pitch. These sets are known as multisamples, and accurate piano sample sets may need a separate sample for every two or three notes of the keyboard. There may also be different samples for loud and soft sounds that either switch over at a specified key velocity or that progressively crossfade as you play louder. The zones of the keyboard relating to individual samples are known as keygroups, and the more keygroups you have, the more accurate the sound will be. Naturally, the more keygroups you use, the more memory you’ll need to hold all of the individual samples. This is the way in which SoundFonts work.

The other popular way of using samplers is to record not just individual notes but whole musical or rhythmic phrases, and this way of working forms the cornerstone of modern dance-music construction. A typical application might be to sample a one-, two- or four-bar drum rhythm and then trigger this repeatedly from within a sequencer in order to provide a continuous rhythm track. (See the section on "ReCycle" later in this chapter to find out how to produce sample loops that can be played back at different tempi without resorting to time stretching.) SoundFonts can also contain rhythmic loops, and the version of ReCycle included in this package makes it easy to create custom loops that can be altered in tempo without suffering a change in pitch.

Some loop libraries are arranged in layers, with different parts assigned to different keys on the keyboard so that you can build up your rhythm loops as the song progresses. For example, you may have a kick and snare drum on one layer, percussion on another and hi-hat on a third. Unless the loops are in ReCycle format (ie Rex files) or a similar format (such as Spectrasonics’ Groove Control), you must set your sequencer to the tempo of the sampled loop — which, in the case of library material, is normally provided in the documentation.

The maximum sampling time of a hardware sampler is always limited by the amount of RAM available, and a fully expanded, top-of-the-range sampler may hold many minutes of samples, so it’s worth fitting as much RAM as you can afford. Software samplers use the computer’s own RAM, so, again, fit as much as you can. The biggest drain on sample RAM is running a lot of multisamples multitimbrally, especially if the individual samples are long.

As with synthesisers, sustained waveforms are usually looped to conserve sample memory. Most sustained sounds have a distinctive attack portion, but, as they start to decay, the sound becomes more consistent. This being the case, you can often sample just the first few seconds of the sound and then use the sampler’s editing facilities to create a loop so that the middle part of the sample repeats itself continually until you release the key. The level-envelope shaper may also be used to recreate the natural decay of the sound. One of the greatest skills in sample editing is choosing the best loop points at which to produce a natural sound.

synthesiser oscillators

Having looked at the basic methods of synthesis, it’s now time to explore some of the common elements. Both samplers and synthesisers start out with a raw oscillator, sampled sound or other sound source, which is then passed through a filter and a level-envelope shaper. The character of a natural sound is largely determined by its harmonic content and its envelope, the envelope being the way in which the level of the sound changes with time. Percussive sounds start suddenly and then die away, whereas a bowed sound might start quite slowly and then sustain at a more or less fixed level.

synthesiser envelopes

The envelopes of real sounds can be very complex, but an adequate approximation can often be achieved by using a basic four-stage ADSR (Attack, Decay, Sustain and Release) envelope generator controlling a VCA (Voltage Controlled Amplifier). The block diagram of a simple synth plus its ADSR envelope is shown in Figure 7.1, where the start of the envelope is triggered by the action of pressing a key.

Figure 7.1: Synth block plus ADSR envelope shaper

The attack section of an envelope is the time taken for the amplitude to reach its maximum level, and for percussive sounds the attack time is very short. Once the sound has reached its maximum level, it starts to decay at a rate set by the decay time setting, until it reaches a level known as the sustain level. It remains at this level for as long as the key is held down, but once the key is released the sound resumes its decay, this time at a rate determined by the release setting. If the key is pressed again before the envelope generator has completed the release part of the envelope, the old release level is abandoned and a new envelope is initiated. This type of envelope generator — and more complex variations of it — are regularly found in modern digital synthesisers, as well as older analogue models and virtual instrument plug-ins. Note that, while attack, decay and release controls set the rate at which the level of the envelope changes, the sustain parameter is a level, not a rate. The action of a sustain pedal interacts with the envelope control to extend the decay portion of a sound, although the way in which this works varies slightly from instrument to instrument.

filtering

Although some of the simpler modern synths don’t include them, filters are very useful for moving or creating new timbres, and they’re essential in analogue-style synthesis, where the source waveforms are relatively basic. What’s needed is a filter that can be made to alter its characteristics (specifically its cut-off frequency) in a controllable way, usually under the control of an envelope generator. Other control sources may be added to make the filter section more flexible, with common examples including keyboard position (ie the higher the note you play, the higher the filter frequency) and LFO. Simpler synths tend to share the same envelope generator for the filter and for the output level, while more sophisticated models have separate envelope generators for each function. Sound Blaster Audigy’s synth chips have comprehensive filter and envelope parameters rivalling those of hardware synthesisers.

polyphony

As explained earlier, the polyphony of an instrument determines how many different notes it can play at the same time. Digital synthesisers tend to have 64- or even 128-note polyphony, and on a multitimbral instrument this polyphony is shared between all parts. Sometimes there is a system for sharing out the polyphony so that each part always has one or two voices in reserve rather than having the polyphony robbed by activity in other parts. In the case of virtual instruments, the amount of polyphony has a direct impact on the proportion of CPU resources used, so there’s generally an option for the user to determine the maximum number of voices that can be played. Setting the polyphony to level 1 produces the classic mono analogue synth effect, where playing a new note always cuts off the old one. This setting is useful for bass lines, lead sounds and emulations of instruments that are naturally monophonic, such as flutes and other wind instruments.

onboard effects

It’s now common practice for hardware synthesisers and modules to come complete with built-in digital effects — such as reverb, chorus and echo/delay — to add life and realism to a performance. Usually, there is a choice of types and combinations of effects, and the user often has the option of editing these effects. The ways in which these effects can be deployed when the synth is used multitimbrally will vary from manufacturer to manufacturer, but it’s pretty common for the key aspects of the effects to be MIDI controllable. For example, in GM instruments, the level of chorus and reverb effects may be changed from part to part.

Many virtual instruments also include effects sections, although not all of them do. However, it’s very easy to insert a VST effect after a VST instrument. Sound Blaster Audigy includes a flexible yet easy-to-use effects section capable of producing up to four simultaneous effects. Note, however, that the Sound Blaster Audigy effects cannot be deployed with the same flexibility as VST effects.

Sound Blaster Audigy structure

SoundFont envelopes may be edited with up to six stages, using the included Vienna SoundFont editing software. Listed below are the basic building blocks of the Sound Blaster Audigy synthesiser.

Oscillator

This is the original sound source, which in this case may be an audio waveform or a sample of a real instrument. A collection of these raw sounds are loaded as SoundFonts.

Low-Pass Filter

Sound Blaster Audigy’s filter section comprises a low-pass filter, where the cut-off frequency can be selected from a range spanning 100Hz to 8kHz. By modulating the value of the filter cut-off frequency, analogue-sounding filter sweeps can be achieved, especially when using higher resonance settings. An example of a GM instrument that makes use of filter sweeping is instrument number 87, lead 7 (fifths). Increasing the resonance of the Sound Blaster Audigy filter dramatically emphasises signals at the cut-off frequency in order to produce wah-wah or synth filter-sweep effects.

Amplifier

The amplifier determines the loudness of an audio signal and can be modulated by an envelope generator to shape the attack and release characteristics of a sound. It may also be modulated via an LFO to create tremolo effects.

LFO1

LFO1 operates at sub-audio frequency, from 0.042Hz to 10.71Hz, and modulates the pitch, volume and filter cut-off simultaneously.

LFO2

LFO2 is similar to LFO1, except that it modulates only the pitch of the audio signal, creating vibrato effects.

LFO1 To Volume (Tremolo)

LFO1’s output is routed to the amplifier, with the depth of oscillation determined by the "LFO1 to volume" parameter. This produces tremolo, which is a periodic fluctuation of volume that was popular with guitar players in the ’60s. An example of a GM instrument that makes use of LFO 1 to volume is instrument number 45, "tremolo strings".

LFO1 To Filter Cut-Off (Wah-Wah)

LFO1’s output is routed to the filter, with the depth of oscillation determined by the "LFO1 to filter cut-off" parameter. This produces a periodic fluctuation in the filter cut-off frequency, producing a regular wah-wah effect. An example of a GM instrument that makes use of LFO1 to filter cut-off is instrument number 19, "rock organ".

LFO1 To Pitch (Vibrato)

The output of LFO1 is routed to the oscillator, with the depth of oscillation determined by the "LFO1 to pitch" parameter. "LFO1 to pitch" produces a periodic fluctuation in the pitch of the oscillator, which is known as vibrato. An example of a GM instrument that makes use of "LFO1 to pitch" is instrument number 57, the trumpet.

LFO2 To Pitch (Vibrato)

The Sound Blaster Audigy chip’s LFO1 can simultaneously modulate pitch, volume and filter range. LFO2, on the other hand, modulates only pitch, with the depth of modulation being determined by the "LFO2 to pitch" parameter, which produces a regular vibrato effect. When this is used at the same time as "LFO1 to pitch", a more complex vibrato effect can be achieved.

Volume Envelope

Here, the envelope shaper modulates the output level of the synthesiser chip, enabling the attack and release characteristics of the sounds to be modified. Not only does this make it possible to emulate real instruments, but it also makes real-instrument waveforms sound more abstract.

performance control

The secret of a convincing performance when using any synthesiser is to make full use of real-time control, including (but not limited to) sustain pedal, pitch bend and vibrato depth.

Aftertouch can also be a useful performance control and comes built into many keyboards, although it tends to act on all of the notes playing at any one time. (As mentioned earlier, because aftertouch generates a lot of data, it’s best to switch it off at the keyboard if you’re not using it.)

Some instruments come equipped with joysticks, with which you can control two parameters at once by using the vertical and horizontal vectors. Often, these can be assigned to any of the regular MIDI controllers, which means that it’s up to the user to decide the parameters that they will affect.

Ribbon controllers are rarely fitted to modern instruments, although they are available as add-ons. With these, as you slide your finger from one end of the ribbon to the other, it acts much like a slider, but as soon as you remove your finger from the ribbon, the contact is broken and the original parameter value is restored. Ribbons are useful for controlling such things as level, pitch, vibrato, filter brightness and so on.

Breath controllers are particularly effective, but relatively few modules and controllers are built with these kinds of inputs. The mouthpiece of the breath controller is attached to a headset and a pressure sensor converts breath pressure into electrical information, which is subsequently used to generate MIDI controller data. Anything that can be controlled via a MIDI controller can be controlled via a breath-control unit, including volume.

Sound Blaster Audigy real-time control

Many of Sound Blaster Audigy’s synthesiser functions can be controlled in real time, either via the sequencing software or via an external hardware MIDI controller such as Phatt Boy or Doepfer’s pocket control, which features 128 easily programmable patches via MIDI and comes with free software. The following chart shows which MIDI controllers are supported by Sound Blaster Audigy and what they do. An X in a column shows that the function is not supported while an 0 shows that the function is supported.

Function | Transmitted | Received | Remarks
MIDI Channel | X | 1-16 | .
Mode | X | 3 | .
Note Number | X | 0-127 | .
Velocity | . | . | .
Note On | X | . | 9n, V = 0-127
Note Off | X | . | 8n, V = 0-127
Key Aftertouch | X | X | .
Channel Aftertouch | X | 0 | .
Pitch Bend *1 | X | 0 | +/-2 octave pitch-bend sensitivity recognised
Control Change *1 | . | . | .
0, 32 | X | 0 | Bank select
1 | X | 0 | Modulation
2 | X | 0 | Breath Control
6, 38 | X | 0 | Data Entry
7 | X | 0 | Main Volume
10 | X | 0 | Pan
11 | X | 0 | Expression
21 | X | 0 | Undefined (E-mu Enhancement Control 1)
22 | X | 0 | Undefined (E-mu Enhancement Control 2)
23 | X | 0 | Undefined (E-mu Enhancement Control 3)
24 | X | 0 | Undefined (E-mu Enhancement Control 4)
64 | X | 0 | Sustain Pedal
66 | X | 0 | Sostenuto
67 | X | 0 | Soft
91 | X | 0 | Reverb Depth
93 | X | 0 | Chorus Depth
98 | X | 0 | NRPN LSB
99 | X | 0 | NRPN MSB
100 | X | 0 | RPN LSB
101 | X | 0 | RPN MSB
120 | X | 0 | All Sounds Off
121 | X | 0 | Reset All Controllers
123 | X | 0 | All Notes Off
Program Change | X | 0 | 0-127

notes

For functions marked *1, all channels (including the one for drums) respond to MIDI volume. At default power-up, pitch bend is set at two semitones, master volume is at 100 and all controllers are at normal.

synth editors

Because many hardware synths employ a menu- and button-Sound Blaster Audigyn user interface, it’s often easier to edit them via a computer screen, where level and filter envelopes may be presented graphically and you can use the mouse to click and drag them into new shapes, which makes for more intuitive editing. Indeed, a number of companies now make universal synth editors on which software modules relating to the various synths in circulation can be loaded and used. Such editor systems tend to include librarian facilities, which allow you to store new sounds on disk when your synth memory is full. In this way, you can build up a vast library of different sounds for your instruments and then transfer these to your synth as they’re needed.

To use an editor/librarian system, it’s necessary for the MIDI Out of the instrument being edited to be connected to the MIDI In of the interface serving the computer, and the MIDI Out of the interface must be connected back to the MIDI In of the instrument. This provides two-way communication between the instrument and the computer so that patch data and instructions can be sent both ways. This may require the use of a MIDI merge box to combine the MIDI Outs from the modules being edited with the MIDI Out from the master keyboard.

Another alternative is to use hardware MIDI controllers, such as MIDI fader boxes, which send out MIDI controller information. These tend to be programmable, allowing you to create presets to help you edit the main parameters on all of your favourite hardware synths and VST instruments. Figure 7.2 shows the MIDI connections necessary for using a MIDI fader unit, where a separate MIDI merge box is used to combine the MIDI Out from the master keyboard with the MIDI Out from the hardware controller. The same MIDI fader box may also be configured to control fader levels in Cubasis VST CE’s mixer, providing the control of audio and/or MIDI track volumes.

Figure 7.2: Connecting a MIDI fader

Note that the Sound Blaster Audigy card plus an Audigy Drive provides two MIDI inputs which can be used to merge MIDI signals, so with this system no separate merge box is needed.

An advantage of virtual instruments is that, as they’re already in the software domain, they come with built-in virtual control panels and patch-library systems. No MIDI connection is needed to use these facilities, as everything is routed within the computer, and the MIDI connection is handled internally by the host sequencer, so you don’t need to use a MIDI interface or any cables.

alternative MIDI instruments

MIDI and keyboards are based around switches, which is a very simple and reliable way of sending Note information to a computer. However, not every musician plays a keyboard, so various other controller instruments have been developed to generate MIDI information, including the guitar, the violin, wind instruments, drums and some innovative/experimental controllers with no natural counterpart.

The electric guitar is still the most popular contemporary instrument, but guitars don’t lend themselves naturally to MIDI because, unlike the electronic keyboard, the notes are created by vibrating strings rather than by turning oscillators on or off with switches. In order to generate MIDI information in this way, there needs to be some means of measuring the pitch of each string, but the signal from a conventional guitar pick-up is too complex to analyse when more than one string is sounding at a time. The most common solution is to use a split pick-up — in effect, one pick-up per string — so that the pitch of each string can be tracked independently and the information passed onto a microprocessor, which then generates the required MIDI data.

Because of the harmonic complexity of a plucked guitar string, even the best systems generate some spurious information, and if the player doesn’t terminate the note by damping or lifting his finger off the string there’s no telling when the note will stop — it all depends on the sustain of the guitar. A related problem is that the very action of lifting a finger off a string can cause the open string to vibrate just enough to cause an accidental retrigger. However, as a MIDI sequencer gives you the opportunity to fix mistakes afterwards, the MIDI guitar can still be a practical way of recording MIDI information.

A MIDI guitar can be used as a regular MIDI controller, but to use it in this way would be to miss out on some of the unique attributes of the instrument, such as the ability to apply different amounts of pitch bend and vibrato to different notes. To make this work over MIDI, each string must be handled by a different MIDI channel, and this can be achieved by using MIDI mode 4 rather than the more normal Poly mode (mode 3). This puts each guitar string in control of its own part of a multitimbral, monophonic sound module, providing a maximum polyphony of one note per string, just like a real guitar.

Even when there’s no intention of bending notes, it’s essential to stick with the one-channel/one-string approach if hammer-ons and slides are to be tracked accurately, as these also rely on MIDI Pitch Bend data. Because guitar slides can cover large intervals, it’s best to set the MIDI guitar and the receiving synths to a high pitch-bend range, typically an octave or more. Obviously, the guitar synth and the sound modules that it controls must be set the same bend range or bends and slides will be out of tune.

beyond the MIDI guitar

MIDI violins usually work on a similar principle to MIDI guitars, but they’re more likely to employ piezo-electric devices as pick-ups, as do nylon-string guitar systems. Again, these use a system of one MIDI channel per string to provide the greatest flexibility.

Various wind controllers have been built at one time or another, most of which rely on switches to duplicate the functions of the keys on a clarinet or similar instrument. On these devices, a special mouthpiece capable of measuring breath pressure and lip pressure provides additional controller information, thus adding more life to the sound. These instruments may also be fitted with sliders, modulation wheels or ribbon controllers that the player can operate with his thumb, while other refinements include octave switches. Like real wind instruments, these controllers are monophonic, although you can still set your synth to play parallel intervals.

MIDI drums

MIDI drum systems aren’t too difficult to design, compared with other controller systems. Usually, a synthetic rubber pad fitted with a pick-up is used instead of a real drumhead, and the pick-up monitors how hard the pad has been struck. Each impact is converted by a processor into MIDI Note On and Off messages, along with the appropriate Velocity information.

A separate floor-mounted pad is often used in conjunction with a conventional bass-drum pedal for producing bass-drum sounds, and a regular footswitch often serves as a simple hi-hat open/close toggle. Cymbals and hi-hat sounds can be triggered by the same types of pads used for the drum sounds, although some more sophisticated systems use cymbal-shaped pads equipped with position sensors that allow two or more MIDI-controlled sounds to be crossfaded as the player plays across the surface of the pad. For example, a cymbal pad might have a cymbal bell sound near the centre and a ride-cymbal sound near the edge. Additional sensors may also be provided so that the cymbals can be manually dampened by grabbing hold of them.

Drum pads are available on full-sized pads to replace the conventional drum kit, or they may be presented as a number of smaller pads fitted to the surface of a single compact unit. Most have inputs to accept pedals and bass drum pads, although the cheaper models may use simple switches for these functions, which means that no Velocity information is transmitted.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

synthesis methods
additive synthesis
analogue synthesis
subtractive synthesis
sample-based synthesis
more about Sound Blaster Audigy
FM synthesis
physical modelling
wavetable synthesis
soundcards
software synthesis
samplers
how samplers are used
synthesiser oscillators
synthesiser envelopes
filtering
polyphony
onboard effects
Sound Blaster Audigy structure
performance control
Sound Blaster Audigy real-time control
notes
synth editors
alternative MIDI instruments
beyond the MIDI guitar
MIDI drums


chapter 8

Sound Blaster Audigy and its music software

Some cheaper soundcards have been unreasonably criticised for their performance in serious musical applications, which isn’t entirely fair when you consider that a budget soundcard can cost less than a reel of tape for a professional studio recorder. Sound Blaster Audigy sets a new standard for soundcards by offering extremely good audio quality combined with two state-of-the-art onboard synthesis engines, onboard effects processing and a suite of extremely powerful music software from the market leader, Steinberg. Furthermore, it is extremely affordable.

Sound Blaster Audigy uses the new Creative Audigy processor chip, which offers twice the power of the current EMU10K1 chip. Also, unlike earlier cards, Sound Blaster Audigy has six channels of analogue plus S/PDIF digital output to support the playback of Dolby digital-encoded surround-sound material. An audio media player is also included, and this offers equalisation, click removal and noise reduction for the cleaning up of existing audio recordings. In fact, Sound Blaster Audigy is a very flexible piece of hardware, with equally flexible support software, which means that it has applications in music playback, multimedia and games as well as advanced desktop music studio use. As this book is concerned specifically with the desktop music studio applications of Sound Blaster Audigy, however, only those features directly relating to musical applications will be referred to here.

The Sound Blaster Audigy Platinum and Platinum eX hardware bundles differ only in the fact that, with the eX system, the Audigy Drive comes as an external module. Both systems come with a comprehensive suite of Creative Labs software featuring Steinberg’s Cubasis VST CE, WaveLab Lite and ReCycle (SoundFont edition), and combined this adds up to a very powerful desktop music-production system.

Clearly, Sound Blaster Audigy is designed to be extremely versatile — it can provide professional-quality sound for gaming, multimedia and MP3 playback, and includes Dolby-licensed AC3 5.1 surround-sound capability. To facilitate this, the card has six analogue outputs, which can be used to drive the five main surround-sound speakers, plus a sub-bass (LFE) speaker. However, because of the flexibility of the included ASIO software driver (with ASIO standing for Audio Streaming Input/Output, one of Steinberg’s major innovations), up to six of these outputs can be accessed simultaneously with the included Cubasis VST CE sequencing software as conventional discrete outputs.

The Sound Blaster Audigy Platinum comprises two hardware components:

• The Sound Blaster Audigy card, which includes two line inputs and two mic-level inputs (one mono, one stereo) that can be used simultaneously, if required. Because the panel space on soundcards is limited by the form factor of the PCI slot in which the card is installed, all of the connections are on 3.5mm stereo jacks (unbalanced), so you’ll need suitable adaptors or cables to connect these to any other audio components that you may have. An SB1394 connector on the rear of the Sound Blaster Audigy card facilitates the connection of external IEEE1394/Firewire devices, such as video cameras, hard drives, CD writers and so on;

• The Audigy Drive, which fits into a standard five-and-a-quarter-inch drive-bay slot and connects to the host Sound Blaster Audigy card via a ribbon cable. Its stand-alone counterpart connects to the computer by a multicore cable, which in turn attaches to a daughterboard connected to the Sound Blaster Audigy card via an internal ribbon cable. Both versions provide the same additional connectivity and features. There are two sets of digital inputs and outputs in S/PDIF format, one set on RCA phono (co-axial) connectors and the other on optical ports. The digital input is fed via a high-quality sample-rate converter, enabling Sound Blaster Audigy to accept inputs from CD players, DAT machines, MiniDisc recorders and so on without the user having to be concerned with sync status or clock rates. However, only one set of digital inputs can be used at once, and the optical inputs take priority if both are connected. Both outputs will operate simultaneously, but they can’t be discretely addressed as both output the same signal. Sound Blaster Audigy always runs from its own internal clock, and when using ASIO to record in Cubasis the sample rate is fixed at 48kHz.

In addition, there is a stereo mic/line input (to accept a balanced TRS quarter-inch jack) with gain control suitable for line-level signals or microphones not requiring phantom power, a stereo aux 2 line-level input on two RCA phono sockets and a stereo headphone outlet with gain control.

Mini DINs on the front of the Audigy Drive are extended to standard MIDI DIN connectors, using the supplied adaptor cables to provide MIDI In and Out to the system. The joystick port on the Sound Blaster Audigy card itself can be accessed via an additional panel that sits behind an unoccupied card slot, and with the aid of an optional adaptor cable (available as an accessory from the Creative website or a computer/music store) this can also provide one MIDI In and Out. By using both MIDI ports, Sound Blaster Audigy can address up to 32 external MIDI channels.

ASIO

ASIO provides audio routing between the Sound Blaster Audigy and any ASIO-compatible multitrack audio-recording software, such as Cubasis VST CE, which is included in the Sound Blaster Audigy software bundle. Although almost invisible, the ASIO driver is actually a vital part of the system. It ensures low-latency operation and provides a straightforward control panel to determine which physical inputs and outputs are used by the software and also how some of the internal signal paths (virtual inputs and outputs) within the Sound Blaster Audigy card are routed. Note, however, that not all ASIO-compatible audio software is able to fully exploit all of the routing options offered by the ASIO driver.

The ASIO driver supports up to 14 simultaneous, sample-synchronous, low-latency ASIO audio outputs, which, as you may have noticed, is more than the number of physical outputs. This is because the ASIO driver can access a number of internal points (virtual inputs and outputs) within the Sound Blaster Audigy hardware environment, as well as the physical inputs and outputs. One function of these virtual outputs is to allow several different signal sources to be routed and/or mixed via Sound Blaster Audigy’s internal effects chips.

Physically, Sound Blaster Audigy has the following outputs:

• Front left and right (rear of the card);

• Real left and right (rear of the card);

• Centre and LFE (sub) (rear of the card);

• S/PDIF out (front of the Audigy Drive)

ASIO can route to all of these physical outputs directly, as long as the host software supports this facility.

The way in which the virtual ASIO outputs are identified is as follows:

• ASIO outputs 1 and 2 (WAV/MP3 1/2), 3 and 4 (WAV/MP3 3/4) and 5 and 6 (WAV/MP3 5/6) go via the stereo upmix path, internal to the Sound Blaster Audigy card. Effectively, the ASIO driver provides access to six discrete sources that are mixed in hardware before being output via this path. These signals are processed within the card and then sent to the left and right front speaker physical outputs. Depending on the speaker mode and the CMSS (Creative Multi-Speaker Surround) settings, they may also be output to the rear and centre speaker physical outputs. For example, if CMSS is active and the card is set to 5.1 mode, the audio is processed to make it sound more natural and some of the signal is routed to the centre speaker. Furthermore, AudioHQ may be used to add effects to the "WAV/MP3" path, in which case whatever effects are assigned there will affect the signals being output;

• ASIO outputs 7 and 8 (front left/right) feed the left and right output sockets at the rear of the Sound Blaster Audigy card directly. These are the outputs that would be used for most desktop recording work, where the desired final product is mostly a conventional stereo mix;

• ASIO outputs 9 and 10 (rear left/right) feed the left and right surround outputs on the rear of the Sound Blaster Audigy card directly (when the card is set to 4 or 5.1 speaker mode), although these can simply be utilised as an additional stereo pair by software that can access them. They don’t have to be used for surround purposes;

• ASIO outputs 11 and 12 (centre/LFE) feed the centre and subwoofer outputs on the rear of the Sound Blaster Audigy card directly (when the card is set to 5.1 speaker mode), although these too can simply be utilised as an additional stereo pair by software that can access them and also don’t have to be used for surround purposes;

• ASIO outputs 13 and 14 (reverb) feed the oncard EAX ADVANCED HD reverb directly.

ASIO and surround-sound

Using ASIO outputs 7 through 12 in conjunction with suitable audio software, it’s possible to create a true 5.1 audio mix. Cubasis VST CE, Cubase VST or Logic Audio may be used to address three stereo busses to produce a 5.1 mix by using the six analogue outputs. Professional multichannel authoring solutions work in the same way, using a dedicated I/O card to feed six channels (analogue or digital) to a dedicated AC3 encoder. The most straightforward way to use Cubasis VST CE is to select the input source to be recorded (from VST inputs under the Audio menu) and to assign the Master outputs in the VST mixer to the front left and right speaker outputs.)

Sound Blaster Audigy’s ASIO driver also supports 12 simultaneous sample-synchronous, low-latency ASIO audio inputs that are sample-synchronised to the ASIO outputs listed above. Again, there are more sources available than merely the physical inputs of the system, and these are mapped as follows:

• ASIO inputs 1 and 2 come from the mixed analogue inputs on Sound Blaster Audigy, which is the same signal as that for "Analog Mix". (Analog Mix is, in effect, any signals from any sources that you can hear via the Sound Blaster Audigy outputs, and this includes any Sound Blaster Audigy effects that may have been added);

• ASIO inputs 3 and 4 (Pre EQ) are sourced from the mixed signal before EQ and effects are added. (This isn’t a physical input);

• ASIO inputs 5 and 6 are "Mix (Post EQ)", and this, too, isn’t a physical input. Using compatible software, this allows the signal to be fed via the onboard Creative DSP Spatializer and main EQ, making it possible to record a "virtual" 5.1 mix for playback over a two-channel headphone or loudspeaker system. What happens is that the DSP Spatializer processes the individual surround components in a way that recreates the illusion of 5.1 surround-sound from a two-speaker system. Very neat! What’s more, you can hear the effect when replayed over any two-speaker system or headphones, and so, if you use this effect on one of your own tracks, anyone can play it back using regular stereo playback equipment. Note, however, that, if you’re in 5.1 speaker mode and record this output, no signal will be output from the rear, centre or subwoofer channels. What you hear will be the virtual surround-sound coming from a single stereo output. If you want to hear these elements separately, choose "Mix (Pre EQ)";

• ASIO inputs 7 and 8 come from the S/PDIF input on the Sound Blaster Audigy card. This input supports the SCMS copyright protection system and includes automatic sample-rate conversion, enabling any consumer digital source to be used. (Sound Blaster Audigy always clocks from its own internal sampling clock);

• ASIO inputs 9 and 10 come from the Audigy Drive line/mic stereo input;

• ASIO inputs 11 and 12 come from the Audigy Drive aux 2 input.

the Creative Surround Mixer

Even though ASIO can route signals directly to ASIO-compatible audio software, the audio outputs from that software are also sent via the Creative Surround Mixer before emerging at the physical outputs of the system. This allows external sound sources to be mixed in with your audio software outputs and also makes it possible to record the mixed audio from the Analog Mix and the MIDI-instrument mix back to a fresh WAV file. Additionally, EAX ADVANCED HD effects may be added to signals passing through the Creative Surround Mixer.

The Creative Surround Mixer includes faders to control overall volume (playback volume on all physical outputs), bass and treble (outputs) and WAV/MP3 (any streamed audio, such as a WAV file, software movie or MP3, or even the audio output from any of your audio software). The MIDI fader controls the level of any oncard MIDI (sample playback) instruments and CD audio (ie that from any CD playing on the computer’s CD-ROM drive), while "Line In" determines the level of any physical line input on the rear of the Sound Blaster Audigy card and "Line/Mic 2" controls the level from the stereo mic/line input on the front of the Audigy Drive bay. All of these sources can be added into the mix if required. See Figure 8.1 for a block diagram of the Creative Surround Mixer.

Figure 8.1: Creative Surround Mixer

There are also faders that control the levels of the Sound Blaster Audigy card microphone input and Analog Mix sources. The final fader has a button that allows you to record your Analog Mix, which can be useful in Cubasis, as it enables you to record not only the audio tracks but also MIDI instrument parts, effects and so on. Note that the default sources for the last three faders (which are user definable) can be changed via pull-down menus, making it possible, for example, to replace the mic source with the aux inputs or the S/PDIF inputs. The last fader also allows individual signals to be recorded as an alternative to the Analog Mix function — for example, you may want to create a mixed WAV file comprising just the MIDI instrument parts.

Tip: If you find that you can’t hear the expected output, check the settings in the Creative Surround Mixer. If you’re using Cubasis, also ensure that all of your audio sources are enabled in the ASIO Inputs control panel in the VST Audio menu. If they’re not, you won’t be able to access them.

EAX ADVANCED HD

EAX ADVANCED HD is a sophisticated onboard surround-sound effects system that was originally intended for use in games and other multimedia applications in which both stereo and surround-sound effects can be generated. Of course, much of this is irrelevant to the conventional music user, although the EAX ADVANCED HD system has now evolved to include effects that can be used in music production.

The EAX control panel provides access to up to four studio-quality effects, including a high-quality reverb, which can be added to signals passing through the Creative Surround Mixer. There is no direct means of adding these effects to individual tracks within Cubasis, but it is possible to create an Analog Mix file of selected tracks with their effects added, which may then be imported into Cubasis complete with effects. Each of the effects levels are individually adjustable for each of the sound sources to which the effect is applied.

Reverb and chorus are always available, although with a number of variations on each. The other two effects may be selected from the following settings: Vocal Morpher, Ring Modulator, Pitch Shifter, Frequency Shifter, Flanger, Parametric EQ, Stereo Echo, Distortion, Normalizer and Auto Wah. All of these effects are fully editable, and any changes can be saved in an internal library, enabling you to create custom effects libraries. You can also store complete effects set-ups of all four effects and their routings. The routing system is quite flexible, enabling effects to be cascaded, and it’s also possible to apply effects to the master outputs as well as to the other inputs and outputs of the Creative Surround Mixer.

MIDI and audio mixing

Many soundcard systems allow you to internally mix your multitrack recordings to a new stereo soundfile without the signal ever leaving the computer, but few integrate adequately with the MIDI capabilities of the sequencer, which means that it’s up to the user to work out a way of getting the MIDI parts into a mix. However, Sound Blaster Audigy makes it easy to mix all of your audio tracks with the MIDI sounds coming from the Sound Blaster Audigy chip-based or software synthesisers.

To do this, after you’ve recorded all of the parts of your composition, set up the desired mix and then create a new stereo track. (You’ll be recording your finished work on this track.) Set the source for this track to the ASIO input Mix Post-EQ. Put the track into Record and play the song from start to finish. The complete mix will then be recorded onto the new track as a new stereo audio file. This file may then be opened in an editing package, such as WaveLab Lite, and ultimately it can be burned to CD, all without the signal ever leaving the digital domain.

It’s also possible to use the "What U Hear" feature in the Creative Surround Mixer to record a combination of sources including WAV/MP3 audio, MIDI instruments, EAX ADVANCED HD processing and audio from external sources.

Cubasis VST CE

When you first come to work with a powerful MIDI/audio sequencer such as Cubasis VST CE, the number of options available to you can be overwhelming, so this section is designed to give you some idea of what the program can do for you. You can learn all of the fine details from the manual that comes with Cubasis VST CE, but you can also learn much through experimentation. The program works with both audio and MIDI elements, each of which have their own tracks, and it makes sense to start with the program’s MIDI capabilities first.

Using Cubasis VST CE, all of your MIDI (and audio) tracks can be recorded at different times, after which they can be mixed to produce a finished stereo recording. MIDI parts can be entered either by playing the parts normally, one at a time on a MIDI keyboard; by entering note and timing data manually; or by a combination of "live" playing and editing. The main Arrange page handles basic "recording" and arranging, while other pages address various aspects of MIDI editing, where the recorded data can be represented as a piano-roll-style grid of notes, as a list of Note data or as a regular musical score. The Record and Playback controls are designed to look and operate like a tape recorder’s transport control buttons, and operation is pretty straightforward once you’ve taken some time to find your way around.

Once recorded, the MIDI tracks may be played back via any MIDI-compatible synthesiser, including the ones on your Sound Blaster Audigy card. A recorded MIDI sequence appears in the Arrange window as a block, and this can be dragged (using the computer’s mouse) to a new position in the same track, or it may even be moved to a completely different track so that it plays back with a different sound. Sequence building blocks may also be copied, split into shorter sections or deleted as required. This ability to move and copy the sections you’ve recorded is what makes the sequencer such a powerful music compositional tool.

MIDI as a compositional tool

In fact, composing with MIDI isn’t that different from the traditional musician’s approach. As with the traditional composer, the work often starts at the keyboard, but in this case the keyboard is a MIDI instrument connected to a MIDI sequencer rather than a piano. Instead of writing down a score, the MIDI composer records sections of music into a sequencer against an electronic metronome set to the required tempo.

When hand-writing a score, the traditional musician either has to imagine the effect of the completed work or has to hire musicians to play all of the parts together, but in a MIDI system you can play back your completed composition using synthesised sounds. In either case, what’s played back is determined by the score — one paper, one electronic. And, just like the written score, if you’re not happy with something you’ve done, you don’t have to start from scratch; you can just erase the unwanted notes and "write in" new ones.

sequencer set-up

The MIDI keyboard is connected to the sequencer via a MIDI cable, and when the sequencer is set to Record, any notes played on the keyboard are recorded as MIDI data into whichever Cubasis VST CE MIDI track has been selected for recording. (You can connect the keyboard to either MIDI In port.)

Note that, in Cubasis VST CE, any track can be configured as an audio track (identified by a small waveform icon) or a MIDI track (identified by a musical note icon). You must also select the MIDI destination for each track, which can be either of the external MIDI ports, either of the internal onboard synths or the internal software synth. The options are visible in a pull-down menu that appears when you click on the Output box relating to the MIDI track in question, and any VST instruments you have installed will also be added to this menu.

If your master keyboard is a synthesiser, select Local Off and connect the synth’s MIDI Out to the sequencer MIDI In. Local Off isolates the synth’s keyboard from its sound-generating circuitry so that it behaves as a separate dumb controller keyboard and MIDI synth module. Electrically separating the keyboard from its synth engine in this way is necessary to prevent MIDI information from being fed around the system via the sequencer in a continuous loop, which usually causes trouble with stuck or repeating notes. If you have other synth modules to connect, I’d recommend that you buy a MIDI thru box, as "daisy-chaining" MIDI devices can cause problems when the chain is more than two or three instruments long. Note, however, that you can connect a short chain of MIDI modules (three is a practical limit) to each of the two Sound Blaster Audigy MIDI ports.

A single MIDI port can provide only 16 separate MIDI channels, even if you have a thru box connected; but, because you have two MIDI ports available, the maximum number of separate external MIDI channels that you can address is increased to 32. Combined with the onboard Sound Blaster Audigy synths (which you can use at the same time as the external MIDI ports), this provides plenty of flexibility.

click track

It’s possible to treat Cubasis VST CE simply as a multitrack recorder for MIDI and audio information, but that would be to miss out on a lot of the program’s editing potential. The real power of a sequencer can be seen in the way in which recorded data may be modified or edited, but for the recorded data to make any sense in a beats-and-bars context it must be played in time to a metronome click running at the same tempo as the sequencer. Cubasis VST CE provides an integral click generator for this purpose, which makes editing note timing or copying and moving whole sections very easy and precise. If you don’t want to be tied to tempo at all, you can simply turn off the metronome click and play freely, as you would when using a tape recorder, but then you’d sacrifice the ability to make tempo-related edits, as the bars and beats of your performance wouldn’t line up with the bars and beats determined by the sequencer’s internal tempo clock.

For music incorporating tempo changes, it’s possible to enter a new tempo at any bar and beat location in Cubasis’ Mastertrack, a special track that controls the tempo of the song. However, if you don’t need tempo changes, just input the desired tempo in the control bar’s Tempo box.

tracks and channels

Another potential point of confusion is getting MIDI channels and sequencer tracks mixed up. A sequencer track is simply somewhere to record one layer of your composition, but the MIDI information on that track can be on sent on any MIDI channel you want. However, to prevent confusion, you may choose to use track 1 to control a synth set to MIDI channel 1, track 2 for MIDI channel 2, and so on.

You can also have several different tracks set to the same MIDI channel, and this is very common when recording drum parts that are too complicated to play in one go. For example, you might want to put the bass and snare drums on one track, the cymbals and hi-hats on another and any tom fills on a third. Because these are all on different tracks, they’re effectively recorded as different layers, which makes it easier to play and edit the parts, but they’re still played back by the same MIDI device, as they’re all set to the same MIDI channel.

Most soundcards (including Sound Blaster Audigy) and multitimbral hardware synths have built-in drum sounds, and in the case of GM-compatible synths these are always assigned to MIDI channel 10. Using drums is exactly the same as using any other keyboard sound, except that, instead of having the same sound at different pitches across the keyboard, each key will play back a different drum sound. Figure 8.2 shows the Arrange page of Cubasis VST CE, displaying the layout of the tracks, including a drum part spread over a number of tracks.

Figure 8.2: Cubasis Arrange page (showing drum layers)

rechannelising

As mentioned earlier, Cubasis VST CE converts the incoming MIDI data to the channel set for the track on which you’re recording. This is a process known as rechannelising, which removes the need to select a new MIDI channel on your master keyboard every time you want to record a part on a different MIDI channel. In fact, you don’t need to change the MIDI channel on your keyboard at all, and most people leave it set to transmit on MIDI channel 1.

cut, copy and paste

The basics of cut-and-paste editing are covered in an earlier section. Suffice to say here that, in Cubasis VST CE, editing at note level is generally done in the Key, List or Score Edit pages. For those who don’t read music, the Key Edit window is probably the easiest environment in which to work. The user preferences in Cubasis VST CE allow you to specify which type of edit window will open up when you double-click on a recorded part.

Within Cubasis’ editing pages, you can change the value, start time, length and velocity of any of the notes you’ve played, or you can build up compositions by entering new notes manually onto the quantise grid in non-real-time, rather like writing out a manuscript. In much the same way, it’s also possible to enter notes directly onto the score.

Cutting and pasting whole sections of tracks is done in the main Arrange page. A number of tools are available to make this process as intuitive as possible, and these may be accessed by holding down the right mouse button (on a PC) and then selecting the desired tool. To copy a part and move the copy somewhere else, simply hold down Control and Alt and drag a copy of the part to its new position.

quantisation

Again, the practice of quantising your music is covered in an earlier chapter. The quantise function must be used carefully, as it can strip all of the "feel" from some types of music, but for dance music, where precise timing is essential, quantising is a must. The Cubasis VST CE Quantize box is shown at the top of the Arrange window and provides a menu of all of the available quantise options.

further editing

Other editing options available to the user include the ability to transpose recorded parts, to change the volume of parts and individual notes and to adjust the MIDI pan value. This is done via the Inspector panel that opens up when you click the Inspector icon at the bottom-left-hand corner of the Arrange window. Of course, it pays to be aware of whether the edits you’re performing are destructive or non-destructive.

beyond notes

Unless you deliberately filter out certain types of MIDI data, you’ll find that your sequencer captures Note On/Off, Velocity, Pitch Bend, Modulation, Aftertouch and other controller information, as well as MIDI Program Change and Bank Change messages, and you can also switch Cubasis VST CE to record sysex messages. Furthermore, you don’t have to record all of the MIDI data at once, so if you’re working on a part that needs to have a lot of complicated pitch bending or vibrato added it’s possible to record the part straight onto one track and then record the vibrato and pitch-bend-wheel controller data on a separate track set to the same MIDI channel. As you record the controller data track, you’ll hear it affecting the original performance on the original track, and because it’s a separate track you can edit or erase it without affecting the original MIDI note track. Cubasis VST CE also enables you to draw in the main types of controller data graphically in the lower half of the Key Edit page. (On a PC, after you’ve selected the pencil tool, you’ll have to hold down the Alt key as you begin to draw in controller information or nothing will happen.)

patches

A sequencer track must also be told what synthesiser sound it’s expected to control, and so, in addition to the MIDI channel — which tells it which instrument or which part of a multitimbral instrument it’s controlling — it’s also necessary to enter the program number of the patch you want to hear. If the synthesiser supports MIDI Bank Change messages, you’ll also need to tell it the bank number in which the sound is located. It helps to photocopy the patch lists from your synthesiser manuals and pin them to the wall close to your sequencer and use these for reference.

In Cubasis VST CE, MIDI patch and bank changes are handled within the Inspector section of the Arrange window. Here, GM-compatible synths can have their patches selected by name, as the GM patch names are already built into Cubasis VST CE.

playback

When your MIDI sequence is played back, the sequencer transmits the MIDI information to the receiving synth in exactly the same order, and with the same timing, as the original performance, although you can change the tempo after recording without affecting the pitch (unlike on a tape recorder, where you’re dealing with sound rather than MIDI data). The level of each of the parts in your composition can also be controlled via MIDI, by changing the value of MIDI controller 7 (MIDI master volume).

importing MIDI files

MIDI sequencers save their song data in a proprietary format, which other sequencers may not be able to read. However, as mentioned earlier, data can be moved from one sequencer to another by using the Standard MIDI File (SMF) format. SMFs were devised to allow complete interchangeability between MIDI song files and enable third-party companies to provide commercial MIDI song files. SMFs can handle only the basic 16 MIDI channels, and commercial SMFs are generally distributed either on the Internet or as PC-formatted floppy disks, which can also be read by modern Macintosh computers.

audio sequencing

The audio tracks within Cubasis VST CE record digitised audio directly onto your computer’s hard drive (as WAV files), so in this respect the hard drive takes the place of traditional tape. Unlike a tape recording however, here your audio tracks can be divided into sections that can be copied or moved to different locations in a song, just like your MIDI data. It’s possible to use the same backing vocals on every chorus, and similarly a short drum part can be copied a number of times to form a continuous rhythmic backing.

Using a sequencer with audio isn’t very different from using the MIDI-only version, and the quality of the recording is limited only by the technical specification of the audio soundcard and the source signal. However, before you can record audio or MIDI in Cubasis VST CE, you need to set up the MME and ASIO configurations by going to the Start menu and selecting Programs > Steinberg Cubasis VST > Setup MME. Once this has been done, select ASIO Multimedia Setup or ASIO Direct X Setup to select the Audio driver to communicate between the Sound Blaster Audigy system and Cubasis VST CE.

Figure 8.3: MME Setup page for Augidy/Cubasis

Figure 8.4: ASIO set-up

Line in 2 or aux 2 are probably good choices for connecting the signal source that you wish to record, as these allow you to use the connectors on the front of the Audigy Drive panel.

The outputs to which the Cubasis VST master and buss outputs are routed are set up in the Cubasis Audio Mixer page, using the buttons at the bottom of the master and buss channels. Possible destinations are Front L/R, Rear L/R, WAV/MP3 5/6, WAV/MP3 1/2, WAV/MP3 4/5, Centre/LFE and Reverb. The simplest option is Front L/R, and it’s best to choose this at first, at least until you become more familiar with the program and the routing options available to it.

When you first come to make a recording, the program will also ask you where you would like to store your audio files. Ideally, you should create a special folder for your audio files and name them meaningfully.

When an audio track is recorded, the digitised data is saved as a file on your hard drive, but it also shows up as a block on your sequencer’s Arrange page. You can freely drag the part to a new location, including a different audio track, without changing the data you actually recorded. Similarly, you can divide the audio parts into smaller sections, again without changing the original data. Cubasis is able to playback up to 24 audio channels, this is limited only by the speed and fragmentation level of your audio drive as well as the CPU power and RAM.

Cubasis VST CE relies on WaveLab Lite (or Creative WaveStudio, if you prefer) to perform waveform editing, and to use this it’s first necessary to nominate WaveLab Lite as the wave editor to be opened when an audio sequence is double-clicked. This is done via the audio preferences in Cubasis VST CE. You can also opt to open Creative’s WaveStudio, which also offers de-noising tools and the ability to use Direct X effects, while destructive edits routinely enable you to change audio levels, reverse files (so that they play backwards), create fade-ins and -outs and replace unwanted regions with silence. WaveLab Lite also includes EQ and compression, but it can’t make use of VST plug-ins. However, it can use DX-format plug-ins.

The mixing side of the program is handled by a separate audio mixer screen, where tracks can be EQ’d, balanced and panned. Two aux sends enable effects such as reverb and delay to be shared between the various channels, while each channel also has one insert point into which a single VST plug-in may be loaded. The audio mixer looks just like a hardware mixer, except that the two effects sends and the EQ remain invisible unless you click on the FX/EQ button. Cubasis VST CE provides two bands of parametric EQ per mixer channel, and the mixer includes one stereo group in addition to the main stereo outputs. This group may be routed to a different pair of physical outputs to the main stereo output, which is useful if you’re using a separate mixer and you want to keep some signals separate.

MIDI-controlled mixer automation enables operations like adjustments of level and pan control to be recorded, as well as changes to the parameters of any VST plug-ins being used. Automation allows you to fine-tune your mix until everything is perfect, when it will play back with the right level and right automation moves every time. Putting a mixer channel into Write mode enables automation moves to be recorded, while Read mode plays them back. To disengage the automation, select neither Read nor Write.

Mix-automation data is stored in a dedicated Audio Mix track reserved for this purpose. VST instrument automation is saved internally as MIDI sysex data rather than controller data, but external hardware control is also possible from a MIDI fader box, in which case the automation is saved as MIDI controller information.

As already stated, the number of tracks that you can play back at any one time will depend on the speed of your hard drive and on the power of your computer. Unlike tape, however, you can record more tracks than you can play back, which is a useful feature if you want to play ten guitar solos and then play back one at a time to find the best one. As long as you only play one version at a time, it only counts as one track, for playback purposes. Just mute the tracks you’re not using.

software plug-ins

Most recording and signal-processing tasks traditionally associated with hardware are now available via software, and in this form they use only the native processing power of the computer’s CPU. Cubasis VST CE supports both Direct X plug-ins and Steinberg’s VST plug-in protocol, which allows effects and processors from a number of third-party companies to be used with the system. Note that, unlike the full version of Cubase VST, you can only use one "insert" VST plug-in per mixer channel, plus two "send" effects shared between all channels. Effects cannot be inserted into the master stereo or group channels.

The VST format was created by Steinberg but was then opened up to all of the major music software companies in order to promote compatibility. VST II expands on the original concept by enabling plug-ins to read MIDI information from the host sequencer, thus making it possible to automate the plug-in parameters in much the same way as with mix automation. The practical limit on the number of times a plug-in may be used at once is the amount of DSP (Digital Signal Processing) power and RAM available.

VST instruments

Cubasis VST CE supports VST instruments, which enables third-party software instruments to be accessed from within the program. Visit www.steinberg.net for more details.

Computers can handle any type of synthesis, from emulated analogue to FM, sample based, wavetable and additive. (For more information on synthesis methods, refer to the chapter on "Synthesis Methods".) The amount of polyphony is usually related to the computer processing power available, and any VST instruments that have been installed will show up as available devices on MIDI tracks once they have been loaded and activated via Audio > VST Instruments.

samplers

Software samplers or those integrated into soundcards operate much like their hardware counterparts, and Creative Labs soundcards have had sampling capability for a long time via their SoundFont system.

A SoundFont is a set of one or more WAV-based sound samples that can be loaded into a SoundFont-compatible soundcard for playback. The quality can be impressive, with some particularly good library sounds being available from www.soundfont.com and the websites of other third-party companies. SoundFonts may be loaded into any of the banks on the two onboard chip-based synths, although it’s probably wisest to leave the GM sounds in the first bank (where they are loaded automatically) and add new SoundFonts to subsequent banks. If a SoundFont bank is given the same name as the song in which it’s used, it will automatically appear as available for use when the song is loaded again at a later date.

The Vienna software that comes with your Sound Blaster Audigy card allows WAV files to be recorded and then edited so that you can create your own custom SoundFonts, and there are also some good third-party SoundFont editors out there right now, including one called Wien.

If you need a sampler that can read the CD-ROMs from Akai’s popular sample-format library, a VST sampler such as Steinberg’s Halion or Emagic’s EXS24 VST is the obvious choice. Halion uses the computer’s own RAM as sample memory, and its sound quality is as good as that of the soundcard you’re using.

sequencer familiarisation

If you haven’t used a computer before, take some time to read the manual and then try a few exercises to get used to the mouse. Make sure that you know how to start the machine and how to shut it down properly, and if you have a floppy drive then you’ll need to know how to format new disks and how to move data between your hard drive and your floppy drive. You’ll also need to know how to open and close files; how to open, close and reposition windows; and how to start and quit programs. Once you’re happy with all of the basic computer operations (which shouldn’t take long), you can try your hand at sequencing.

the Arrange page

Most of the successful sequencer packages bear more than a passing resemblance to Steinberg’s Cubase, in which the main page shows the sequencer tracks running from left to right across the screen. An important part of Cubasis VST CE’s Arrange window is the toolbox, which contains six tools, all of which you need to know how to use. The pointer tool is used to select parts and the eraser to delete them, although you can also delete a part by first selecting it and then using the delete/backspace key on your keyboard. The pencil tool is used to change the length of existing parts or to create new parts, while the scissors tool is used to divide recorded parts and the glue tool joins together selected parts to form a single part.

Cubasis VST CE is based directly on Cubase VST but offers slightly fewer features, making it more user friendly for the newcomer. The Arrange page of the Cubasis VST CE sequencer is shown in Figure 8.2, while Figure 8.5 shows the track Inspector area, which can be seen to the left of the main Arrange screen. This always relates to the currently selected track and is where important track data is entered, including patch and bank numbers.

Figure 8.2: Cubasis Arrange page (showing drum layers)

Figure 8.5: Cubasis Arrange page Inspector section

Each track can be set to record on any MIDI channel and can be routed to any available internal or external MIDI destination — ie you don’t have to use track 1 for MIDI channel 1, track 2 for channel 2 and so on, although it may be less confusing at the outset if you do choose to work in this way.

program selection

Having set your tracks to the MIDI channels that you wish to use, you should enter a MIDI Program Change number in the Inspector section of each MIDI track so that Sound Blaster Audigy’s onboard synth plays the sound program of your choice. Cubasis displays the names of the patches in SoundFonts loaded, if you select a track using internal synth A or B. In the Inspector bar, when you select a MIDI track, if the output device is either SB Audigy Synth A or SB Audigy Synth B, you can load high-quality SoundFont sample banks directly from either your hard drive or a CD-ROM. In the Inspector box, click on the Bank box, and at the bottom of the box is a menu item called Manage. This opens up a menu box that allows you to load, save or edit individual SoundFont banks or presets within your Cubasis song. Multiple banks can be loaded up to the limit imposed by available RAM.

All of the GM and SoundFont synth sounds can have their patch names displayed within Cubasis VST CE’s Arrange page, which makes choosing sounds easy. For external synths, simply photocopy the manual’s patch list and keep this to hand so that you can locate the desired patch and bank numbers quickly.

Once you’ve chosen suitable synth sounds for the various tracks in your test recording, you can move on to setting the tempo of the click track.

tempo

Tempo changes are set up the Mastertrack, where the tempo information is shown as a list, although for fixed-tempo songs you only need to set the tempo in the transport window. Once you start recording, the computer will play a simple metronome click for two bars (the default setting) before the recording starts. Click tracks can be very limiting to play to, but it’s easy to record a simple guide drum part first and quantise it so that you can use the drum sound instead of the metronome, and this track can just as easily be erased or replaced when you’re finished with it. You probably don’t want to have to tap out your guide drum rhythm for the whole length of the song, so the simplest option is to create just one or two bars and then copy these as many times as necessary.

drumming made easy

If you find playing drum parts difficult, set up three or four sequencer tracks to the MIDI channel of your drum sounds (which, in the case of GM sounds, is channel 10) and then record your drum part in layers. For example, put the kick-drum part on one track, the snare-drum part on the next drum track and then add a hi-hat part on the third track. The other tracks can be used for cymbal crashes and tom fills.

looping

Cubasis VST CE can be set to loop around two points in the song defined by the left and right markers in the time ruler at the top of the Arrange window. Use the left mouse button (on a PC) to position the left marker and the right-hand button to position the right marker. The Loop option must be turned on in the transport bar for this to work.

the next track

Once you have your guide drum part, select a new track and overdub a suitable keyboard part. You can turn the original metronome click off in the transport window if it’s distracting you.

Listen to each track after you’ve recorded it to check for timing errors or wrong notes. If you’re a good player, you’ll almost certainly get more "feel" in your performance by not quantising it, but if you feel that your music needs tightening up then you should make use of Cubasis’ quantise features. The quantise options include all of the standard time signatures as well as some "swing"-style settings that change the feel from straight to swing. (Note that VST CE only features standard Q settings and T variants.)

moving your music

I’ve already mentioned that one very powerful feature is the ability to move both MIDI data and audio material around, so why not give it a try? All you have to do is use the mouse to drag your sequence to a new position. If you only need a part of it, divide it up by using the scissors tool located in the Toolbox. On a PC, press Control and Alt and click-drag to create a copy.

Cubasis won’t let you drag stereo audio tracks to mono tracks or MIDI tracks to audio tracks, so you shouldn’t get into trouble. And besides, if everything goes wrong, you can always revert to the last version saved and carry on from there. While you’re at it, try putting two MIDI sequences end to end, selecting them both and using the glue tool to weld them into one continuous sequence.

transposing

Use the Transpose function in the Inspector panel to try moving the melody part up or down an octave. This feature is particularly useful if you need to create a part that’s outside the range of your keyboard or if you realise that the part you’ve recorded sounds better when played back an octave higher. You can also transpose all of the elements of a song or section of a song by the same amount to bring about a key change. However, remember not to transpose the drum track, or you’ll hear different drum sounds.

key edit

The other editing process with which you should familiarise yourself is the fixing of wrong notes in the piano-roll or Key Edit window, where the notes are represented as bars on a grid depicting time (in beats and bars) in one direction and pitch (in semitones) in the other. An image of a piano keyboard is used to depict the pitch axis of the grid. Figure 8.6 shows the Key Edit page in Cubasis. To implement corrections, click and hold the offending notes with the mouse and drag them to different locations.

Figure 8.6: Key Edit page

The Key Edit window takes the form of a split screen displaying MIDI Note data in the upper part of the window and MIDI controller data in the lower part. In this window, a new set of tools is provided, comprising an arrow tool for selecting, a pencil for entering notes directly onto the grid, a brush for literally painting in notes (which can be useful for drum parts or creative experimentation), an eraser for deleting notes and a line tool for drawing in graphical controller information, while a magnifying glass is used to play individual notes. The six most useful MIDI controllers — Pitch Bend, Aftertouch, Velocity, Modulation, Main Volume and Pan — can be viewed for editing in the bottom window. Interestingly, it’s this section of the original Cubase program that made possible the familiar rapid-fire snare-drum crescendi used in dance music. To achieve this, use the brush tool to draw in a continuous series of notes on a grid set to (for example) 1/32 of a bar resolution and then use the controller line tool to draw in a steadily rising level.

MIDI list edit

If you’re not comfortable with grid editing, you should investigate the MIDI List Edit window, which represents your composition as a long list of MIDI events, each marked with its own beat and bar location. Values in this list may be changed and new notes added. Figure 8.7 shows the List Edit page from Cubasis VST CE. The list shows the MIDI data within the selected part, while the note lengths are represented graphically on the right-hand side of the window.

Figure 8.7: MIDI List Edit page

score edit

Finally, the musically literate may prefer to edit notes on the stave, and Cubasis VST CE also allows this, although the facilities are simplified when compared to those in Cubase VST. In Cubasis, notes are displayed on a conventional stave and may be physically dragged to new pitches and deleted, or new notes may be inserted. Figure 8.8 shows the Score Edit window in Cubasis VST CE, where any key signature can be set up for both bass and treble clefs. The finished score may be printed out to produce sheet music of a high standard, although some musical knowledge is needed to ensure that your computer has interpreted your playing in the way in which you’d want it to be presented.

Figure 8.8: Score Edit page

more features

What has been described so far represents only a small proportion of what Cubasis VST CE can do, but once you’ve mastered the basic recording and editing skills that have been discussed so far you’ll know enough to start making music. Most of the time, you’ll only need to use a fraction of your sequencer’s features, and you can explore the more sophisticated features as and when you feel you need them. However, you’re bound to come up against the occasional difficulty, so I’ve listed some of the more common problems and their solutions at the end of this section.

practical MIDI automation

When it comes to using MIDI controller information to set up volume and pan effects, you first have to make sure that your instruments respond to these messages. This may sound obvious, but there are a few older instruments out there that are totally oblivious to master volume (controller 7). The only way that you can implement a fade with these is either to pull down the fader by hand or to modify the MIDI Velocity data in the MIDI Note List so that the notes actually become quieter. The line-drawing tool in the Key Edit window makes this relatively easy.

If you have a keyboard with assignable data sliders or wheels, you already have a convenient way of sending controller data in real time. On those occasions when you need to use a lot of controller changes, you’ll also need to place controller information at the start of your song in order to establish the starting conditions. Otherwise, the controller values will remain in the positions at which they were last set.

The SoundFont playback engine used in the Sound Blaster Audigy synth section can use MIDI controllers to adjust numerous sound parameters in real time. It’s also possible to control certain EAX ADVANCED HD effect functions via MIDI, and again all these changes can be recorded. However, in this case, the amount of effect is applied only to the synth, just like with standard reverb and chorus controllers.

Because it’s so easy to automate instruments in a MIDI mix, you’ll probably find that you’re able to do things that you never could before, so take the time to experiment. All of your automation data will be saved with your song, so you can recreate the same mix exactly at any time, and just occasionally you’ll stumble upon something amazing that nobody has tried before. Check out Cubasis’ Mixer page, which will allow you to control values such as level and pan directly using knobs and faders, and the movements that you make here can be recorded as automation data. The Mixer page is shown in Figure 8.9.

Figure 8.9: Cubasis Mixer page

Cubasis VST CE user tips

• Create a default song, ie an "empty" song file that has your instruments already set up and ready to go. Store a copy on a locked floppy so that it can’t be overwritten by accident. A typical default song contains the MIDI channel and track assignment for your different instruments, suitable "vanilla" starting patches and various MIDI status functions, such as MIDI Thru, MIDI Click and so on.

• Create your own metronome. Rather than use the default metronome when recording, program a simple guide drum part and then save your guide percussion parts, either in a separate song or as a part of your default song so that they’ll always be available whenever you start a new song.

• Use your computer keyboard. Although most jobs can be tackled with the mouse, some things are faster and easier to do by using keyboard shortcuts.

• Photocopy the preset patch lists for all of your instruments and also type out the names and descriptions of your user patches. These sheets may then be put into plastic sleeves and clipped into a single "Voices" folder, which you can keep close at hand.

• Don’t over-quantise. Some forms of music demand a rigid approach to timing, but if you want to keep the feel of the original performance it may be better not to quantise at all. In this case, just use the sequencer as you would a tape recorder.

• Back up your work. Even the best computers have a habit of crashing or locking up when you least expect it, so save your song every few minutes. When working with a hard drive, back up important work to floppies or removable media at the end of each session. Modern drives are reliable, but they’re not infallible.

• Keep a notebook. Paper may be low tech, but when you come across a six-month-old disk filled with MIDI files named something like "Ideas 1-99" a few notes are very valuable. I also find it very helpful to use Notepad and save a text file containing all of my notes on the same back-up disk.

• If you create your own MIDI control data for cyclic panning, or if you have an assortment of killer drum fills, save them and build up a library of "MIDI clip art".

MIDI troubleshooting

The most common problem in any audio system is the absence of sound when you’re expecting something to happen. Here are a few things to check if this happens.

• Check that everything is switched on (including your monitoring system) and that your synth modules are set to Multi or Sequencer mode (assuming that you want to use them multitimbrally). Also, make sure that your synths are set to the same MIDI channels as those on which you’re sending data.

• Check your MIDI cable connections and don’t rule out the possibility of having a faulty MIDI lead. To help narrow down the problem, most sequencers provide some visual way of indicating that they’re receiving MIDI data, and many hardware synth modules also have LEDs to signify MIDI activity.

• If two or more instruments try to play the same part, check to see if one or more instruments are set to Omni mode. If your master keyboard plays its own sounds whenever you try to record on any track or channel, check that Local Off really is off. (Note that, on some instruments, Local Off reverts to Local On every time you switch on the power.)

• If playing a single note results in multiple or stuck notes, limited polyphony or other irregularities, you probably have a MIDI loop, where data generated by the master keyboard passes through the sequencer and somehow gets sent back to the input of the master keyboard, completing the loop (if Local On is selected). Again, check that you’re in Local Off mode and also check your MIDI wiring to make sure that you haven’t created an unintentional loop.

If you have an instrument with no Local Off facility, disable the sequencer MIDI Thru on the channel on which your master keyboard is sending data.

• Don’t forget to check the settings in the Creative Surround Mixer.

the virtual mixer

Once you’ve produced and mixed a song using Cubasis VST CE, you don’t need to record it to cassette tape, DAT or MiniDisc. By using the Export Audio facility, your mix can be saved to disk as a stereo audio file. You can also use the Analog Mix part of the Creative Surround Mixer to squeeze more flexibility out of the excellent onboard EAX ADVANCED HD section by recording effected tracks to new audio files. Cubasis VST CE doesn’t have any way of routing individual tracks via the Creative EAX ADVANCED HD section, but there’s an easy workaround for this. Simply mute all of the audio tracks (other than those to which you want to add the effect), route the output of the VST mixer via the desired EAX ADVANCED HD effect and then export the result to a new audio file. After that, import this new audio file into your song, mute the original dry versions and you have your track complete with effects. Alternatively, route your mix to the ASIO Post-Effects output and then set up a new audio track to record from this source.

stereo editors

Once exported, you can open the finished stereo file in a dedicated editing package — such as your copy of WaveLab Lite (included in this package) or Creative WaveStudio — and add the finishing touches before burning it to CD. Figure 8.10 shows the main editing screen of WaveLab. Note that the ASIO driver used by Cubasis only supports 48kHz audio recording, so you’ll have to convert the sample rate by using your stereo-editing software before attempting to burn your finished tracks to CD. The bundled EMU sample rate converter is recommended for this task. Note that both WaveLab Lite and WaveStudio use the MME driver, rather than ASIO, which means that they can support playback of 44.1kHz audio files.

Figure 8.10: WaveLab main screen

Good editing software must be able to offer precise cut-and-paste editing with variable crossfades between sections, the ability to create fade-ins and fade-outs and the means of changing levels. There should also be a facility to silence unwanted material and to normalise the level of audio files and sections of audio. (Normalising means that the level of the selected audio is increased so that its loudest point is either at digital maximum level or at a user-defined number of decibels below this. Basically, it’s a simple way of getting your audio as loud as you can without risking clipping.)

Note that, unlike the full version of WaveLab, WaveLab Lite doesn’t offer VST compatibility, so you can’t process audio by using VST plug-ins, although built-in facilities exist to process EQ and dynamics control, the two most widely used processes in mastering. If you need to use other plug-ins, you can always open the file in Cubasis VST CE and apply plug-in processing there before exporting the processed audio to a new track.

Producing an album in WaveLab Lite involves first trimming any unwanted material from the beginnings and ends of the recorded tracks and then creating any fade-ins or -outs that you may want. The built-in dynamics- and EQ-processing facilities can be used to fix up any tracks that don’t sound quite right, and then the subjective volumes of the different tracks can be matched up. This is an artistic decision, so you’ll have to go by your instincts.

You can’t burn a CD directly from WaveLab Lite, so the last part of the process is handled by another piece of Creative software called Creative Playcenter 3, which is really a kind of jukebox program that’s used to play WAV and MP3 files and to facilitate CD burning. However, as long as you’ve finished off your individual tracks in WaveLab Lite, it can also burn your master audio CD for you. It’s a very simple playlist-style program and places a fixed gap of two seconds between audio tracks. Creative Playcenter 3 can also be used to encode your stereo mixes into MP3 format so that you can post them on the Internet. If you need greater flexibility, I recommend that you buy a dedicated audio-CD-burning program.

ReCycle

ReCycle is one of the most popular tools for dance-music production, as it’s able to process audio drum loops so as to create sets of audio samples that enable the loops to be played back over a range of tempi without affecting their pitch. This special version of ReCycle enables the loops to be saved in SoundFont II format so that they can be played back using your Sound Blaster Audigy card rather than an expensive hardware sampler. The only limit to the number and length of samples that you can use is the amount of free RAM available, but this should be no problem, given that most loops are only a couple of bars long.

In addition to making drum loops more "elastic", ReCycle is also able to do a number of other things, including trim loops to a user-defined length and replace individual sounds within a loop with other sounds or sections of silence. This apparent magic is achieved by slicing the loops into smaller samples, where each sample segment is a single beat of the loop. These individual samples are then played back by using MIDI Note data to recreate the original loop. By increasing the space between the beats (ie by slowing down the tempo of the MIDI sequence driving them) the tempo can be slowed down, or it can be increased by moving the beats closer together.

After importing a section of audio, your first task is to trim the start and end points so that the audio loops smoothly without any clicks or timing jumps, and there are a number of simple tools provided to do just this. The waveform can be seen on the screen, and in most cases the starts of beats are quite obvious. The loop can be heard as you adjust it, so finding the best loop point is a straightforward business. ReCycle then separates out the beats based on a threshold that the user can adjust with a sensitivity control. This can be adjusted while the loop is running, enabling you to hear the result right away, in real time. With simple loops, the program will almost always be able to separate the beats for you with no trouble, but if the sound is especially dense or otherwise unusual then the slice points can be adjusted, inserted or removed manually. It’s also possible to "lock" slices so that subsequent changes in threshold won’t affect them. A waveform overview at the top of the screen shows the complete waveform, while you can zoom in on the lower part of the screen if you need greater accuracy.

Once a loop has been sliced into beats, each beat is automatically assigned a different MIDI note, starting with C1 and successively rising in steps of one semitone. By driving this sample set with a rising scale of equally spaced MIDI notes, the original loop can be recreated at any tempo. (The practical range is up to around +/-50% before the sound becomes too unnatural.) ReCycle may also be used to extract single drum beats from a loop, which could be useful if you wanted to create a snare-drum sample by using the snare-drum sound from the loop.

Not only is it possible to play these loops at different tempi but also individual beats may be retuned. Changes in time signature or groove are also easy to achieve by requantising the MIDI file driving the loop or by adding swing to it. (Figure 8.11 shows ReCycle’s main screen.) Also, ReCycle can be used to speed up the process of importing audio multisamples from CD. For example, audio recordings of piano notes can be automatically mapped to different MIDI notes (not the right ones, initially!), after which you just need to use Vienna to remap the samples to the correct MIDI notes.

Figure 8.11: ReCycle main screen

Even though ReCycle SF can’t export segments as WAV files, once you’ve exported the sounds to SoundFonts you can then use Vienna to export the individual samples as WAV files.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

Sound Blaster Audigy and its music software
ASIO
ASIO and surround-sound
the Creative Surround Mixer
EAX ADVANCED HD
MIDI and audio mixing
Cubasis VST CE
MIDI as a compositional tool
sequencer set-up
click track
tracks and channels
rechannelising
cut, copy and paste
quantisation
further editing
beyond notes
patches
playback
importing MIDI files
audio sequencing
software plug-ins
VST instruments
samplers
sequencer familiarisation
the Arrange page
program selection
tempo
drumming made easy
looping
the next track
moving your music
transposing
key edit
MIDI list edit
score edit
more features
practical MIDI automation
Cubasis VST CE user tips
MIDI troubleshooting
the virtual mixer
stereo editors
ReCycle


chapter 9

the desktop Sound Blaster Audigy studio

With its flexible I/O configuration and its onboard synthesisers and effects, Sound Blaster Audigy provides the facilities that most musicians need at a price that they can afford, and in combination with the bundled software and a suitable MIDI keyboard it forms the basis of a complete desktop recording studio that can be expanded or upgraded whenever the user wishes. This chapter looks at some of the practical and technical issues involved in setting up a desktop studio based around an Sound Blaster Audigy card.

To begin with, when feeding a balanced destination (such as a mixer) from an unbalanced source (such as Sound Blaster Audigy’s line outputs), wiring up a special unbalanced-to-balanced cable as shown in Figure 9.1 will reduce the risk of interference from ground-loop hum. Use this technique in combination with adapter cables that convert the stereo mini jacks on the back of the Sound Blaster Audigy card to individual mono quarter-inch jack sockets.

Figure 9.1: Unbalanced-to-balanced cable connection

the all-digital myth

Just because you can use a computer to record and mix audio, there’s no reason why you can’t use other audio components in your system, both analogue and digital. In a simple set-up where you want to include external hardware synths in the mix, for example, a small analogue model is the most cost-effective mixer you can use, as you get good sound quality; you can patch in outboard effects, if you need to; and you don’t have to worry about sample rates and synchronisation if you want to use material from other digital sources, such as a CD, DAT or MiniDisc. It’s also a good idea to choose a mixer with a few more inputs than you currently need, because studios have a habit of growing. Here are some more reasons why you should think about adding a mixer.

mixer benefits

While Sound Blaster Audigy comes with mic and line inputs that allow you to record your own WAV audio files, it’s simply not possible to include a studio-quality mic pre-amplifier with phantom powering for capacitor microphones, as these alone tend to cost more than the complete Sound Blaster Audigy bundle. Furthermore, soundcards have to work inside the PC, where high-gain mic inputs can pick up interference from poorly screened data busses, which is another good reason for choosing an external mic pre-amp/mixer for serious applications. You can certainly get good-quality demo results by using the built-in mic amp, but if you’re aiming for commercial-quality CDs and you wish to use studio-grade capacitor microphones then you’ll need to think about buying either a separate mic amp or a mixer with phantom-powered mic inputs to bring the output from a decent mic up to line level. (Read the following chapter, "Recording With Microphones", for more information about capacitor microphones and their uses.) Once at line level, the signal can be fed into the line input of your Sound Blaster Audigy card, where interference from inside the computer is much less of a problem.

Even using a fairly basic general-purpose mixer, you can still use one channel as a mic pre-amp simply by turning the channel fader right down and then using the channel insert send (or direct channel output, if your mixer has one) to feed your soundcard. In this case, the mic gain is set by using the channel gain trim and the signal level is monitored within the host software. Figure 9.2 shows how a mixer might be added to an Sound Blaster Audigy-based PC music-recording system.

Figure 9.2: A typical soundcard studio (master synth Local Off)

If your mixer has no insert points, it’s equally simple to use the pre-fade (foldback) aux send on the mic channel to send the mic signal to the correspondingly numbered aux-send output, which in turn is connected to the soundcard input. For example, you could feed your mic into mixer channel 1 and then route this to the (pre-fade) aux 1 output by turning up the aux 1 send on channel 1 only. The level fader on channel 1 would be off and the level sent to the soundcard would be controlled by the aux 1 master output level knob.

Outboard effects may be connected to the mixer in the conventional way, via insert points or the post-fade aux send/return connections as described in "Audio Mixers". Alternatively, if you only need a mic pre-amp and you don’t need a mixer, your best option might be a good recording pre-amp.

recording pre-amps

A typical recording pre-amp combines a mic/line/instrument pre-amp with a compressor, and some have additional functions such as an equaliser, limiter or de-esser. These pre-amps plug directly into the line input of your soundcard, although some also feature a digital output which can be connected to the S/PDIF digital input of your soundcard, in which case the pre-amp must be used as the sync master and the soundcard as the slave. Electric guitars and basses may be plugged into the high-impedance instrument input, while line-level sources such as synthesisers may be recorded via the line input.

Having a compressor in a recording pre-amp is useful, as it evens out the signal level before it’s fed into the soundcard. Although there are some very nice software compressor/limiter plug-ins currently available, none of them will prevent the input of the soundcard from being overloaded in the case of unexpected level peaks because, by their very nature, they come after the analogue-to-digital converters in the signal path.

Having a good-quality equaliser means that you can adjust the tone of the sound prior to recording, although any radical EQ is best applied during the mixing stage, when you can hear the sound being processed in context with the other instruments and voices in the mix. If you intend to work by recording one track at a time, a recording pre-amp is the best option, but if you also need to mix external signals with the outputs from your soundcard then a small mixer is the right way to go.

Sound Blaster Audigy and MIDI

The usual way of using MIDI with a soundcard is to use a MIDI adaptor cable that plugs into the card’s joystick port. Alternatively, you can buy a hardware adaptor, which looks like a long multipin plug with MIDI sockets built into it. Sound Blaster Audigy provides two sets of MIDI ports, one via the usual joystick connector and one on the front of the Audigy Drive. This enables you to connect and control up to 32 external MIDI parts — for example, two 16-part multitimbral synthesisers or modules. The synthesiser sections of Sound Blaster Audigy use virtual MIDI ports, so in all you have access to up to 48 MIDI parts generated by the Sound Blaster Audigy card, plus 32 external synthesiser parts, all of which may be used simultaneously.

A "dumb" MIDI master keyboard can simply be connected to either of Sound Blaster Audigy’s MIDI Ins, while a MIDI synth keyboard would need to be set to Local Off so that the synth section could be driven from one of the MIDI Out ports. Figure 9.2 (above) shows the latter option.

expansion options

The Sound Blaster Audigy/PC music studio offers enormous creative potential, given that it’s relatively inexpensive and compact enough to fit on a desktop. However, native effects and synthesisers are quite power hungry, and when new software versions become available they always include new features that take up more of your processor power. For that reason, it’s best to choose a fast computer that has a processor that can be upgraded to a faster model when the time comes.

If you decide to add hardware synthesisers and effects units to your system, you’ll need to buy a hardware mixer, as explained earlier, but the great thing about the Sound Blaster Audigy bundle is that you can start making very serious music right away and then expand your system as your needs demand. For example, you may wish to upgrade Cubasis VST CE and WaveLab Lite to the full Cubase VST and WaveLab programs, which will add more features and open up more expansion paths.

latency and monitoring

Sound Blaster Audigy gets around the latency problem (the causes of which are investigated earlier in this book) very elegantly by providing thru monitoring on the card itself, so that, when you’re recording, the input signal is fed directly to the card output with no delay. This precludes the need to monitor the input via any plug-in effects when recording, but it is still possible to route via the hardware EAX ADVANCED HD effects on the card, if required.

Latency also affects virtual instruments in the same way as it does regular audio tracks, but unfortunately thru monitoring doesn’t solve this problem, as the virtual instruments are powered by the host computer’s CPU. Fortunately, Sound Blaster Audigy allows low-latency monitoring, even with slower Pentium II computers, and if you have an even older machine that won’t allow you to use the lower latency settings, you can still record the MIDI parts using regular synth sounds from Sound Blaster Audigy and then switch the track to using the VST instrument’s sounds once the MIDI part is finished.

technical issues

Many soundcards now offer better than 16-bit resolution, although you should be aware that 24-bit recordings take up 50% more hard-disk space and processing power than 16-bit recordings made at the same sample rate. The point of having 24-bit converters is to provide more dynamic range than 16-bit recordings, but unless the rest of your studio equipment is of superb quality the subjective difference between the two settings is actually quite small. By all means try different bit depths (numbers of bits) to determine if you can hear a difference, but 16-bit resolution is generally fine for typical pop music.

If you need to send audio from your computer to a digital stereo recorder, such as a DAT or a MiniDisc machine, you’ll need to use Sound Blaster Audigy’s digital I/O, which conforms to the S/PDIF standard, but you need to know that there are two types are available. The more common is co-axial, which connects via phono sockets, although there’s also a fibre-optic version available, which is known as TOSlink. I mention this because you need to ensure that the S/PDIF connector on the soundcard matches the one on your recorder. Sound Blaster Audigy provides both RCA phono and optical digital I/O, so connecting to other equipment is never a problem. Sound Blaster Audigy has high-quality, 24-bit analogue-to-digital converters to meet the needs of audio professionals, but 24-bit digital signals coming in via the S/PDIF input are automatically reduced to 16 bits (the standard for audio CDs). Also, be aware that SCMS (Serial Copycode Management System) copy-protection codes are recognised by the S/PDIF inputs, so it may not be possible to record some protected material via the digital inputs.

Professional audio equipment uses the AES/EBU interface protocol, which is a balanced system that uses XLR connectors, which aren’t used on soundcards, although they are fitted to some more professional audio equipment. Adaptor cables can be purchased to transfer signals from an AES/EBU source to an S/PDIF input, although you should note that the AES/EBU data stream doesn’t carry track-start IDs or SCMS information.

about digital recording

One of the great benefits of hard-disk recording is random access. Computer hard drives can move to any piece of data within a few milliseconds; you don’t have to wait for tape to wind to get you where you want to go. However, the advantages of random access go much further than simply avoiding tape-rewinding time. By using a relatively small amount of RAM memory as a buffer, audio can be read onto and from a disk in a continuous, uninterrupted stream, even if the audio file comprises segments scattered all over the disk’s surface. Furthermore, because of their powerful error-correction systems, computer hard drives are less prone to errors than tape is. The faster the drive can access and transfer data, the smaller the buffer size needed to make the system work reliably and the lower the latency value.

hard-disk considerations

Once a hard drive is full, you’ll need to erase it before you can do any more work, so if you want to keep what you’ve already done then you need a way of backing it up. The rule of thumb on recording time is that one track-minute of 16-bit, 48kHz audio eats up around 6MB, so a 16-track album project might take up around 5GB. Because hard drives aren’t yet cheap enough to use for permanent archiving, some other form of back-up system is needed. CD-R is good for storing up to around two track-hours of audio (ie around two or three multitrack songs), and writable DVD (Digital Versatile Disc) is becoming cheaper all the time for those who need a greater storage capacity.

My own preference is to use CD-R or CD-RW and to save both the sequencer song file and all of the audio used for each track, ideally organised in separate folders. Getting rid of unwanted audio takes prior to archiving can save a lot of space, but be sure not to discard anything that you may wish to use later. Also, don’t cut corners by using cheap, unbranded disks, as you may lose your valuable data, and avoid getting dust and fingermarks on the disks prior to recording, as this can cause problems when you’re burning.

the practical desktop studio

A traditional recording studio is physically very complex, compared with its desktop counterpart, but the software in a desktop system does the same job as the hardware it replaces, and often a lot more. This saves a lot of money and effort spent on cabling, although you’ll probably still need to resort to using mains distribution boards with multiple power sockets. Audio and computer equipment doesn’t take a lot of power, so it’s generally quite safe to run a desktop studio system from just a pair of distribution boards fed from a double wall socket. It’s also wise to use a mains filter/spike suppressor on your computer to help prevent crashes caused by interference in the mains supply.

Be sure not to remove the earth leads from any equipment that is supposed to be earthed, and check your mains plugs regularly, as loose wires are not only dangerous but they will also cause intermittent crackles and buzzes. Plugs need to be checked regularly, as even the best-made connections have a habit of coming loose over time.

All audio connections should be made using screened cable, while noisy computer drives should be positioned as far away from the mixing position as possible. Some drives are much noisier than others, so it’s worth spending a little more on a quieter drive, especially if you want to record in the same room as your computer. Also, check out some of the computer upgrades available for reducing noise, such as hard-drive sleeves and low-noise fans.

Unless you plan to restrict your MIDI sound sources to those that can be generated by Sound Blaster Audigy or by VST instruments, you’ll need an external mixer and some external sound modules as well as your master keyboard. This involves a certain amount of wiring but still much less than you’d find in a hardware-based studio. Again, it’s vital that you use properly screened cable if interference problems are to be avoided.

studio layout

In a traditional recording studio, the mixing console is the control centre for the whole studio and everything else is sited relative to it. In the desktop studio, however, the focal point of your system is both the computer keyboard and its monitor as well as your hardware mixer, if you have one. In this kind of set-up, the usual layout is to have the mixer dead centre, with the computer monitor behind it and the computer keyboard in front. However, you’ll also need to be able to get to your MIDI keyboard easily, so a tiered keyboard stand might offer the neatest solution. Stereo recorders and CD-burners (where not integral) can generally be positioned to one side, as you don’t usually need to reach them during the mixing process.

the components

For the musician working alone, a combined mic pre-amp and compressor (usually called a recording pre-amp or voice channel) is perfect for feeding high-quality audio signals into the soundcard. A model with a high-impedance instrument input will allow you to record electric guitar or bass, and one that also features line and instrument-level inputs would also be useful. The one that you choose should also be able to provide phantom power for capacitor microphones. Most pre-amps are rack mounted, as are synth modules, samplers and effects units, so it’s often best to put all of these in a free-standing rack positioned to one side of the mixing position. The cables between this rack and the mixer can then be clipped together with cable ties to keep things tidy.

Avoid having mains leads running alongside signal cables, as this can introduce hum into the system, and you should also keep mains-adaptor-style power supplies away from signal cables for the same reason.

Nothing should be placed between the monitor speakers and the sound engineer’s head, so if your rack is higher than the bottom of your monitor speakers it should be moved to one side.

A cassette deck is also useful for creating quick listening copies that you can try in the car or in your ghetto blaster, and it always helps to have some commercial CDs at hand that you can play back from your computer just before you do any serious mixing. Listening to these will give your ears an idea of what kind of sound to aim for and will also help to compensate for any inaccuracies in the monitoring system.

the monitoring system

Even the best soundcard isn’t going to produce top studio results if it’s connected to a pair of cheap and (probably) highly inaccurate plastic desktop speakers. If you’re serious about your music recording, you should buy a pair of small studio monitor loudspeakers, or at the very least a pair of reasonably neutral-sounding hi-fi speakers and a suitable amplifier to drive them, because if what you hear over your loudspeakers isn’t accurate then you have no way of knowing what your mixes really sound like. Sound Blaster Audigy’s outputs are unbalanced and at a line level suitable for feeding into a hi-fi-style amplifier.

A practical monitoring system for a home studio comprises a pair of nearfield monitors and a pair of headphones. Headphones are extremely useful, as they can reveal small distortions, noise and other flaws that loudspeakers might miss, but don’t rely on them for mixing, as they can give a false sense of bass.

A stereo hi-fi amp or a dedicated power amp of 30W per channel or more is fine for monitoring, but don’t go for anything less powerful because, although you may not mix very loudly, signal peaks — such as those cause by drum hits — could cause smaller amplifiers to clip. Distorted signal peaks caused by an underpowered amplifier can lead to loudspeaker damage, and they also affect the audio quality quite significantly.

Use the aux, CD or tuner inputs to connect to the output of your soundcard, unless you also have a mixer, in which case connect the soundcard to the mixer and the mixer’s stereo outputs to the hi-fi amp. (You can’t use phono record-deck inputs, as these are designed for use only with record-player cartridges.)

loudspeakers

Everything that you record and mix is judged by what you hear from your monitor loudspeakers, so it’s important to choose a pair that you can rely on to give you the truth. Choose the most honest-sounding speakers you can afford, rather than speakers that flatter, and try not to be tempted into buying speakers that are too big for the room in which you’re working. Medium-sized two-way speakers are best for home-studio use.

Active loudspeakers (ie those with separate built-in amplifiers for the bass/mid driver and the tweeter) tend to sound tighter and cleaner than passive models, but they’re more expensive. They’re also more difficult to use without a mixer because, unlike a separate hi-fi amplifier, there’s no easily accessible physical volume control.

Whether you choose to use active or passive speakers, you should choose magnetically shielded models if you want to use them close to a conventional computer monitor, or you may suffer colour distortion at the edges of the screen. Flat-screen LCD monitors are unaffected by magnetic fields.

the speaker/room relationship

The performance of a loudspeaker is influenced by the room in which it’s used. Small speakers often cause problems at low bass frequencies, so it’s generally best to use two-way nearfield monitors that roll off gently below 60Hz rather than ones that generate a lot of really deep bass. It’s best to place them on rigid stands behind your computer desk, rather than directly on it, and stands that can be filled with sand or lead shot give the best results. Poor speaker mounting often results in a lack of clarity, especially with bass sounds.

Set up your speakers symmetrically, as shown in Figure 9.3, or your stereo image won’t be accurate. The room should also be as acoustically symmetrical as possible, especially close to the mixing position. For example, it’s not good to have a hard, reflective surface on one side and an absorbent surface (such as heavy curtains) on the other, as this will also affect the stereo imaging. Positioning the speakers between one and one and a half metres from the mixing position is usually best. Also, try to get the speakers to form an equilateral triangle in relation to your listening position. For example, if the speakers are a metre apart, they should also be a metre away from you.

Figure 9.3: Monitor set-up

Avoid putting speakers in or too near corners, as this causes an unpredictable bass boost, and you may end up having no idea of what your bass instruments really sound like. In a rectangular room, it’s usually best to position the speakers along the longest wall.

acoustic treatment

A little acoustic treatment can improve the accuracy of a monitoring environment quite noticeably. The trick is to avoid strong reflections from the walls, floors and ceilings. Simple things such as carpets, curtains and soft furnishings in large rooms can help enormously without making the room sound too dead, while in smaller rooms sticking panels of acoustic foam or heavy curtains on the walls on either side of your working position will help a great deal. Figure 9.4 shows a practical studio layout.

Figure 9.4: Practical studio layout

digital cables

With digital connections, it’s important to choose the right kind of cable, as the wrong kind can lead to errors and cause random clicks and pops. Co-axial S/PDIF signals are generally connected using RCA phono type cables, and physically these are interchangeable with many audio cables. However, it’s not wise to use audio cables, as these have the wrong impedance value for carrying digital signals. Digital cable for S/PDIF use should be 75-ohm co-ax, and it’s well worth buying ready-made digital cables from a reputable source, as these often have better connectors than the type you can buy from an audio parts store.

You might imagine that optical cables would be less problematic, but in reality there are several different grades and the cheaper ones are only suitable for data transmission over short distances. It’s also vitally important not to kink optical cables or bend them around too tight a radius or you’ll fracture the cable inside.

last but not least

Buy yourself a comfortable chair for working at the computer, because you’re likely to spend long periods of time there and using the wrong chair can result in back and neck problems. Also, avoid working too close to the monitor screen, as this will cause eyestrain.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

the desktop Sound Blaster Audigy studio
the all-digital myth (xxx 205)
mixer benefits (xxx 206)
recording pre-amps (xxx 207)
Sound Blaster Audigy and MIDI (xxx 208)
expansion options (xxx 209)
latency and monitoring (xxx 210)
technical issues (xxx 211)
about digital recording (xxx 212)
hard-disk considerations (xxx 213)
the practical desktop studio (xxx 214)
studio layout (xxx 215)
the components (xxx 216)
the monitoring system (xxx 217)
loudspeakers (xxx 218)
the speaker/room relationship (xxx 219)
acoustic treatment (xxx 220)
digital cables (xxx 221)
last but not least (xxx 222)


chapter 10

recording with microphones

Unless you plan to make music entirely using MIDI instruments, you’re going to need to know how to use a microphone. You’ll also need to know a little bit about the different types of microphone available and how to match the right microphone to the right task. All microphones perform the task of converting sound energy into electrical energy, and there are many different types of microphone, but in music recording mainly dynamic or capacitor microphones are used. Dynamic mics are the most common because of their cheapness and suitability for stage work, while capacitor microphones are popular for studio use because of their superior sound quality and greater sensitivity. Fortunately, perfectly acceptable capacitor microphones are now available at much lower prices than they used to be.

The one thing that all microphones have in common is that air vibrations (ie sounds) cause a lightweight diaphragm in them to move back and forth. By this simple mechanism, the rapid positive and negative changes in air pressure that we perceive as sound are converted into corresponding positive and negative fluctuations in electrical current.

dynamic mics

A dynamic mic comprises a lightweight, rigid diaphragm attached to a coil of wire suspended in a magnetic field created by a permanent magnet and an air cavity. As the diaphragm moves in response to sound, so does the coil, and a tiny electrical current is generated in exactly the same way that a spinning dynamo produces electricity. Dynamic mics are relatively cheap and robust, and they require no electrical power.

However, dynamic microphones are limited in that the sound energy has to move both the microphone’s diaphragm and the voice coil attached to it, so high-frequency vibrations are opposed by the combined inertia of the coil and diaphragm. What this means in practice is that few dynamic models are able to produce a meaningful output far beyond 16kHz. Figure 10.1 shows the schematic of a typical dynamic mic.

Figure 10.1: Dynamic mic schematic

Because of the relatively heavy mass of the diaphragm-coil assembly, the dynamic microphone isn’t particularly efficient, either. In other words, there’s very little electrical output, so the signal needs to be amplified many times to bring it up to line level, and the more you have to amplify a signal, the more electrical background noise is added. With loud or nearby sounds, this isn’t serious, but when working with quiet or distant sound sources, dynamic microphones tend to perform poorly.

capacitor mics

Capacitor microphones (sometimes known as condenser mics) don’t need voice coils because they work on an entirely different principle. This means that the diaphragm can be made much thinner and more flexible, and so, because of its lower inertia, the diaphragm is able to follow high frequencies more accurately. The drawbacks are that capacitor mics cost a little more than dynamic models and require a power source to operate.

The diaphragm of a typical capacitor microphone is just a few microns thick (ie a few millionths of a metre), and this is coated with a layer of metal (usually gold) just a few atoms thick to make it electrically conductive and suspended a very short distance from a conductive, stationary backplate. As the diaphragm vibrates, its distance from the stationary metal plate fluctuates. A fixed electrical charge is applied between the diaphragm and the plate, which results in a corresponding change in electrical voltage being produced as the diaphragm moves. This change in voltage is amplified by sensitive circuitry within the microphone, which is why capacitor microphones need electrical power to operate. Power is also needed to provide the electrical charge on the diaphragm. In most instances, this power comes from the phantom power source in the mixer or microphone pre-amplifier. Because of the nature of phantom powering, it can work only with balanced microphones and balanced microphone cables, and all capacitor microphones are balanced. Figure 10.2 shows the way in which a capacitor mic works. Note that tube-based capacitor mics tend to have their own dedicated power supplies, because of the high voltages required by their tubes, so in these cases phantom power isn’t required.

Figure 10.2: Capacitor mic schematic

back-electret mics

With a back-electret mic, instead of the capsule being charged from an external voltage supply, the microphone capsule contains a permanent electrical charge sealed in an insulating material. A pre-amplifier is still required to amplify the signal from the capsule, but this may be battery operated in some models. The type of electret mic used for studio work has this permanently charged material fixed to the capsule’s stationary backplate, allowing the same lightweight, metallised plastic diaphragm as that found on true capacitor models to be used. The best models can rival a conventional capacitor microphone in all aspects of performance, although the models that can run on battery power tend to be rather less sensitive than those designed to run only on phantom power. Figure 10.3 shows the schematic of a back-electret microphone. Good back-electret models may be used in the same way as capacitor models. The only practical difference is that the vast majority of back-electret models aren’t built with switchable pick-up patterns.

Figure 10.3: Back-electret mic schematic

typical uses

Smaller-diaphragm capacitor microphones tend to sound more accurate, while larger-diaphragm models often have a warm, flattering sound, making them popular for recording studio vocals. Capacitor mics exhibit a significant increase in sensitivity and high-frequency response compared with dynamic models and are commonly used for recording vocals and acoustic instruments and being used as drum-kit overheads to capture the cymbal sound and general room ambience.

Dynamic mics can be used to record vocals, although the result is likely to be less "airy" or open sounding than that picked up by capacitor models. They are also used for close-miking drums and for miking guitar and bass-instrument amplifiers. Dynamic mics can be used balanced or unbalanced, but they must be balanced if they are to be connected to a system where the mic inputs are phantom powered, or their performance will be seriously compromised and there will be a small risk of damage to the microphone.

cardioid mics

In the project or home studio, where serious acoustic treatment isn’t usually an option, most recording is done using unidirectional-pattern mics, so called because they pick up sound from mainly one direction. The common name for this type of microphone is cardioid, which means "heart shaped", and this term is used because the pick-up pattern is roughly heart shaped when plotted on a circular graph. This shows that the microphone is most effective when picking up sounds from in front, which helps to keep individual sounds separate and minimises the effect of room reflections. Both dynamic and capacitor microphones are commonly available in cardioid versions. The other possible patterns are omni-directional (where the mic is equally sensitive in all directions) and figure of eight (where the microphone is equally sensitive to sound coming from the front or rear but is insensitive to sound approaching from the sides).

Some of the more expensive capacitor mics have switchable polar patterns, enabling them to be used in omni, cardioid or figure-of-eight mode. These models use two diaphragms, the outputs from which are mixed in various proportions and phases to produce the necessary patterns.

the proximity effect

The so-called proximity effect — which applies to cardioid-pattern microphones and also to figure-of-eight models — causes a significant bass boost when the microphone is used to pick up sound sources closer than 20-30mm. Used creatively, the proximity effect can give the experienced vocalist a means of adding tone and expression to a performance, but in the studio it’s an unwelcome source of inconsistency. For this reason, it’s normal to record a performance at least 100mm from the microphone. Dynamic mics designed for stage use often have a filter to reduce the level at low frequencies, as stage-vocal mics tend to be used much closer to the mouth. Such microphones can sound bass light when used at a distance from the sound source, and it’s particularly important that microphones used for bass-guitar and kick-drum miking aren’t low-cut filtered in this way. Dynamic mics with extended low-frequency responses or pronounced bass-boost characteristics are also built especially for kick-drum miking.

presence

A theoretically perfect mic would have a flat frequency response over the entire audio range, but this isn’t always desirable and many vocal mics are designed with a deliberate degree of treble boost or presence to help the vocals cut through a mix. This characteristic is sometimes called a presence peak, and different manufacturers emphasise different parts of the audio spectrum — usually between 3kHz and 8kHz — in order to achieve the desired effect.

choosing the right microphone

When deciding on which microphone to use for a particular task, first think about whether the sound source you want to record is loud and close or quiet and distant. If it’s loud, you can choose either a dynamic microphone — which will give a solid, punchy sound — or a capacitor microphone, which will produce a more transparent, detailed sound. If the sound source is quiet or distant, a capacitor or sensitive back-electret microphone is the preferred choice.

The professional engineer may also decide to use a pick-up pattern other than cardioid, but cardioid-only mics are fine for home-studio use. Note that electric-guitar amplifiers can be recorded using either dynamic or capacitor models. Dynamic models produce a solid, European sound, while capacitor mics tend to produce a brighter, more American sound.

direct injection

When you use a microphone, the quality of the sound you record depends on both the microphone and on the acoustic character of the recording environment. The greater the distance between the mic and the sound source, the greater the influence of the room acoustics. All natural sound must be recorded using a microphone, but many electronic musical instruments can be recorded using a method known as direct injection, or DI. Direct injection simply means plugging a signal from an electronic or electric musical instrument into a recording system, often using some kind of pre-amplifier or matching transformer. DI recording techniques are suitable for bass guitar, "clean" guitar (and lead guitars with a suitable guitar pre-amp), synths, samplers, drum machines and other electronic sources.

Synths, samplers and drum machines can usually be connected directly to the line input of a mixer or soundcard, but guitars and basses should ideally be DI’d via a matching circuit of some kind. This is because guitar pick-ups are designed to work into a high-impedance input. One solution is to use an active DI box which matches the impedance of the guitar pick-up to that of the soundcard’s line input. Many of these are designed to be powered from either batteries or from a phantom power supply. Clearly, a battery-powered model will be needed to work with a soundcard.

In the case of lead guitar, most of the unwanted upper harmonics generated by overdrive pedals or similar effects are filtered out by the restricted frequency response of a typical guitar loudspeaker. For this reason, recording guitar pre-amps include a piece of circuitry that functions as a "speaker emulator" by mimicking the frequency response of a typical guitar speaker. Without such a device, any attempt to DI a distortion pedal would result in a thin, buzzy sound.

using microphones

The mic placements shown in textbooks can only ever be approximate — you’ll often need to try a little experimentation before you can obtain the best results. However, I have a few tips that will enable you to find a good mic position, regardless of the type of voice or instrument you’re recording. A good way of fine-tuning your mic’s position is to wear fully enclosed headphones so that you can hear the output from the mic as you move it. As the performer runs through the material, you can choose the best mic position by ear.

It’s very important to realise that few acoustic instruments produce all of their sound from just one point, which means that, if you place the mic too close to the instrument, you’ll capture only one element of the overall sound produced. When you’re working with instruments that have sound holes, such as acoustic guitars, try not to aim the mic directly at the hole itself — it may produce a large and apparently healthy sound, but the signal you pick up is likely to sound too boomy or boxy. Pull the mic back and move it to the side of the sound hole until the sound you hear in the headphones seems even and natural.

To work out an approximate mic distance for recording using a single microphone, first estimate the length of the part of the instrument that produces the sound and use this as your initial mic distance. For example, most of the sound from an acoustic guitar comes from the body, so the mic should be positioned somewhere around the same distance as the length of the body away from the instrument. Similarly, a piano mic should be around a piano’s width away. The same applies to wind instruments, and for these instruments make sure that you don’t put the mic too close to the "noisy" end; pull it back to let all parts of the instrument contribute to the sound.

As described earlier, use headphones to fine-tune the position and distance of the mic and remember that the amount of reverberation that the room contributes to the recording will be dictated largely by the distance of the microphone from the source. The closer you get to the source, the more direct sound you’ll pick up relative to the room ambience, whereas having a greater distance between mic and sound source will give more room ambience but the performance may lose intimacy. Unless the room produces a good live sound, you’ll invariably be better off miking fairly close to the instruments, thus excluding the room sound. For live recordings, try using tiled rooms, rooms with wooden floors and glass conservatories with hard floors and all of their soft furnishings removed.

recording vocals

For vocal recording, a mic distance of 100-200mm usually works well, but it’s important to use a pop shield between the mouth and the mic to avoid picking up popping noises on "P" and "B" sounds. A pop shield is simply a fine piece of gauze stretched over a frame, and many a session has been recorded using a nylon stocking stretched over a wire coat-hanger bent into the shape of a square or circle. Don’t underestimate the importance of a pop shield, as it’s almost impossible to make a good vocal recording without one. The foam wind shield that comes with some mics is generally ineffective against popping.

Also, set up your mic away from walls or corners, and if the room sounds too "live" then hang up blankets behind and to the sides of the singer. A suitable mic-and-pop-shield arrangement is shown in Figure 10.4.

Figure 10.4: Vocal miking

noise and spill

When recording quieter instruments, try to be aware of what else the mic is picking up in addition to the sounds you want. Listen for traffic noise, ticking clocks, water cisterns filling up and so on. Computer drives and fans are the biggest culprits, so work as far from your computer as you can. In some types of music, small background sounds tend to be masked by the other instruments, but exposed solo instruments or voices need to be recorded very carefully.

multiple mics

When multiple mics are being used to record separate instruments, it’s important to minimise the amount of sound getting into adjacent mics or you’ll have less control over the level and sound of individual instruments, and the overall sound may also become muddy. The general rule is to try to space your mics at least five times further apart than the distance between the mic and the instrument. If you need to mic up a drum kit using several mics, you’ll need a small mixer to combine the mic signals and mix them to stereo before you record them on your computer.

direct-to-stereo recording

If you’re working with limited equipment, the simplest way of making a recording of live musicians is to use just two microphones set up as a stereo pair. This is one of the most accurate ways of recording anything, and many of the best classical recordings are made in this way. However, the sounds must be balanced at source, because a stereo pair of mics captures everything exactly as it sounds in the room in which it’s recorded. Most early records were made in this way — many in mono, with no EQ! — and they still sound good today.

To use this technique, place your mics as close together as possible and then rotate them so that each points approximately 45º away from an imaginary centre line joining the mic position and the centre of the ensemble being recorded, as shown in Figure 10.5. Position the mics roughly the same distance away as the width of the ensemble and use your headphones to make sure that nobody is too loud or too quiet. The same stereo-miking technique can be used to record other stereo sources, such as a grand piano, a percussion ensemble or a group of backing vocalists.

Figure 10.5: Stereo miking (a coincident pair miking an ensemble)

drum miking

The real secret of miking drums is to get the drums sounding good before you start. General-purpose dynamic mics are fine for the snare drum and toms, but you should use capacitor or back-electret mics for overheads. For the kick drum, make sure that you choose a mic that is specifically designed for the purpose, as most vocal or instrument mics roll off the low bass, which you need to capture intact.

Snare and tom mics are usually positioned around 50mm from the head and 50-100mm in from the edge of the drum. The kick-drum mic goes inside the drum shell at around six inches from the point at which the beater hits the head. This requires a hole to be cut in the front head, while damping is achieved by placing a folded blanket in the bottom of the drum. Also, observe "the 5:1 rule" where possible when setting up the mics, so as to minimise spill between the drums. (The 5:1 rule states that the distance between the mics should be at least five times greater than the distance between the individual mics and the sound sources with which they’re working to minimise the effect of crosstalk, where one mic picks up multiple sources.) Cardioid mics may also be angled away from each other to further reduce spill.

A stereo pair of overhead mics should be positioned around a metre above the cymbals and should be spaced apart by one or two metres. A fully miked drum kit is shown in Figure 10.6, although you can still get good results by just using the kick, snare and overhead mics. Separate hi-hat mics are generally unnecessary, but if you do need to use one then choose a capacitor model and place it around 150mm from the edge of the hi-hats and either just above or just below the cymbals so that it isn’t hit by blasts of air when the cymbals close.

Figure 10.6: Drum miking

guitar amps

Guitar and bass amps can be miked from quite a short distance away with a dynamic mic pointing directly at the speaker cone. Position the mic around 5-300mm away from the speaker cloth and move it slightly to one side if you want a mellower sound. (As a rule, the mic distance should be greater for bass amplifiers.) Modern guitar recording pre-amps are now so good that there’s little to be gained from miking an amplifier, unless you happen to be able to get a particularly good sound that way.

BACK TO TOP
NEXT CHAPTER

CONTENTS PAGE
GLOSSARY OF TERMS

recording with microphones
dynamic mics
capacitor mics
back-electret mics
typical uses
cardioid mics
the proximity effect
presence
choosing the right microphone
direct injection
using microphones
recording vocals
noise and spill
multiple mics
direct-to-stereo recording
drum miking
guitar amps


chapter 11

getting creative

logistics

When recording audio in a computer-based studio, it’s often necessary to set up the mics quite a distance away from the computer to prevent the noise of its fans and drives from compromising the recording quality. At the same time, it’s useful to be close enough to the computer to reach the controls and to be able to read the display. Over a limited distance, using keyboard and mouse extension cables is a cheap and practical option, but note that CRT displays radiate a lot of magnetic interference that can affect magnetic guitar pick-ups, especially non-humbucking types. This is worse when some form of overdrive effect or compression is being used, as these bring up low-level signals during quiet passages, when the hum is most noticeable. Unfortunately, the only solutions are to work as far away from the monitor as possible, to invest in a solid-state display which won’t play havoc with your guitar or to fit low-noise guitar pick-ups.

preparation

Before you start recording, read through the Cubasis VST CE documentation. Although there’s no hard copy included, there is a PDF user guide installed with the program, and I recommend that you print this out and keep it handy for reference. This book isn’t a substitute for a software manual, but it does provide an overview of the music-making process and suggests a way in which you might like to work, at least until you get more familiar with your desktop studio. As you gain more experience, you’ll develop your own unique approach to composing and mixing, but until that time the method described here is as good as any.

getting started

Start off by laying down your main MIDI tracks before recording any audio. For both pop and dance-style music, using a repeating rhythm loop provides a good basis on which to build your piece. You’ll need something to play along to, most of the time, and a guide drum part is always easier to play to than a metronome click.

Once you’ve got the guide rhythm part running (probably by recording a bar or two and then copying it), add the bass and chord parts next, as this will establish a framework for the rest of the composition. (You can always change the arrangement for any of the parts later, if you wish.) Adjust the level balance between your MIDI parts so that what you hear is somewhere close to how you imagine things will sound in the final mix. In most cases, you’ll probably find that it helps to adjust the balance as you record new parts so that, by the time all the parts are recorded, the mix will be getting pretty close to the way it will finally sound.

Read up on the MIDI and audio mix-automation facilities of Cubasis, as these are very important. Usually, you’ll find that there are several ways of doing the same job, but most people find their preferred method and then use that most of the time. Try them all and then use the method that suits you best.

Keep in mind that an automated level or pan position will always stay at its last position unless told to change. For example, if you’ve created a fade-out at the end of a track but you haven’t automated the start of the track, when you play the track from the top next the track level will stay turned down. This is because, after the fade-out, nobody told the track to turn itself back up. For this reason, it’s good practice to automate the start of a track to bring it up to the desired level before the audio or MIDI data in the track actually starts playing.

Keeping track of automation controller data can be even more confusing if you’ve created a short sequence with a fade-out or some other set of automation moves and then copied this part so that it’s used several times, as the automation data will be copied along with MIDI and audio parts. Once again, however, if you’ve created a fade-out without automating the start of the sequence, the part in question will fade out as planned the first time it’s played back but will still be silent the next time it’s supposed to occur in the song. Once you understand this potential problem, it’s easy to avoid, but we’ve all fallen into the trap at one time or another.

Note that, if you’re not using automation, the track level and pan are set up via the track-level and pan parameters in Cubasis’ Inspector. However, if you subsequently decide to add automation data, the initial track parameters will change as soon as the first automation event occurs, and so, if you want to adjust the overall level of an automated track, it’s no use trying to do this by adjusting the Inspector track parameters, as the automation data will simply take over and impose its new values as the song progresses.

handling audio

When all of the main MIDI parts are in place, you can start recording audio. Take care to set healthy recording levels that peak close to the top of the meters without actually causing clipping. If you’re planning to make an audio CD, make sure that you record at a higher resolution than 44.1kHz and then convert the sample rate down to 44.1kHz before recording.

Again, keep your mic away from the computer to avoid picking up unnecessary fan and hard-drive noise. Don’t worry about adding effects and EQ at this stage; these can be added later.

Recording audio is mostly a simple matter of arming an audio track to Record, setting the recording levels and then playing, but if you decide to redo a part then it’s good practice to erase unwanted takes from disk, or your drive will be filled up with short files that waste space and can lead to confusion between what’s needed and what isn’t.

When you delete, cut, copy or move parts around during the editing process, the original audio file remains intact. The only way to get rid of audio permanently is to deliberately delete the file from disk. However, before you do this, make sure that you don’t need other parts of the file elsewhere in your song, or even in other songs. Giving your audio files meaningful names helps enormously. Don’t assume that you’ll remember everything because I can guarantee that you won’t when you come back to a session a few months later!

A useful production trick involves copying a short section of audio onto a new track to create echoes, as shown in Figure 11.1. By copying audio rather than using a plug-in effect, you can create a precise number of repeats of a single word, phrase or sound, and by using the graphical editor to set the level of the repeats you can have them decay in level each time they repeat by an exact amount. If you want the delays to overlap, you’ll need to use two or more separate audio tracks for the repeats, and this method has the advantage of allowing you to pan the two tracks of repeats to different positions to create a stereo echo.

Figure 11.1: Create echoes by copying to new tracks

adding VST effects

When applying VST effects, keep in mind the differences between the way in which effects and processors are connected, as explained in the chapter on "Effects And Processors", and take some time to experiment with the various plug-ins at your disposal. Try automating one or more effect parameters, if you haven’t already done so, as this can open up a number of creative opportunities. Virtually all recordings need reverb, and the most efficient way of using reverb is via a pre-fade aux send. Reverb can be quite power hungry, but there are VST plug-ins of various degrees of sophistication available so that those with less CPU power at their fingertips can use a simpler reverb algorithm that demands less memory. As a rule, the simpler reverb plug-ins don’t have the density of sound of the better ones, but they can still sound good, especially if you only need to add a little. Drum and percussion sounds tend to show up the limitations of a reverb plug-in more than vocals or other instruments do.

When using reverb, a good general rule is to avoid using it on very bassy sounds, such as bass guitar, bass synth and kick drum, as this can spoil the clarity of a mix. You can use short ambience settings on most sounds to create a sense of space without muddying the mix, but longer reverb times should be used sparingly. It’s always useful to listen to a few commercial records to see how reverb is used on these, and often you’ll be surprised at how unobtrusive it is. One of the most common mistakes made by newcomers to recording is adding too much reverb.

Another indispensable plug-in is the compressor, and as this is an effect it must be used via the mixer insert points. Compression is invariably needed to even up the levels of vocals, and you may wish to add more as you mix, even if the vocals were recorded via a voice channel with a built-in compressor. Note that excessive compression produces a noticeably compressed sound, which can be used creatively to make parts sound larger than life or more powerful. However, also be aware that the more gain reduction you apply using a compressor, the more any background noise present in the signal will be increased.

the science of mixing

Mixing is the process by which all of your audio tracks are combined to produce a stereo recording. You can record the mix to an external DAT or MiniDisc recorder, via either the analogue or digital soundcard outputs, but it’s also possible to mix your song back to the computer so that you produce a stereo soundfile.

This approach is both convenient and cost effective, and in any event the mixed audio will need to end up on your computer, if you want to edit it further using WaveLab Lite or burn an audio CD. It’s least confusing if you save each mixed song as a separate stereo soundfile — and when doing this, remember to name it appropriately.

always back up

As a precaution, I usually save a copy of my song files and all of their associated audio files into individual song folders located on a separate hard drive to the one on which I’ve been recording. This provides a little security, as it’s unlikely that two hard drives will go down at the same time. When I’ve completed several songs, I copy their folders to a CD-R, which provides me with a portable, archivable back-up that’s easy to reload if I ever need to do further work on the songs. If the work is really important, I’ll make at least two CD-R back-ups.

before mixing

A good mix starts with a good recording, so if a sung or played part is sonically or artistically wrong then it’s best just to do it again. Keeping track of your work as it progresses is also important, as is setting up both your virtual and hardware equipment properly.

A professional studio engineer always keeps a track sheet nearby showing him what instrument is recorded on what track, along with notes about the performance and mixing process. To some extent, a desktop system does away with the need for paper, as long as you name your tracks after recording them, but sometimes it’s useful to keep additional notes. A good way of doing this is to use your computer’s Notepad facility.

If you have a separate mixer and it allows you the option, make sure that any unused channels aren’t routed either to the groups or to the left/right buss, as these will contribute unnecessary noise to the mix, even if the faders are turned down. Also, take advantage of any subgrouping facilities that your mixer might have to place logical groups of sounds (such as percussion sections) under the control of a single fader or pair of faders where possible.

Another useful thing to do before mixing is to solo any audio tracks and play them back one at a time, checking for unwanted noises or sections of unerased audio that you don’t need. Also, listen carefully to make sure that there are no tuning or timing problems. You can open the track in WaveLab Lite and silence any unwanted material, which will make mixing a great deal easier. You can also silence (or reduce in level) any annoying guitar squeaks or noisy breaths. In theory, you could do all of this via mix-level automation, but it’s often simpler and more precise to trim things in the waveform editor, as you can see (and audition) exactly what you’re erasing or reducing in level.

Unless you’ve been setting up mix automation and effects as you go along (which most people do, once they’ve gained a little experience), set the pan controls to their central positions, bypass any EQ and effects plug-ins and then just listen to what you’ve got. You may want to do this even if you’ve been making adjustments as you go along, if you feel that the mix isn’t working out and you need to start again.

setting a balance

There are two main approaches that you can adopt when setting a balance: you can either start with the rhythm section and then build up the track a part at a time, which is a good method for those with limited experience, or you can just push up all the faders and then start to balance everything relative to everything else. Professional engineers working with tape tend to use the latter approach, although in a software environment it may be easier to work on a few tracks at a time. However, once all of the tracks have been turned up, you’ll still need to listen to the mix as a whole, as some judgements about the balance of the material that you made earlier may need revising once everything is playing simultaneously. Normally, I’d advocate adding effects later in the mixing process, but in the case of compression you may as well set it up right from the start, as compression will change the level of a part and also affect the way it integrates with the rest of the mix.

It’s generally easiest to balance drums and bass first, as these form the foundation for the whole track, particularly in dance music. Once the rhythm section is sounding good, you can think about adding the other instruments and the main vocal part. For most musical styles, it’s important to leave space for the vocal, and compression helps to prevent quieter words or phrases from getting lost in the backing. If noise on the vocal track is a problem, a gate plug-in used just before the compressor can help, especially if you didn’t manage to edit out all of the unwanted material before mixing.

It should be possible to set up an approximate balance fairly quickly, without resorting to EQ or panning — you can work on these later. If your recording is a mix of audio and MIDI parts, you may discover that some of the MIDI sounds don’t work as well as you first thought, in which case now is the time either to choose different patches or to edit those that you’re using.

When you’ve achieved a reasonable balance, you can start to think about panning the sounds and adding EQ and effects. However, don’t spend too much time on trying to EQ individual tracks in isolation, because they’ll almost certainly sound quite different when all of the other tracks are playing. Try to arrive at a ballpark EQ fairly quickly and leave the fine-tuning until the whole mix is playing. Also, try not to use EQ just because it’s there; voices and instruments invariably sound at their most natural with as little EQ as possible.

vocal compression

A useful compressor setting for vocals combines a fairly fast attack with a release time of 0.25 to 0.5 seconds and a ratio of between 2:1 and 5:1. If you adjust the threshold control so that you’re getting between 5dB and 10dB of gain reduction, you should find that the vocal level is evened out considerably, although you can use a higher ratio if you want a more obviously compressed sound, which is a technique often used in rock music to create a sense of energy. You can also use mix automation to fine-tune levels if some words or phrases still sound too loud or too quiet.

panning

The way in which a traditional pop mix is set up generally approximates the way in which you might hear the musicians onstage, with the drums, bass and singer close to the centre and other instruments and backing vocals spread around the stereo soundstage. Bass drums, bass guitars, bass synth lines or any other predominantly low-frequency sounds should be panned to the centre, because these sounds carry most of the energy in a mix. By keeping them in the centre, both speakers in a stereo system will share the load, enabling the music to be played louder. Vocals are normally positioned in the centre, for artistic reasons.

Other instruments, backing vocals and effects can be panned left and right to create an illusion of space. Reverb returns are almost always in stereo to provide the maximum sense of space and depth, and most reverb plug-ins will accept a mono signal and generate a stereo output. No matter where the original signal is panned, any additional reverb will come equally from both sides, just as it does in real rooms. Although reverb increases the sense of space, the fact that it does come from both sides means that it can mask the location of the original sound. Normally, this doesn’t matter, but it’s sometimes useful to use reverb in mono, via a track insert, if a sound needs to be precisely positioned in the mix.

It can be tempting to spread things out too much in the stereo mix, but this can sound unrealistic, in the case of some "real" instruments. For example, if you spread stereo pianos and drum kits over too great a width, they sound as if they’ve been stretched right across the stereo soundstage. A narrower left/right spread will sound more natural, and the use of stereo reverb will provide an adequate illusion of spaciousness.

By using the automation functions of your sequencer, both MIDI and audio can be panned from side to side as fast and as often as you want. As you might imagine, this can be artistically useful in small doses, but it can also lead to a dizzying effect if used in excess. Pans that are in sync with the tempo of the song work better than those that aren’t, and sometimes panning just your effects can be interesting without being overpowering.

creating depth in your mix

In conventional stereo, everything comes from just two speakers, and although surround-sound is an emerging format, most people will be listening to stereo for a long time to come. Nevertheless, there are mixing tricks that can be used to make stereo music sound more three dimensional.

The early reflections produced when a sound occurs in an enclosed space have a profound influence on how near or far the sound appears to be from the listener, which is one reason why reverb is such an important effect. Small rooms produce closely spaced reflection patterns, and this seems to create a sense of closeness or intimacy, while in large halls the reflections start off more widely spaced. After picking a reverb program that conveys the right sense of distance, you can treat sounds that you wish to appear at the back of your mix.

Conversely, to make a sound appear closer to the listener, it usually needs a "smaller" type of reverb, with more of the dry component present, and it can also help to push the sound forward, if EQ is used, to make it slightly brighter by boosting frequencies between 10kHz and 15kHz. Using compression to stabilise the level will allow you to place your sound right at the front of the mix without it seeming too loud.

You may find that, by the time you’ve added all of your tracks to a mix, it sounds rather overcrowded and has lost some of its sparkle. The cause of this is often a combination of inappropriate sounds and a messy musical arrangement. Where the arrangement is at fault, you may be able to mute or replace some parts, and of course all MIDI sounds can be changed right up to the mixing stage. You can also improve matters by careful use of EQ, although there are a few guidelines governing its use.

EQ as a tool

EQ can only boost frequencies that are already there in the original sound, which means that there’s no point in trying to add bass to a sound that contains no low frequencies in the first place. Similarly, a very dull sound may have nothing at the top end to boost other than noise. You’ll need to experiment to find the exact frequencies and amounts of cut and boost that work for each type of sound, but as a rule there will be little low-frequency sound below the fundamental frequency of the lowest note that an instrument can produce.

It’s also possible to use shelving EQ cut at the high and low ends of a sound’s natural range to squeeze it into a narrower range. You might want to do this when a mix is starting to sound congested, as it will give each sound more of its own space in which to exist. It’s particularly important to make sure that nothing conflicts too strongly with the mid-range element of the lead vocals.

If you can solve a problem by using EQ cut rather than boost, your results will probably sound more natural. However, less natural sounds such as bass guitars, electric guitars and close-miked acoustic drums often benefit from quite aggressive equalisation. Even so, don’t spend too much time perfecting a bass-guitar sound in isolation, because it will always sound different when you add the rest of the tracks. It’s more useful to set up an approximate EQ and then make any necessary fine adjustments when the whole mix is playing.

bass guitars

DI’ing a bass will produce a clean and detailed sound but one that may get lost when it has to compete with the rest of the mix. A dedicated bass-guitar recording pre-amp is likely to work better, but it’s possible to get a good sound by using a DI box if you also apply some compression and suitable EQ.

The definition in a bass-guitar sound comes largely from the mid range. You may need to apply quite a lot of boost somewhere between 2kHz and 4kHz to get enough definition to the sound, but it’s sometimes necessary to combine this with some shelving cut higher up to reduce excessive string and finger noise.

To add more bass, you can add boost at between 70Hz and 120Hz, but also try cutting and boosting in the 150Hz-1kHz range, as a lot of the bass guitar’s audible character is due to frequencies in that range.

electric guitars

As with the bass, with electric guitars you must first start with an adequate instrument and a good player. Traditionally, a guitar amp would be miked close to the speaker cloth using a dynamic mic, but as there are now so many good recording guitar pre-amps on the market it’s possible to get just about any guitar sound with all the convenience of a DI box. There are also VST plug-ins available that are designed for processing guitar, although the pre-amp approach has the benefit of there being no latency to deal with, as you still get the proper guitar tone if you decide to monitor the source signal.

For guitar reverb, try using a spring reverb simulation or a short, ambient room setting rather than a long wash, and try using different pre-delay times. Direct your EQ towards the 150Hz-3kHz part of the spectrum. Cut at a higher frequency can be used to smooth out a buzzy overdrive sound, while clean DI’d guitar can be EQ’d effectively up to 6-7kHz, as it contains a lot of harmonics.

vocals

A good singer with a good mic shouldn’t need much in the way of EQ, although, if you want a very processed sound for artistic reasons, you can do whatever you think the track needs.

Unless the EQ changes you need to make involve only a little general brightening or warming, you should use a parametric EQ, rather than a shelving equaliser, as a parametric model offers more precise control. Presence can be fine-tuned by cutting or boosting in the 3-7kHz range, while chest and throat resonances tend to lie in the 150-400Hz range. Compression can be applied either before or after EQ, but you get more control if you compress first and EQ afterwards.

Close-miked vocals always need reverb, but you don’t always need as much as you think, and the philosophy of "less is more" is a good one to apply. Bright reverb sounds are popular on some pop vocals but tend to emphasise sibilance, so always listen carefully to your vocal sound both with and without effects.

step-by-step mixing

• Document everything and back up your data every few minutes.

• Check individual audio tracks for noise or unwanted pieces of audio and erase the unwanted parts.

• Set up a rough mix and see how it sounds. Start with the rhythm section and build up a track at a time, making your final adjustments when all of the tracks are playing.

• If the mix seems too busy, first see if you can change the arrangement to make some more space. You may also be able to use different MIDI instrument sounds or use EQ to thin out some of the existing audio tracks.

• Keep the main vocal and bass sounds panned near the middle of the mix.

• Don’t overuse effects, as they can make things sound less immediate. Use less reverb in conjunction with added brightness on up-front sounds to make them sound closer.

• Use your mix automation to do all of the hard work — bringing up instrument levels in solos, levelling out vocals and so on. You’ll probably only need to automate a few of the tracks. Avoid changing the levels of the drums or bass too much, as these provide the foundation on which the rest of the music rests.

• Enhancers can be useful for adding definition and clarity to individual tracks or even to whole mixes. Use them sparingly, however, and be aware that adding enhancement seems to pull a sound forward in the mix.

• Finally, when you think you’ve got it right, take a break, have a cup of coffee, listen to a few records and then listen to the mix again. If it still sounds good, listen again from the next room with the adjoining door left open, because anything that’s too loud or too quiet in the mix will become instantly obvious to you this way. This is one of the most useful and effective tips I’ve ever heard, so be sure to try it.

At this stage, make a cassette or CD-R copy so that you can also check your mix on other sound systems.

mastering

The mastering stage is when the final gloss is applied to the music and the tracks are organised to form a cohesive album. Mastering is largely about making the different tracks on an album sound consistent and getting the correct relative levels. There’s a lot more to mastering than compressing everything to make it sound as loud as possible, but you can get excellent results in a home studio, provided that you have a reasonably accurate monitoring system and that you take care over what you’re doing. At a minimum, the only extra equipment you’ll need is a suitable CD-R machine. It’s possible to do just about any processing function that you might require with software, and WaveLab Lite has both compression and EQ facilities built in.

There are several quite simple mastering tricks that you can employ to make your tracks sound better than they did when you mixed them, but the most important tool is the ear of the person doing the job. Listen critically to as much other music as you can and try to figure out the techniques that were used when it was mastered.

After your own ears, the most important requirement is an accurate monitoring environment, which means that you should use hi-fi or studio monitor speakers with a reasonable bass response. Computer-style multimedia speakers aren’t really suitable for any serious musical work, especially not mastering.

mastering EQ

Tracks that were recorded at different times can sound very different, so you may need to use a little overall EQ to even things out. Listen first to the bass end of each song to see how that differs and use the EQ to try to get a similar character in each track. The approach to adopt is to apply cut in the areas where sounds are too strong and boost where they’re too weak. However, be sure to apply only gentle boosting and use cut rather than boost when a more radical change is needed.

If you need to add brightness, use a harmonic enhancer plug-in or a parametric EQ set to around 15kHz with a low Q setting (ie a wide bandwidth). Applying just a couple of decibels of boost at this frequency should make the track seem clearer and more transparent. As a precaution against overprocessing your mix, keep a CD player patched into your system and make frequent comparisons between your results and a selection of commercial recordings in a similar style.

Note that, if an audio file needs to be normalised (ie brought up in level so that the highest peak is at digital full scale), this should be done after all other processing has been completed, or the processing may cause level shifts that may result in clipping. Even EQ cut can result in increased levels at some frequencies, because you may cut a frequency that was originally cancelling out another frequency at various points throughout the song.

mastering dynamics

Dynamics is just another term for any signal processing that changes the level of a signal according to the loudness of the audio. Dynamic processors include compressors, limiters, gates and expanders. You should use a limiter to make a track sound louder when it’s already peaking close to digital full scale. With a well-designed limiter, you can increase the overall level by at least 6dB without producing any noticeable side-effects, although a dedicated mastering limiter will produce the most natural results. What actually happens is that the top few decibels of short peaks — such as drum beats — are reduced in level, but because these are usually so short anyway the processing is inaudible. A compressor set to its fastest attack time and a release time of around 100ms can also be used as a limiter.

overall compression

Using compression on a complete stereo mix can also add energy and help to even out a track. Often, a compressor will change the apparent balance of a mix slightly, so you may need to use it in combination with EQ, ideally with the EQ coming after the compressor.

Split-band compressors and limiters are usually better for mastering than conventional full-band types, as on these there’s less interaction between the different parts of the audio spectrum. For example, when using a split-band compressor, a loud bass sound that results in heavy compression will only affect the bottom half of the audio spectrum, so bright sounds like hi-hats won’t be affected. Although WaveLab Lite doesn’t support VST plug-ins, you can either upgrade to the full version, which does, or you can open your stereo files in Cubasis VST CE and apply the necessary VST plug-ins there, saving the processed tracks as new files.

As a rule, low compressor thresholds in combination with ratios below 1.4:1 work best for mastering, as you can increase the overall energy of a track and make all of the component parts seem better integrated without making the end result sound obviously processed. Multiband compressors are better at this, but a single-band compressor used with care can still produce excellent results. You should adjust the threshold control after setting the ratio so that the maximum gain reduction in signal peaks is between 3dB and 6dB. If you can hear the compressor working, as opposed to the track just sounding better, try reducing the ratio or increasing the threshold slightly.

editing tasks

One of the first things that you need to do when mastering a track is to silence unwanted noise at the beginning and end of the song. You may also want to fade out the last few moments of a song so that the final decaying sound ends in perfect silence. Don’t start the track until the natural fade of the sound is well under way, though, or the track might appear to end too abruptly.

Matching the relative levels of tracks on an album doesn’t simply mean making every song the same level. If you do this, the quieter songs will actually seem too loud when compared with the stronger songs. Listening to the vocal levels often provides a good idea of how well matched songs are, but a lot is purely down to feel.

advanced editing

When editing tracks together from various takes or sections, try to position any butt joins just before or just after a drum beat, which will mean that any small discontinuities are likely to be masked by the beat. Also, any crossfades should be made as short as necessary in order to provide a smooth edit. Once you’ve edited a track, listen to it carefully to ensure that none of the edits are audible. Listen for level and tonal changes as well as more obvious timing irregularities and then resave your edited song as a new soundfile, as this will make CD burning easier.

After tidying up the starts and ends of your tracks, you can assemble them in the desired order for your album by using the Playlist function of the included Creative Playcenter 3 software. Simply import your individual songs as separate WAV files, after editing them with WaveLab Lite. In Creative Playcenter 3, the gaps between tracks are fixed at two seconds, and so, if you need a longer gap, you’ll need to add extra silence to the end of the preceding track when editing in WaveLab Lite. For more sophisticated mastering, you may consider buying more sophisticated software that lets you adjust the gaps between tracks, relative track levels and so on, although with care you can achieve very professional-sounding results just by using Creative Playcenter 3, as shown in Figure 11.2.

Figure 11.2: Creative Playcenter 3 Playlist function

Before burning your CD, listen to the finished master all the way through as it plays back from the playlist. Use headphones to do this, as this will make it easier to spot problems. Even when you’ve burned your CD, don’t make further copies until you’ve played the master on a few different systems to make sure that both your mixes and the CD itself are OK.

If the CD is to be used as a master for commercial duplication, it will need to be a Red Book-compatible, PQ-encoded master disc containing all of the necessary track-start and pause codes, as well as a table of contents in the form demanded for the mass-production of consumer audio CDs. In this case, it may be best to upgrade to the full version of WaveLab, which has a Playlist function and supports CD burning.

A Red Book disk must always be written in Disk At Once mode, rather than Track At Once mode, in order to avoid errors being created between tracks. Always use good-quality, branded blank CD-Rs for important work. Cheap discs might save you a few pence, but they may not be reliable. Many incur high error rates, and they may have poor long-term storage characteristics. Always hold the blank CD-R by its edges, as dirt or fingerprints can also cause errors. Also, check that the writing surface is spotlessly clean before attempting to write to it.

Internet audio

In addition to making a CD master, you may also wish to prepare extracts from your work in a form that can be played over the Internet. For example, you may wish to create a website to publicise your material, where visitors will be able to hear short sections of your music. The most common audio format for Internet use is MP3, an audio data compression system that shrinks audio files to less than a tenth of the size of the original yet retaining near CD quality. MP3 files can be downloaded from the Internet, just like any other files, and either played back on the computer or via a hardware MP3 player

To encode WAV files into MP3 format, you’ll need software that can handle MP3 encoding, and Creative Playcenter 3 is able to do this for you. MP3 playback is often supported via plug-ins to browser software such as Microsoft’s Internet Explorer or Netscape Navigator, and this format is the de facto standard for high-quality Internet audio delivery.

Acid and Fruity Loops are additional software only included with the Sound Blaster Audigy Platinum eX. Acid is a brilliant tool for writing loop-based songs. It can be used as an alternative to an audio sequencer and is able to combine loops originally created at different tempi. One of its most useful features is the ability to import a loop, change its tempo without altering the pitch and rexport it for use elsewhere. It also supports .rm and .wma files. Fruity Loops is a an innovative pattern based sequencer that can make use of samples or built in softsynth modules as sound sources and also offers output to and control of the Sound Blaster Audigy's internal synths. As well as its own built in effects it supports VST instruments and VST or DirectX effects.

BACK TO TOP

CONTENTS PAGE
GLOSSARY OF TERMS

getting creative
logistics
preparation
getting started
handling audio
adding VST effects
the science of mixing
always back up
before mixing
setting a balance
vocal compression
panning
creating depth in your mix
EQ as a tool
bass guitars
electric guitars
vocals
step-by-step mixing
mastering
mastering EQ
mastering dynamics
overall compression
editing tasks
advanced editing
Internet audio


glossary of terms

AC

Alternating Current.

active

Describes a circuit containing components that can amplify, as opposed to passive circuits that work purely by resistive, capacitive, inductive or diodic action.

ADT

Automatic Double Tracking, a term used to describe the use of a short echo to simulate the effect of the same sound being recorded twice and then replayed simultaneously. (See "Double Tracking".)

A-to-D converter

Device used to convert analogue signals into a digital data stream by sampling and measuring the input-signal voltage at regular intervals.

AES/EBU

Professional digital interfacing standard that uses a balanced, 100-ohm XLR connection.

ambience

The perceived effect of the environment on a sound due to acoustic reflections and absorption from surfaces.

amp

Abbreviation of ampère, the standard unit of electrical current.

amplify

To increase the amplitude (magnitude) of an electrical signal.

amplitude

Level or magnitude of an electrical signal, expressed in volts.

analogue

Term used to describe a signal that takes the form of a continuously varying voltage.

anechoic

Term used to describe an acoustic environment designed to absorb all sound.

attenuate

To reduce the level of an electrical signal.

audio

The area of technology related to sound recording, processing, amplification and reproduction.

aux send

Mixer-buss output designed specifically to drive external effects or foldback systems. (See "Pre-Fade" and "Post-Fade".)

axis

Imaginary line depicting the primary direction of transmission or reception of an audio transducer.

back-up

Safety copy of tape, software or other digital media.

balance

Ratio of the left and right channels in a stereo system.

balancing

Cabling system that uses two out-of-phase conductors within a common screen. When balanced equipment is connected onto both ends of the cable, any interference affecting the cable is cancelled out, resulting in a cleaner signal.

band

Specific range of frequencies with an upper and lower limit. In audio, this usually means a section of the audio spectrum.

bandwidth

Range of frequencies passed by an electronic circuit.

binary

Numbering system comprising ones and zeros used in all areas of digital electronics.

bit

Term describing the smallest piece of binary information, which may be either a one or a zero.

boost/cut control

Equaliser control that allows a specific range of frequencies to be either increased or decreased in level. In the centre position, the control has no effect.

bouncing

Process of mixing two or more tracks from a multitrack recorder and simultaneously recording the result back to another track(s).

(analogue) buffer

Analogue circuit (usually with a very low output impedance) designed to isolate the source circuit from the circuit it is feeding. For example, a buffer circuit on the output of one device may be used to prevent the next piece of equipment in line from loading the output of the first device.

(digital) buffer

Area of RAM used for the temporary storage of information.

buss

Electrical signal path (or its virtual equivalent) onto which other signals may be mixed. In a mixer or multitracker, different busses are provided to carry the stereo mix, with the signals being sent to the multitrack recorder, the aux sends and so on.

byte

Piece of digital data comprising eight bits.

capacitor

Electronic component comprising two spaced conductors coupled electrostatically. The space between the conductors may be air or some other non-conducting di-electric.

capacitor microphone

Professional recording microphone that works by exploiting small changes in electrical capacitance. Capacitor microphones require phantom power to operate, usually at 48V.

cardioid microphone

Type of microphone that picks up sound mainly from one direction. These mics are also said to be unidirectional.

channel

A mixer or multitracker signal-input path and its associated controls. MIDI systems also operate on one of 16 channels. (See the chapter on "Introducing MIDI".)

chase

Process whereby the slave device in a master/slave synchronisation system attempts to achieve sync with the master.

chorus

Effect that uses delay and pitch modulation to create the effect of two or more musicians playing the same part.

clipping

Type of distortion where the top of a waveform is truncated when a circuit or algorithm is forced to handle a signal level higher than that which it was designed to accommodate.

clock

Electronic circuit designed to generate precisely spaced pulses for timing applications, such as analogue-to-digital conversion or to drive a digital processor.

clone

Exact copy. In digital recording, the verb relates to the digital transfer of a tape or disk, where the copied data is identical to that of the original

compressor

Processor for reducing the dynamic range of an audio signal.

conductor

Material that presents little resistance to the flow of an electrical current.

continuous controller (MIDI)

Control that provides the semblance of smoothly variable control (although actually this takes place over 128 steps) rather than being simply on or off.

cut and paste

Editing term that originated with word processing to describe the process of copying or moving data from one place to another.

cut-off frequency

Frequency at which the gain of an amplifier or filter falls by 3dB.

daisy chain

To connect two or more devices in series, where the output of one device feeds the input of the next device along, and so on.

damping

Control exercised by the output stage of a loudspeaker amplifier’s attempt to overshoot. Damping factor is calculated as the load (speaker) impedance divided by the output impedance of the amplifier.

DAT

Digital Audio Tape, used with DAT recorders.

data

Information stored in a digital (usually binary) form.

dB

Short for decibel. Used to express the relative levels of two electrical voltages, powers or sounds.

dBm

Reference level where 0dBm = 1mW into 600 ohms.

dB per octave

Measure of the slope of a filter circuit.

dBu

Same as dBv.

dBv

Reference level where 0dBv = 0.775V.

dBV

Reference level where 0dBV = 1V.

DC

Direct Current.

decay

Time it takes for a sound to fade to silence. Also used to describe the closing of an envelope-generating circuit.

depth

Amount by which one parameter is modulated by another — for example, vibrato or chorus depth.

desk

Alternative word for a mixer or console.

di-electric

Insulating layer between the two conductors of a capacitor.

digital audio

Electronic device that works by representing and processing information as a series of binary numbers.

digital delay

Digital processor for generating delay or echo effects.

digital reverb

Digital processor for recreating reverberation.

DIN connector

Type of multipin connector with several possible pin configurations. MIDI uses a five-pin, 180º DIN plug and socket.

disc

Media in the form of a disc, such as CD or MiniDisc. Excludes media that contain computer-readable data, which is spelled with a k.

disk drive

Mechanism for reading and writing computer floppy or hard disks. Fixed hard drives contain a disk that cannot be removed.

display

Computer monitor or some form of alpha-numeric readout built from LCDs or LEDs.

distortion

Any measurable difference (other than in amplitude) between an input signal and an output signal.

dithering

Process of adding a low-level noise to digital signals so as to produce smoother low-signal performance at the expense of slightly increased background noise.

double tracking

Process of recording the same performance twice onto two different tape tracks. When the two parts are played back, the effect of two people playing or singing together is created. Double tracking is often employed to thicken up the sound of a weak vocalist.

driver

Term used to describe the mechanical part of a loudspeaker. Also used to describe a piece of software that enables a hardware peripheral or internal card to interface with a computer.

dry signal

Sound source that has no added effect. Conversely, a sound treated with an effect such as reverberation or echo is often referred to as being wet.

D-to-A converter

Circuit used to convert a digitised signal back into an analogue signal. Also known as a DAC.

dynamic microphone

Microphone that uses a moving coil in a magnetic field to generate an output signal.

dynamic range

Range between the highest and lowest levels of a signal, usually expressed in decibels.

echo

Effect created by repeating the original signal — often several times — after a short time delay.

edit

To change recorded data or computer-stored digital data in some way.

effect

Device designed to add special effects to a sound. Examples include delay, reverb, pitch shifting, chorus, flanging, ADT, phasing and vibrato.

effects send

Mixer output designed to feed an external effects unit.

effects return

Additional mixer input used to feed an effects unit back into the mix.

electret microphone

Type of microphone based on a permanently charged capacitor capsule.

envelope

Overall amplitude contour of an electrical waveform.

equaliser

Device used to selectively increase or decrease the level of specific parts of the audio spectrum in relation to others.

erase

To remove data from a recording system and replace it with silence. Recordings may also be erased by recording new material in place of the original material.

expander

Audio processor designed to increase the dynamic range of a signal. Conceptually like a compressor in reverse.

expander module

Usually describes a MIDI sound module, although the term may also be used to describe an add-on that provides a mixer with more channels.

fader

Slider control, as opposed to rotary control.

ferric

Term used to describe a type of recording-tape composition. Ferric tapes are usually the cheapest, but these don’t produce as high-quality results as CrO2 or Type II tapes.

filter

Circuit that amplifies or attenuates a specific band of frequencies.

flanging

Delay effect using modulation and feedback to produce a sweeping sound.

foldback

Also known as cue. System for providing performers with a separate mix, which they can listen to while recording or overdubbing.

format

Process done to a computer disk before it can be used to store data. Formatting effectively creates "compartments" into which data can be stored.

frequency

Number of cycles of a repetitive waveform that occur each second.

frequency response

Measurement of the frequency range that can be accurately handled by a piece of electrical equipment, microphone or loudspeaker.

FSK

Frequency Shift Keying. System for representing MIDI clock pulses as bursts of audio tones that can be recorded onto tape.

FX

Abbreviation of effects.

gain

Amount by which a signal is amplified.

gate

Device for shutting off a signal when it falls below a specific threshold.

glitch

Unwanted pop or click that is recorded onto tape, often due to electrical interference from an outside source.

graphic equaliser

Equaliser that has several faders, each of which provides cut or boost over a narrow range of frequencies.

ground

Electrical connection to earth.

ground loop

Wiring problem that causes unwanted hum to be added to an audio signal.

hard-disk recording

Process of recording digitised audio onto a hard disk rather than onto tape.

harmonic

High-frequency component of a waveform that occurs at a multiple of the fundamental frequency.

harmonic distortion

Addition of harmonics not originally present in a signal.

HF

High Frequency.

high-pass filter

Filter that passes signals above a specified frequency and attenuates those that fall below that frequency.

inductor

Electrical component (usually some form of coil) that exhibits inductance. Inductors have a higher impedance at high frequencies than they have at low frequencies.

insulator

Material with very high resistance that effectively prevents an electrical current from flowing.

impedance

Simply put, the "AC resistance" of a circuit.

insert point

Connection socket (or virtual-mixer access point) that allows an external processor (or VST effect) to be "inserted" in series with a signal.

interface

Device that converts one form of data or signal into another. For example, a MIDI interface allows MIDI information to be generated and read by a computer.

I/O

Input/Output.

jack plug

Common semi-pro recording and instrument audio connector. May be either mono or stereo.

jack socket

Receptacle for a jack plug.

keyboard

Musical interface based on the piano keyboard but electrical in operation. Also applies to a computer keyboard.

kHz

Multiples of 1,000Hz (ie 1,000 cycles of a waveform per second).

latency

Delay between a signal being fed into a soundcard recording system and that same signal being fed to the audio outs of the soundcard. High latency values are audible as echoes, which upset the timing of the performer. Latency is usually caused by either slow computers or by poorly written software drivers.

LCD

Liquid Crystal Display.

LED

Light-Emitting Diode, a type of solid-state lamp.

LFO

Low-Frequency Oscillator, which is used as a control source rather than a sound source.

limiter

Device which prevents an audio signal from exceeding a set level while allowing signals below this level to remain unaffected.

logic

Type of circuitry used to process digital signals.

loop

Circuit where the output has a path back to the input.

low-pass filter

Circuit that passes signals below a set frequency and attenuates those above it.

mA

Abbreviation of milliamp (ie a thousandth of an amp).

mega

Abbreviation of 1,000,000. Examples include MHz (megaHertz), MB (megabyte) and so on.

memory

Circuit used to store digital data.

microprocessor

Chip at the hearts of desktop computers and many other digital devices.

modulate

To change some aspect of a signal (or digital representation of a signal) by means of another signal or waveform.

monitor

In recording terms, to monitor means to listen over loudspeakers or headphones. The noun can refer to a computer VDU or to a loudspeaker designed for accurate listening.

mono

Single channel of audio information for reproduction over a single speaker. If multiple speakers are used in mono, they all carry exactly the same signal.

multitimbral

Term used to describe a synthesiser or module that is capable of playing back two or more sounds simultaneously, each controlled by a separate MIDI channel. The majority of modern multitimbral instruments can produce either eight or 16 simultaneous parts.

multitrack

Process of recording a piece of music using a multitrack recording device so that different parts may be recorded at different times.

multitracker

Hardware multitrack recorder combined with a mixer.

noise gate

See "Gate".

normalise

To wire a socket so that the original signal path is unaffected, unless a plug is inserted into the socket. Mixer insert points are normalised, as are some types of patchbay connection.

octave

Range of frequencies where the upper frequency is twice the lower frequency.

offline

Term used to describe a process carried out in non-real time.

ohm

Unit of electrical resistance.

Ohm’s law

Formula relating resistance, voltage and current in a resistive circuit, as follows: I=V/R, where I is the current in amps, V is the voltage and R is the resistance in ohms.

open circuit

Circuit with a break in it that prevents current flow.

operating system

Basic "housekeeping" software used by a computer to allow it to run other software, communicate with peripherals and run a display.

oscillator

Electronic circuit that produces a repeating waveform.

overdub

To record onto a new track of a multitrack recorder while monitoring what has already been recorded on the other tracks. Alternatively, the newly recorded material obtained by such an action.

overload

To exceed the limits for which a circuit has been designed.

pad

Resistive circuit designed to reduce the level of a signal.

pan control

Control for moving a signal between left and right stereo extremes.

parallel

Term used to describe an arrangement in which two or more electrical components or systems are connected so that all of their inputs are connected together and all their outputs are connected together.

parametric EQ

Band-pass equaliser providing independent control over cut/boost, frequency and bandwidth.

passive

Electrical circuit that contains no active (amplifying) components. For example, a resistive pad is a passive circuit.

phantom power

System for supplying 48V power to balanced capacitor and electret microphones via a standard microphone cable. The phantom power source may be a stand-alone unit but is more often built into the mixing console or the mic pre-amp being used.

phase

Timing difference between two electrical waveforms, expressed in degrees. 360º represents a delay of one complete cycle.

phaser

Device which mixes a signal with a phase-shifted version of itself to produce a filtering effect.

phase shift

Change in phase of a signal relative to its original form via time delay or other electrical/electronic processing.

phasing

Studio effect created by adding a phase-shifted signal to a non-phase shifted signal and then changing the amount of phase shift.

phono plug

Type of signal connector used on hi-fi and semi-pro recording equipment.

pitch

Frequency of a musical note.

power supply

Device that converts mains electricity to the voltages required to power a piece of electronic equipment.

post-fade

Aux signal derived after a mixer’s channel fader, so that the aux send level reflects any channel-fader adjustments. Post-fade sends are generally used for feeding effects devices and may be referred to as effects sends.

pre-fade

Aux signal derived from before the channel fader, so that the aux send level is independent of the channel-fader position. Pre-fade sends are often used for creating foldback or cue mixes and may be referred to as foldback controls.

program change

MIDI command for changing synthesiser or effects programs.

punching in

Also known as dropping in. Describes the action of putting a tape track into Record while the tape is in motion so as to replace a specific section of a recording.

punching out

Action terminating a punch-in by switching the tape machine out of Record.

Q

Measure of the resonance of a filter circuit, defined as the centre frequency divided by the bandwidth.

quantise

To divide information into equally spaced time divisions. For example, quantising MIDI data will place each note to the nearest 1/16 of a bar, or whatever quantisation resolution is selected.

RAM

Random Access Memory.

R-DAT

Rotary-head Digital Audio Tape.

real time

Term used to describe a process that takes place with no perceptible delay.

resistance

Opposition to the flow of electrical current, measured in ohms.

resonance

Degree to which a filter circuit or mechanical resonator emphasises a particular frequency. (See "Q".)

reverberation

Natural effect created when a sound bounces off nearby solid surfaces in an enclosed space.

sampling

Process of digitising a signal by measuring successive points along an analogue waveform. A sampler is a type of synthesiser that uses recorded sounds as its source. These recorded sounds are in turn called samples.

separation

Keeping sounds separate. In a studio where several musicians are playing together, each player’s mic will tend to pick up some sound from the other instruments in the room. The lower the level of this unwanted spill, the better the separation.

(MIDI) sequencer

Device for recording, editing and playing back MIDI music compositions. May be computer based or a piece of stand-alone hardware.

short circuit

Term used to describe an accidental signal path between two points in a circuit that are not normally connected.

signal

Any meaningful electrical information passing through an electronic system.

signal-to-noise ratio

Ratio of the maximum signal level to the circuit or tape noise, measured in decibels.

SMPTE

Time code used in film soundtrack work, music and recording.

S/PDIF

Digital standard interfacing system for transferring stereo audio data from one piece of equipment to another. The connection format is RCA phono connectors, although specialised digital cable should be used.

spill

Term used to describe unwanted sound leakage into microphones. For example, in a live situation, the drums and guitar amps will invariably spill into the vocal mics.

SPL

Sound-Pressure Level.

stereo

Term used to describe a two-channel system feeding left and right loudspeakers in an attempt to recreate the way in which we perceive sounds coming from different directions.

sync

Abbreviation of synchronisation, the process of making two or more time-dependent devices start together and run at exactly the same speed.

synthesiser

Musical instrument able to generate a wide variety of musically pitched sounds by electronic means.

track

Originally a tape-based term, track relates to the physical section of tape used to store individual parts of a recording. Tracks are parallel to each other and are recorded and played back using a multisection head so as to keep them separate until they are mixed. The term track has now been carried over into digital tape and hard-disk recording systems, although the term is mainly conceptual in this context insomuch as the data is not recorded on individual, parallel tracks.

transpose

To change the musical key or pitch of a note or sequence of notes.

unbalanced

Term used to describe a conventional audio connection with a single signal conductor surrounded by a screen.

unison

Musical term relating to two or more instruments or sounds playing the same notes at the same time.

valve

Active circuit device involving a heated cathode, a grid and an anode sealed in an evacuated glass tube. Also known as a tube.

VCA

Voltage-Controlled Amplifier.

VCF

Voltage-Controlled Filter.

VCO

Voltage-Controlled Oscillator.

velocity

Measure of how hard a note is played on a MIDI keyboard.

vibrato

Musical, low-frequency modulation of pitch.

volt

Unit of electrical potential energy.

watt

Unit of electrical power.

wah-wah

Filter sweep effect originally developed for use in guitar pedals.

waveform

Visual representation of an electrical signal.

white noise

Random electrical signal with equal average energy per Hertz.

XLR

Type of pro-audio connector commonly used to carry balanced audio signals, including those produced by microphones.

zero-crossing point

Point at which an AC waveform switches from positive to negative voltage, and vice versa.

basic MIDI jargon

channel

Conduit over which MIDI information can be sent.

controller

MIDI message sent in response to the movement of certain physical controls on the master keyboard or some other MIDI instrument.

merge box

Device for combining two streams of MIDI data.

MIDI

Musical Instrument Digital Interface.

mode

MIDI information can be interpreted by the receiving MIDI instrument in a number of ways, the most common being polyphonically on a single MIDI channel (Poly/Omni Off mode). Omni mode enables a MIDI instrument to play all incoming data, regardless of channel.

module

Sound-generating device with no integral keyboard.

MTC

Abbreviation of MIDI time code, the MIDI equivalent of SMPTE time code which uses the same time and frame parameters. Unlike SMPTE, however, MTC is incorporated into the MIDI data stream and can be passed down the same MIDI cable as other MIDI data.

multitimbral module

MIDI sound source capable of producing several different sounds at the same time and controlled on different MIDI channels.

note on

MIDI message sent when a note is played (ie a key is pressed).

note off

Message sent when a key is released.

program change

Type of MIDI message used to change sound patches on a remote module or the effects patch on a MIDI effects unit.

sync

System of synchronising two or more pieces of compatible equipment using MIDI clock, a tempo-related timing signal of 96 pulses per quarter note.

BACK TO TOP
ACKNOWLEDGEMENTS

CONTENTS PAGE


Audigy User Guide

Acknowledgements

The Author

Paul White was born in Yorkshire. Leaving school to train as an electronics engineer with the Ministry of Aviation, he has been on the scene since home recording became popular, and has always been a performing musician, first on drums then on electric guitar. Paul left the commercial electronics sector to become a technical author and he is currently editor of Sound On Sound magazine, Europe's biggest and most respected music technology publication. He is also the author of many books for Sanctuary Publishing, including Home Recording Made Easy, MIDI For The Technophobe, Music Technology - A Survivor's Guide, Creative Recording I & II, Desktop Digital Studio and Recording And Production Techniques. He is a member of the Audio Engineering Society.

Additional thanks:

Technical Contributions: Staff at Creative Labs and E-MU especially Mike Guzewicz, George Thorn, Hugh Doolan and Andrew Longhurst.

Initial concept: Franco DeBonis and Neal Leggett.

Formatting and design: Stuart Hunt/Patrick Wheeler.

Technical Editor: Darragh O'Toole.

Staff at Sanctuary Publishing


Chapter 1
introduction to Sound Blaster Audigy
computers and music
MIDI
adding audio
MIDI/audio integration
the user interface
the audio interface
audio mixing
effect plug-ins
VST
virtual instruments
virtual samplers
sample loops
computers and composition
practicalities
the upgrade path
the rest of the studio
your task…
be prepared

contents

Chapter 3
MIDI sequencers
the strength of the sequencer
rechannelising
MIDI sequencer set-up
MIDI isn’t audio
click track
quantisation
tracks and MIDI channels
cut-and-paste editing
track information
destructive editing
sequencing a drum machine
the MIDI interface
multiport MIDI interfaces
the sequencer paradigm
saving your songs
help!

Chapter 2
introducing MIDI
the virtual band
MIDI sequencing
MIDI wiring
the MIDI note
sending MIDI note data
MIDI sockets
the synthesiser module
MIDI channels
a word about omni
multitimbral modules
MIDI thru boxes
MIDI programs
MIDI controllers
other MIDI controllers
controller listing
MIDI modes
non-registered parameters
system-exclusive messages
aftertouch
sound banks
assignable controls
MIDI and timing
start, stop and continue
song position pointers
MIDI machine control
MIDI isn’t magic
MIDI song select
tune request
sysex dumping
MIDI compatibility
more advanced sync options
MIDI merge
General MIDI
polyphony and multitimbrality
basic GM definitions
GM voice table
GM drum map
the GS format

Chapter 4
audio and sequencing
sampling theory
sample rates
high sample rates
why more bits, anyway?
dithering
digital connections
clock sync
word clock
sample-rate conversion
the sequencer revolution
audio and hard drives
how many tracks?
random access
the virtual mixer
VST plug-ins
monitoring and latency
mixer layout
waveform editing
time and pitch manipulation
audio in arrangements
audio and clocks
audio loops
recording levels

Chapter 5
audio mixers
the building blocks
mic and line levels
channel gain
mixer channels
stereo mixers
auxiliaries
pre-fade send
post-fade send
insert points
multitrack mixers
tracks or channels?
groups

Chapter 6
effects and processors
using virtual effects and processors
types of plug-ins
what are effects for?
reverberation
delay
multi-tapped delay
modulation effects
chorus and ADT
flanging
phasing
vibrato
pitch shifting
processors
compressors/limiters
gates
de-essers
equalisers
exciters
autopanners
pitch correction
summary

Chapter 7
synthesis methods
additive synthesis
analogue synthesis
subtractive synthesis
sample-based synthesis
more about Sound Blaster Audigy
FM synthesis
physical modelling
wavetable synthesis
soundcards
software synthesis
samplers
how samplers are used
synthesiser oscillators
synthesiser envelopes
filtering
polyphony
onboard effects
Sound Blaster Audigy structure
performance control
Sound Blaster Audigy real-time control
notes
synth editors
alternative MIDI instruments
beyond the MIDI guitar
MIDI drums
Chapter 8
Sound Blaster Audigy and its music software
ASIO
ASIO and surround-sound
the Creative Surround Mixer
EAX ADVANCED HD
MIDI and audio mixing
Cubasis VST CE
MIDI as a compositional tool
sequencer set-up
click track
tracks and channels
rechannelising
cut, copy and paste
quantisation
further editing
beyond notes
patches
playback
importing MIDI files
audio sequencing
software plug-ins
VST instruments
samplers
sequencer familiarisation
the arrange page
program selection
tempo
drumming made easy
looping
the next track
moving your music
transposing
key edit
MIDI list edit
score edit
more features
practical MIDI automation
Cubasis VST CE user tips
MIDI troubleshooting
the virtual mixer
stereo editors
ReCycle
Chapter 9
the desktop Sound Blaster Audigy studio
the all-digital myth
mixer benefits
recording pre-amps
Sound Blaster Audigy and midi
expansion options
latency and monitoring
technical issues
about digital recording
hard-disk considerations
the practical desktop studio
studio layout
the components
the monitoring system
loudspeakers
the speaker/room relationship
acoustic treatment
digital cables
last but not least
Chapter 10
recording with microphones
dynamic mics
capacitor mics
back-electret mics
typical uses
cardioid mics
the proximity effect
presence
choosing the right microphone
direct injection
using microphones
recording vocals
noise and spil
multiple mics
direct-to-stereo recording
drum miking
guitar amps
Chapter 11
getting creative
logistics
preparation
getting started
handling audio
adding VST effects
the science of mixing
always back up
before mixing
setting a balance
vocal compression
panning
creating depth in your mix
EQ as a tool
bass guitars
electric guitars
vocals
step-by-step mixing
mastering
mastering EQ
mastering dynamics
overall compression
editing tasks
advanced editing
Internet audio